Hide Table of Contents

SolidWorks eDrawings Publishers

SolidWorks eDrawings Publishers are plug-ins for CAD applications that enable you to create eDrawings files. You can view the eDrawings files with the SolidWorks eDrawings Viewer, and you can mark them up with SolidWorks eDrawings Professional.

See the SolidWorks eDrawings functionality matrix for a list of functions covered by the various publishers.

Publishers are available for:

SolidWorks eDrawings Publisher for AutoCAD

Create eDrawings drawing (*.edrw) files from AutoCAD drawing files.

Installation

NOTE: You must install AutoCAD before installing eDrawings.

The SolidWorks eDrawings Publisher for AutoCAD installs automatically when you install eDrawings. When you open AutoCAD, the eDrawings Publisher for AutoCAD opens.

To create eDrawings files using the eDrawings Publisher for AutoCAD:

From an AutoCAD drawing document, do one of the following:

  • Click eDrawings ®.

  • Click eDrawings, Publish.

  • Enter edw on the command line.

The new eDrawings file is displayed in the eDrawings Viewer.

NOTES:

  • The new eDrawings file is not saved automatically; you must save it using the eDrawings Viewer.

  • Certain toolbar and menu items in the eDrawings Viewer, related to 3D data, are disabled because eDrawings supports only AutoCAD 2D data.

  • The eDrawings application can open DXF and DWG files. See Opening Files for more information.

Back to Top.

SolidWorks eDrawings Publisher for Autodesk Inventor Series

Create eDrawings part (*.eprt), assembly (*.easm), and drawing (*.edrw) files from Inventor part, assembly, and drawing files and from Mechanical Desktop (MDT) files. Geometric Software Solutions developed and distributes the SolidWorks eDrawings Publisher for Autodesk Inventor Series. See also eDrawings Publisher for AutoCAD above.

Installation

  1. Download the eDrawings Publisher for Autodesk Inventor Series from http://www.eDrawingsViewer.com/download.

  2. Double-click the downloaded executable file and follow the instructions to install the eDrawings Publisher for Autodesk Inventor Series.

The eDrawings Publisher for Autodesk Inventor Series appears as the eDrawings menu in the Inventor and MDT applications.

NOTES:

  • In the Destination Folder installation page, select the top level Inventor or MDT folder (where Inventor or MDT is installed) for the destination folder.

  • Enter your SolidWorks eDrawings Professional license key, if you have one, to install eDrawings Professional for Autodesk Inventor Series. If not, click Next to install the complimentary eDrawings Publisher for Autodesk Inventor Series.

To create eDrawings files using the eDrawings Viewer for Autodesk Inventor Series:

  1. Open the Inventor or MDT file.

  2. Click eDrawings and select from the following:

  • Publish. Opens the eDrawings Viewer with the eDrawings file displayed.

    1. Click File, Save.

    2. Set the options (see Options below).

    3. Enter the file name.

    4. Click OK to save the eDrawings file.

  • Options. Displays the Options dialog box.

    1. Select from these options which vary depending on the file type:

    • Export shaded data with drawings (drawings only). Saves the shaded data from the drawing document in the published eDrawings file.

    • Alert on free publishing. Enables a pop-up dialog that appears if you publish an eDrawings file but do not have a SolidWorks eDrawings Professional license from the pool of available network licenses.

    • Allow recipient to measure. Enables measurement of this model by other SolidWorks eDrawings Professional users. If the file is review-enabled, then anyone can measure it. If you do not enable this option, measurement is disabled and no one can measure the model.

    • Allow recipient to export STL (parts and assemblies only). Allows recipients of the eDrawings file to save it as an STL file from the eDrawings Viewer.

  1. Click OK to save the options, or Reset to set the options to the original settings.

  • Save. Displays the eDrawings Save dialog box.

    1. Set the Options (see the Options section above).

    2. To protect the eDrawings file with a password (Inventor only), select Password required to open document, then enter and confirm the password.

    3. Enter the file name.

    4. Click OK to save the eDrawings file.

You can then view the eDrawings file using the eDrawings Viewer.

  • Batch Publish (Inventor only). Converts multiple CAD files to eDrawings files. Displays the SolidWorks eDrawings Batch Publisher dialog box.

    1. Select the files to publish. You can also select folders.

    2. Specify the location for saving the eDrawings files.

    3. Set export Options.

    4. Click Start.

  • Help. Displays the eDrawings online help.

  • About. Displays information about the eDrawings for Autodesk Inventor Series applications, including the version.

Back to Top.

SolidWorks eDrawings Professional for CATIA V5

Create eDrawings part (*.eprt), assembly (*.easm), and drawing (*.edrw) files from CATIA V5 part, assembly, and drawing files. Geometric Software Solutions developed and distributes SolidWorks eDrawings Professional for CATIA V5.

Installation

  1. Download SoldWorks eDrawings Professional for CATIA V5 from http://www.eDrawingsViewer.com/download.

  2. Double-click the downloaded executable file and follow the instructions to install SolidWorks eDrawings Professional for CATIA V5.

SolidWorks eDrawings Professional for CATIA V5 appears as the Tools, eDrawings menu in the CATIA V5 application.

NOTES:

  • In the Destination Folder installation page, select the top level CATIA V5 folder (where CATIA V5 is installed) for the destination folder.

  • Enter your SolidWorks eDrawings Professional license key to install SolidWorks eDrawings Professional for CATIA V5.

To create eDrawings files using SolidWorks eDrawings Professional for CATIA V5:

  1. Open the CATIA V5 file.

  2. Click Tools, eDrawings and select from the options below.

NOTE: The eDrawings toolbar is also available with these options.

  • Publish. Opens the eDrawings Viewer with the eDrawings file displayed. The file currently open in CATIA is exported using the options set in the Options dialog box (see Options below).

  • Options. Displays the Options dialog box.

    1. Select from these options which vary depending on the file type:

    • Export shaded data with drawings (drawings only). Saves the shaded data from the drawing document in the published eDrawings file.

    • Tessellation Quality. Controls the amount of tessellation. Lower settings have smaller file size but are less accurate, while higher settings are more accurate but have larger file size.

    • Allow recipient to measure. Enables measurement of this model by other SolidWorks eDrawings Professional users. If the file is review-enabled, then anyone can measure it. If you do not enable this option, measurement is disabled and no one can measure the model.

    • Allow recipient to export STL (parts and assemblies only). Allows recipients of the eDrawings file to save it as an STL file from the eDrawings Viewer.

    • Export mass properties (parts and assemblies only). Allows the mass properties of the entire model to be exported.

  1. Click OK to save the options, or Reset to set the options to the original settings.

  • Save. Displays the eDrawings Save dialog box.

    1. Set the Options (see the Options section above).

    2. To protect the eDrawings file with a password, select Password required to open document, then enter and confirm the password.

    3. Enter the file name.

    4. Click OK to save the eDrawings file.

You can then view the eDrawings file using the eDrawings Viewer.

  • Help. Displays the eDrawings online help.

  • About. Displays information about SolidWorks eDrawings Professional for CATIA V5 application, including the version.

  • Batch Publish. Converts multiple CAD files to eDrawings files. Displays the eDrawings Batch Publisher dialog box.

    1. Select the files to publish. You can also select folders.

    2. Specify the location for saving the eDrawings files.

    3. Set export Options.

    4. Click Start.

Back to Top.

SolidWorks eDrawings Publisher for Google SketchUp

Create eDrawings files from Google SketchUp files. Geometric Software Solutions developed and distributes the SolidWorks eDrawings Publisher for Google SketchUp.

Installation

  1. Download the SolidWorks eDrawings Publisher for Google SketchUp from www.eDrawingsViewer.com/download.

  2. Double-click the downloaded executable file and follow the instructions to install the eDrawings Publisher for Google SketchUp.

The eDrawings Publisher for Google SketchUp appears as a menu item eDrawings under the Plugins menu.

To create eDrawings files using the eDrawings Publisher for Google SketchUp:

  1. Open a file in Google Sketchup.

  2. Click Plugins, eDrawings, Publish.

  3. In the eDrawings Viewer, with the eDrawings file displayed, click File, Save.

  4. In the Save dialog box, select or clear:

  • Allow recipient to measure. Enables measurement of this model by other SolidWorks eDrawings Professional users. If the file is review-enabled, then anyone can measure it. If you do not enable this option, measurement is disabled and no one can measure the model.

  • Allow recipient to export STL (parts and assemblies only). Allows recipients of the eDrawings file to save it as an STL file from the eDrawings Viewer.

  1. Enter the file name, then click OK.

Back to Top.

SolidWorks eDrawings Publisher for IntelliCAD

Create eDrawings drawing (*.edrw) files from IntelliCAD drawing files.

Installation

Any IntelliCAD-like product needs to be run once prior to installing the publisher.

The SolidWorks eDrawings Publisher for IntelliCAD installs automatically when you install eDrawings. When you open IntelliCAD, the eDrawings Publisher for IntelliCAD opens.

To create eDrawings files using the eDrawings Publisher for IntelliCAD:

From an IntelliCAD drawing document, do one of the following:

  • Click eDrawings ®

  • Click Menu, eDrawings, Publish

  • Type epublish on the command line

The new eDrawings file is displayed in the eDrawings Viewer.

NOTES:

  • The new eDrawings file is not saved automatically; you must save it using the eDrawings Viewer.

  • Certain toolbar and menu items in the eDrawings Viewer, related to 3D data, are disabled because eDrawings supports only IntelliCAD 2D data.

  • The eDrawings application can open DXF and DWG files. See Opening Files for more information.

Back to Top.

eDrawings Publisher for Kompas

Create eDrawings part (*.eprt), assembly ( *.easm) and drawing (*.edrw) documents from KOMPAS-3D V8 Plus (Kompas) part, assembly, and drawing files. Geometric Software Solutions developed and distributes the SolidWorks eDrawings Publisher for KOMPAS-3D V8 Plus (eDrawings Publisher for Kompas).

Installation

The Kompas application contains the SolidWorks eDrawings Publisher for Kompas.

The eDrawings Publisher for Kompas appears as the *.eprt, *.easm, and *.edrw extensions in File, Save As.

To create eDrawings files:

Save the files as eDrawings files using the eDrawings Publisher for Kompas.

Using eDrawings for Kompas:

  1. Open the Kompas file.

  2. Click File, Save As and select the file type as *.eprt, *.easm, or *.edrw.

  3. Enter the filename.

  4. Click Options, set the following options, then click OK.

  • Enable measure. Enables measurement of this model by other eDrawings users.

  • Allow STL export (parts and assemblies only). Allows recipients of the eDrawings file to save it as an STL file from the eDrawings Viewer.

  • Export shaded data (drawings only).  Saves the shaded data from the drawing document in the published eDrawings file.

  • Launch eDrawings Viewer. Enables the publisher to open the published eDrawings file immediately after conversion. If not enabled, the file is saved in the specified location.

  1. Click Save.

Back to Top.

SolidWorks eDrawings Professional for NX/Unigraphics

Create eDrawings part (*.eprt), assembly (*.easm), and drawing (*.edrw) files from NX/Unigraphics® part, assembly, and drawing files. Geometric Software Solutions developed and distributes SolidWorks eDrawings Professional for NX/Unigraphics.

Installation

  1. Download SolidWorks eDrawings Professional for NX/Unigraphics from http://www.eDrawingsViewer.com/download.

  2. Double-click the downloaded executable file and follow the instructions to install SolidWorks eDrawings Professional for NX/Unigraphics.

eDrawings Professional for NX/Unigraphics appears as the File>Export>eDrawings menu in the NX/Unigraphics application.

NOTES:

  • In the Destination Folder installation page, select the top level NX/Unigraphics folder (where NX/Unigraphics is installed) for the destination folder.

  • Enter your SolidWorks eDrawings Professional license key to install SolidWorks eDrawings Professional for NX/Unigraphics.

To create eDrawings files using SolidWorks eDrawings Professional for NX/Unigraphics:

  1. Open the NX/Unigraphics file.

  2. Click File, Export, eDrawings and select one of the following:

  • Publish. Opens the eDrawings Viewer with the eDrawings file displayed.

    1. Click File, Save.

    2. Set the options (see Options below).

    3. Enter the file name.

    4. Click OK to save the eDrawings file.

  • Options. Displays the Options dialog box.

    1. Select from these options which vary depending on the file type:

    • Export shaded data with drawings (drawings only).  Saves the shaded data from the drawing document in the published eDrawings file.

    • Tessellation Quality. Controls the amount of tessellation. Lower settings have smaller file size but are less accurate, while higher settings are more accurate but have larger file size.

    • Allow recipient to measure. Enables measurement of this model by other SolidWorks eDrawings Professional users. If the file is review-enabled, then anyone can measure it. If you do not enable this option, measurement is disabled and no one can measure the model.

    • Allow recipient to export STL (parts and assemblies only). Allows recipients of the eDrawings file to save it as an STL file from the eDrawings Viewer.

  1. Click OK to save the options, or Reset to set the options to the original settings.

  • Save. Displays the eDrawings Save dialog box.

    1. Set the Options (see the Options section above).

    2. To protect the eDrawings file with a password, select Save file with Password Protection, then enter and confirm the password.

    3. Enter the file name.

    4. Click OK to save the eDrawings file.

You can then view the eDrawings file using the eDrawings Viewer.

  • Help. Displays the eDrawings online help.

  • About. Displays information about the eDrawings for NX/Unigraphics application, including the version.

  • Batch Publish. Converts multiple CAD files to eDrawings files. Displays the eDrawings Batch Publisher dialog box.

    1. Select the files to publish. You can also select folders.

    2. Specify the location for saving the eDrawings files.

    3. Set export Options.

    4. Click Start.

Back to Top.

SolidWorks eDrawings Publisher for OneSpace Designer Modeling

Create eDrawings part/assembly (both as *.easm) and drawing (*.edrw) files from OneSpace Designer Modeling (OSDM) part, assembly, and drawing files. Geometric Software Solutions developed and distributes the SolidWorks eDrawings Publisher for OneSpace Designer (eDrawings Publisher for OSDM).

Installation

The OSDM application contains the SolidWorks eDrawings Publisher for OSDM.

The eDrawings Publisher for OSDM appears as the Collaborate>Publish eDrawings menu in the OSDM application.

To create eDrawings files:

Use the eDrawings Publisher for OSDM or save the file as an eDrawings file.

Using eDrawings for OSDM

  1. Open the OSDM file.

  2. Click Publish eDrawings (eDrawings toolbar) or Collaborate, Publish eDrawings.

  3. Under Object:

    1. Select the object to publish.

    2. Select or clear Professional. Select if you have a SolidWorks eDrawings Professional for OSDM license and want the eDrawings file to be review-enabled. Clear if you have the free eDrawings Viewer for OSDM.

  4. Under Options, set these options:

    • Export shaded data (drawings only).  Saves the shaded data from the drawing document in the published eDrawings file.

    • Alert on free publishing. Enables a pop-up dialog that appears if you publish an eDrawings file but do not have a SolidWorks eDrawings Professional license from the pool of available network licenses.

Using Save as eDrawings File

  1. Click File, Save.

  2. Select the items to save using one of these methods:

You may need to first click Select in the browser.

  • Select the part or work plane in the graphics area.

  • Select the objects from the browser.

  • Use the Select tool.

  • Type the object name in the input line surrounded by asterisks (for example, *face*).

  1. Enter a file name in the browser.

  2. Set these options in the dialog box:

    • Professional. Select if you have a SolidWorks eDrawings Professional for OSDM license and want the eDrawings file to be review-enabled. Clear if you have the free SolidWorks eDrawings Viewer for OSDM.

    • Export shaded data (drawings only).  Saves the shaded data from the drawing document in the published eDrawings file.

    • Alert on free publishing. Enables a pop-up dialog that appears if you publish an eDrawings file but do not have a SolidWorks eDrawings Professional license from the pool of available network licenses.

    • Enable measure (Professional only). Enables measurement of this model by other eDrawings Professional users. If the file is review-enabled, then anyone can measure it. If you do not enable this option, measurement is disabled and no one can measure the model.

    • Allow STL export (parts and assemblies only). Allows recipients of the eDrawings file to save it as an STL file from the eDrawings Viewer.

Back to Top.

SolidWorks eDrawings Publisher for Pro/ENGINEER

Create eDrawings part (*.eprt), assembly (*.easm), and drawing (*.edrw) files from Pro/ENGINEER part, assembly, and drawing files. Geometric Software Solutions developed and distributes the SolidWorks eDrawings Publisher for Pro/ENGINEER.

You can also open Pro/ENGINEER models (parts and assemblies) in eDrawings.

Installation

  1. Download the SolidWorks eDrawings Publisher for Pro/ENGINEER from http://www.eDrawingsViewer.com/download.

  2. Double-click the downloaded executable file and follow the instructions to install the eDrawings Publisher for Pro/ENGINEER.

The eDrawings Publisher for Pro/ENGINEER appears as the eDrawings menu in the Pro/ENGINEER application.

NOTES:

  • In the Destination Folder installation page, select the top level Pro/ENGINEER folder (where Pro/ENGINEER is installed) for the destination folder.

  • Enter your eDrawings Professional license key, if you have one, to install SolidWorks eDrawings Professional for Pro/ENGINEER. If not, click Next to install the complimentary eDrawings Publisher for Pro/ENGINEER.

To create eDrawings files using the eDrawings Publisher for Pro/ENGINEER:

  1. Open the Pro/ENGINEER file.

  2. Click eDrawings and select one of the following:

  • Publish. Opens the eDrawings Viewer with the eDrawings file displayed.

    1. Click File, Save.

    2. Set the options (see Options below).

    3. Enter the file name.

    4. Click OK to save the eDrawings file.

  • Options. Displays the Options dialog box.

    1. Select from these options which vary depending on the file type:

    • Export shaded data with drawings (drawings only).  Saves the shaded data from the drawing document in the published eDrawings file.

    • Tessellation Quality. Controls the amount of tessellation. Lower settings have smaller file size but are less accurate, while higher settings are more accurate but have larger file size.

    • Allow recipient to measure. Enables measurement of this model by other SolidWorks eDrawings Professional users. If the file is review-enabled, then anyone can measure it. If you do not enable this option, measurement is disabled and no one can measure the model.

    • Allow recipient to export STL (parts and assemblies only). Allows recipients of the eDrawings file to save it as an STL file from the eDrawings Viewer.

        • Alert on free publishing. Enables a pop-up dialog that appears if you publish an eDrawings file but do not have a SolidWorks eDrawings Professional license from the pool of available network licenses.

  1. Click OK to save the options, or Reset to set the options to the original settings.

  1. Save. Displays the eDrawings Save dialog box.

    1. Set the Options (see the Options section above).

    2. To protect the eDrawings file with a password, select Password required to open the document, then enter and confirm the password.

    3. Enter the file name.

    4. Click OK to save the eDrawings file.

You can then view the eDrawings file using the eDrawings Viewer.

  • Help. Displays the eDrawings online help.

  • About. Displays information about the eDrawings for Pro/ENGINEER application, including the version.

  • Batch Publish. Converts multiple CAD files to eDrawings files. Displays the eDrawings Batch Publisher dialog box.

    1. Select the files to publish. You can also select folders.

    2. Specify the location for saving the eDrawings files.

    3. Set export Options.

    4. Click Start.

Back to Top.

SolidWorks eDrawings Publisher for  Solid Edge

Create eDrawings part (*.eprt), assembly (*.easm), and drawing (*.edrw) files from Solid Edge part, sheet metal, assembly, and draft files. Geometric Software Solutions developed and distributes the SolidWorks eDrawings Publisher for Solid Edge.

Installation

  1. Download the eDrawings Publisher for Solid Edge from http://www.eDrawingsViewer.com/download.

  2. Double-click the downloaded executable file and follow the instructions to install the eDrawings Publisher for Solid Edge.

The eDrawings Publisher for Solid Edge appears as the eDrawings toolbar, as well as in the Tools, Add-Ins menu, in the Solid Edge application.

NOTES:

  • Enter your eDrawings Professional license key, if you have one, to install SolidWorks eDrawings Professional for Solid Edge. If not, click Next to install the complimentary SolidWorks eDrawings Publisher for Solid Edge.

To create eDrawings files using the eDrawings Publisher for Solid Edge:

  1. Open the Solid Edge file.

  2. Click Tools, Add-Inns, eDrawings and select one of the following:

  • Publish. Opens the eDrawings Viewer with the eDrawings file displayed.

    1. Click File, Save.

    2. Set the options (see Options below).

    3. Enter the file name.

    4. Click OK to save the eDrawings file.

  • Save. Displays the eDrawings Save dialog box.

    1. Set the Options (see the Options section above).

    2. To protect the eDrawings file with a password, select Password required to open the document, then enter and confirm the password.

    3. Enter the file name.

    4. Click OK to save the eDrawings file.

  • Options. Displays the Options dialog box.

    1. Select from these options which vary depending on the file type:

    • Export shaded data with drawings (drawings only).  Saves the shaded data from the drawing document in the published eDrawings file.

    • Alert on free publishing. Enables a pop-up dialog that appears if you publish an eDrawings file but do not have a SolidWorks eDrawings Professional license from the pool of available network licenses.

    • Allow recipient to measure. Enables measurement of this model by other SolidWorks eDrawings Professional users. If the file is review-enabled, then anyone can measure it. If you do not enable this option, measurement is disabled and no one can measure the model.

    • Allow recipient to export STL (parts and assemblies only). Allows recipients of the eDrawings file to save it as an STL file from the eDrawings Viewer.

      1. Click OK to save the options, or Reset to set the options to the original settings.

  • Help. Displays the eDrawings online help.

  • About. Displays information about the eDrawings for Solid Edge application, including the version.

  • Batch Publish. Converts multiple CAD files to eDrawings files. Displays the eDrawings Batch Publisher dialog box.

    1. Select the files to publish. You can also select folders.

    2. Specify the location for saving the eDrawings files.

    3. Set export Options.

    4. Click Start.

Back to Top.

eDrawings Publisher for SolidWorks

Create eDrawings part (*.eprt), assembly (*.easm), and drawing (*.edrw) files from SolidWorks part, assembly, and drawing files.

Installation

The eDrawings publisher for SolidWorks is installed with SolidWorks.

To create eDrawings files using the eDrawings Publisher for SolidWorks:

  1. Open the SolidWorks file.

  2. Click File, Publish eDrawings File ( in the Save flyout toolbar).

The eDrawings Viewer appears with the published file displayed.

  1. Click Save or File, Save.

  2. In the Save As dialog box, select from the options, which vary depending on the file type.

  1. Click Save to save the eDrawings file.

An alternative method is to click File, Save As in SolidWorks and save the document as an eDrawings document.

Back to Top.



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   SolidWorks eDrawings Publishers
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: eDrawings 2010 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.