Welcome
Collapse Getting StartedGetting Started
Overview
Expand Types of SolidWorks API ApplicationsTypes of SolidWorks API Applications
Expand SolidWorks API Object Model and Class HierarchySolidWorks API Object Model and Class Hierarchy
Collapse Programming with the SolidWorks APIProgramming with the SolidWorks API
Add-in Toolbars
API Dependent on SolidWorks Being Visible
Attributes Imported from ACIS SAT Files
Bitmasks
Block Definitions and Block Instances
Bodies in Body Folders
BOOL and VARIANT_BOOL
Bounding Box and Note Text
COM vs. Dispatch
CommandManager and CommandGroups
Components, Configurations, and Suppression States
Compound Note
ComVisibleAttribute in VSTA macros
Controls, Visual Basic 6.0, and Windows XP
Expand Double Arrays and Integer PairsDouble Arrays and Integer Pairs
Drawing Views and Model Entities
Early and Late Binding
Expand EventsEvents
Features of Components
Helper Functions
Hole Wizard Features and Objects
IDispatch Object Arrays as Input in .NET
Implementation Guidelines
Import and Export File Options
In-process Methods
Instantiate ActiveX Controls as Tabs
Interface Pointers
Keystrokes and Accelerator Keys
Library Features and Objects
Lightweight Components
Line Attributes for View::GetPolyLinesAndCurves
Line Weights
Expand Macro FeaturesMacro Features
Manipulators
Mass Properties
Expand Multibody PartsMultibody Parts
Option Explicit Statement
Partition Rollback and API Handles
Persistent Reference IDs
Presentation Transforms
Expand PropertyManager PagesPropertyManager Pages
.NET Interop Assemblies
Quick Tips and Bubble ToolTips
Return Values
Expand SafeArraysSafeArrays
Selection Criteria
Selection Lists
Selections that Define Features
Setup Project to Distribute SolidWorks Add-in
Smart Pointers
SolidWorks Objects
SQLite
Suspend Automatic Rebuilds
swdisp.cpp and swdisp.h Files
System Options and Document Properties
Tessellation and Edges
Tracking IDs
Expand Type LibrariesType Libraries
Units
Unmanaged C++ and C++/CLI Code
VBA and SolidWorks x64
Examples and Projects
Expand SolidWorks API HelpSolidWorks API Help
Expand FeatureWorks API HelpFeatureWorks API Help
Expand SolidWorks Document Manager API HelpSolidWorks Document Manager API Help
Expand eDrawings API HelpeDrawings API Help
Expand SolidWorks Routing API HelpSolidWorks Routing API Help
Expand SolidWorks Simulation API HelpSolidWorks Simulation API Help
Expand SolidWorks Utilities API HelpSolidWorks Utilities API Help
Expand SolidWorks Workgroup PDM API HelpSolidWorks Workgroup PDM API Help
Expand PhotoWorks API HelpPhotoWorks API Help
Expand SolidWorks Toolbox Browser API HelpSolidWorks Toolbox Browser API Help
Hide Table of Contents

System Options and Document Properties

You can get and set SolidWorks system options and document properties (also called user preferences) using SolidWorks API enumerators and methods.

To determine which enumerator corresponds with which system option or document property, you can:

  • change a system or document setting in the user interface while recording a macro. Then edit the macro to identify the name and value of the enumerator that corresponds to the setting you just changed and to also identify the name of the method used to change (i.e., set) it. See the System Options and Document Properties Get/Set Methods table in this topic for a list of methods that get and set system-option and document-property enumerators.

    - or -

  • locate the system option or document property in the SolidWorks user interface and click the link that corresponds to it in the System Options and Document Properties Settings and Enumerators table in this topic. Each link opens a topic that contains a:

    • screen shot of the user-interface dialog or menu corresponding to that system option or document property.

    • table containing all of the settings for that system option or document property and the enumerator and methods that get or set it.

Remember to reset any option or property back to its original state after the operation completes. System-option settings persist across SolidWorks sessions.

System Options and Document Properties Settings and Enumerators

NOTE: Unlinked text indicates that an enumerator does not exist for that system option, document property, or menu item. Unlinked text is shown to help you more easily map the text in the table with the text shown on the specified tabs and menus in the user interface.

Tools > Options > System Options tab

Tools > Options > Document Properties tab

Tools > Customize > Mouse Gestures tab

File menu

View menu

Appears on tab:

General

Drawings

 - Display Style

 - Area Hatch/Fill

Colors

Sketch

 - Relations/Snaps

Display/Selection

Performance

Assemblies

External References

Default Templates

File Locations

FeatureManager

Spin Box Increments

View

Backup/Recover

Hole Wizard/Toolbox

File Explorer

Search

Collaboration

Advanced

 

Does not appear on tab:

Miscellaneous

Appears on tab:

Drafting Standard

Annotations

  - Balloons

  - Datums

  - Geometric

     Tolerances

  - Notes

  - Surface

     Finishes

  - Weld Symbols

Dimensions

  - Angle

  - Arc Length

  - Chamfer

  - Diameter

  - Hole Callout

  - Linear

  - Ordinate

  - Radius

Virtual Sharps

Centerlines/Center Marks

DimXpert (for drafting)

Tables

 - Bill of Materials

 - General

 - Hole

 - Revision

 - Title Block

View Labels

 - Auxiliary

 - Detail

 - Section

Detailing

Grid/Snap

Units

Line Font

Line Style

Line Thickness

Colors

Material Properties

Image Quality

Plane Display

Sheet Metal

DimXpert (for parts)

 - Size Dimension

 - Location Dimension

 - Chain Dimension

 - Geometric Tolerance

 - Chamfer Controls

 - Display Options

 

Does not appear on tab:

Miscellaneous

Appears on tab:

 Enable mouse gestures

> New..

> Open...

   > Files of type

      > SolidWorks Files

      > Part

      > Assembly

      > Drawing

      > DXF

      > DWG

      > Adobe Photoshop Files

      > Adobe Illustrator Files

      > Lib Feat Part

      > Template

      > Parasolid

      > IGES

      > STEP

      > ACIS

      > VDAFS

      > VRML or STL

          > Options

             > STL/VRML

      > Catia Graphics

      > ProE Part

      > ProE Assembly

      > UGII

      > Inventor Part

      > Inventor

         Assembly

         > Options

            > General

      > Solid Edge Part

      > Solid Edge Assembly

      > CADKEY

      > Add-Ins

      > IDF

        > Options

           > IDF

      > Rhino

      > All Files

> Close...

> Make Drawing from
Part (parts only)

> Make Drawing
from Assembly
(assemblies only)

> Make Assembly
from Part (parts
only
)

> Make Assembly
from Assembly
(assemblies only)

> Publish eDrawings File

> Save

> Save As...

     > Save as type

        > Part

           (assemblies
     only
)

        > Lib Feat Part

        > Part Templates

        > Form Tool

        > Parasolid or Parasolid

           Binary

           > Options

               > Parasolid

           > Save

               > Export (sheet metal parts only)

        > IGES

           > Options

               > IGES 5.3

        > STEP (AP203 or AP214)

           > Options

               > STEP

        > ACIS

            > Options

                > ACIS

        > VDAFS

            > Options

                > VDA

        > VRML

            > Options

                > VRML

        > STL

           > Options

                > STL

       

       > eDrawings

           > Options

               > EDRW/

                  EPRT/

                  EASM

       > Adobe

          Portable

          Document

          Format

           > Options

                > PDF

       > Universal 3D

       > 3D XML

       > Adobe Photoshop Files

       > Adobe Illustrator Files

       > Microsoft XAML

       > Catia Graphics

       > ProE Part

       > JPEG

       > HCG

       > HOOPS HSF

       > Dwg or Dxf
   (drawings only)

             > Options

                 > DXF/DWG

        > Tif

             > Options

                > TIF/PSD/JPEG

> Save Sheet
Format...
(drawings only)

> Save All

> Reload...

> Find References...

> Derive Component
Part

> Page Setup

     > Print

          > Margins

> Print Preview...

> Print...

> 3D Printing

> Pack and Go...

> Send To...

> Properties...

 

Does not appear on a menu:

    Line Thickness

 

> Redraw

> Screen Capture

> Display

> Modify

> Lights and Cameras

> Hide All Types

> Planes

> Live Section Planes

> Axes

> Temporary Axes

> Origins

> Coordinate Systems

> Curves

> Sketches

> 3D Sketch

> Grid

> All Annotations

> Dimension Names

> Points

> Routing Points

> Lights

> Cameras

> Decals

> Sketch Relations

> Annotation
Link Errors

> Annotation
Link Variables

> Hide/Show Bodies

> Toolbars

> Workspace

> Full Screen

> FeatureManager
Tree Area

> Toolbars

> Task Pane

> Motion Manager

> Status Bar

> Customize Menu

Back to top

System Options and Document Properties Get/Set Methods

System Options

Document Properties

 

Back to top



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   System Options and Document Properties
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: API Help (English only) 2010 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.