Hide Table of Contents

File > Save as > Save as type > eDrawings > Options > EDRW/EPRT/EASM

This topic contains two tables. The information in the table:

  • appearing immediately after the screen capture of the Export Options - File Format - EDRW/EPRT/EASM dialog corresponds to the settings on that dialog.

  • titled Obsolete Enumerators contains enumerators that previously appeared on the Export Options - File Format - EDRW/EPRT/EASM, but are now obsolete and no longer appear on that dialog.

Setting

Get/Set Methods

Return Value
or
<OnFlag>

Comment

Okay to measure this eDrawings file

ISldWorks::GetUserPreferenceToggle(swUserPreferenceToggle_e.swEDrawingsOkayToMeasure)

ISldWorks::SetUserPreferenceToggle(swUserPreferenceToggle_e.swEDrawingsOkayToMeasure, <OnFlag>)

Boolean value

Specifies whether to enable measurement of geometry in eDrawings file

Allow export to STL for parts & assemblies

ISldWorks::GetUserPreferenceToggle(swUserPreferenceToggle_e.swEDrawingsExportSTLOkay)

ISldWorks::SetUserPreferenceToggle(swUserPreferenceToggle_e.swEDrawingsExportSTLOkay, <OnFlag>)

Boolean value

Specifies whether to allow recipients of eDrawings file to save it as STL file from eDrawings Viewer

Save shaded data in drawings

ISldWorks::GetUserPreferenceToggle(swUserPreferenceToggle_e.swEDrawingsSaveShadedDataInDrawings)

ISldWorks::SetUserPreferenceToggle(swUserPreferenceToggle_e.swEDrawingsSaveShadedDataInDrawings, <OnFlag>)

Boolean value

For SolidWorks drawings only; specifies whether to save shaded data from SolidWorks drawing document in published eDrawings file

Save Bill of Materials features to eDrawings file

ISldWorks::GetUserPreferenceToggle(swUserPreferenceToggle_e.swEDrawingsSaveBOM)

ISldWorks::SetUserPreferenceToggle(swUserPreferenceToggle_e.swEDrawingsSaveBOM, <OnFlag>)

Boolean value

Specifies whether to save BOM in eDrawings file

Save Motion Studies to eDrawings file

ISldWorks::GetUserPreferenceToggle(swUserPreferenceToggle_e.swEDrawingsSaveAnimationOkay)

ISldWorks::SetUserPreferenceToggle(swUserPreferenceToggle_e.swEDrawingsSaveAnimationOkay, <OnFlag>)

Boolean value

Specifies whether to save motion studies to eDrawings file

Save each motion study in every configuration

and

Save only in last calculated configuration

ISldWorks::GetUserPreferenceToggle(swUserPreferenceToggle_e.swEDrawingsSaveAnimationToAllConfigs)

ISldWorks::SetUserPreferenceToggle(swUserPreferenceToggle_e.swEDrawingsSaveAnimationToAllConfigs, <OnFlag>)

Boolean value:

  • True: Save each motion study in every configuration

  • False: save each motion study only in the configuration in which it was last calculated

Specifies how to save motion studies to eDrawings files

Recalculate the motion study if the results are out of date

ISldWorks::GetUserPreferenceToggle(swUserPreferenceToggle_e.swEDrawingsSaveAnimationRecalculate)

ISldWorks::SetUserPreferenceToggle(swUserPreferenceToggle_e.swEDrawingsSaveAnimationRecalculate, <OnFlag>)

Boolean value

Specifies whether to recalculate the motion study or use existing results in eDrawings file

 

Obsolete Enumerators

Enumerator

Comment

swEDrawingsCompression

Obsolete

swEdrawingsSaveAsSelectionOption

Obsolete

swEmodelSelectionList

Obsolete

 



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   File > Save as > Save as type > eDrawings > Options > EDRW/EPRT/EASM
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: API Help (English only) 2010 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.