Hide Table of Contents

Extruding Surfaces from a 2D or 3D Face

You can create extruded surfaces from models that include 2D or 3D faces and knit the extruded surfaces to surrounding features.

  1. Click Insert > Surface > Extrude .

  2. Select a face:
    • To extrude from a 3D face, select a 3D face.
    • To extrude from a 2D face, press Alt + select the planar face.

    You can select either a surface or the face of a solid body.
    You can also preselect the 3D faces to extrude before clicking Insert > Surface > Extrude.

  3. Select other faces to define the extrude as required.

    You can select faces that are not touching when you create a surface extrude in a given direction.

  4. Select the end condition.

  5. For 3D faces, select a plane, edge, 2D face, or sketch line to define the direction of extrusion .

    Select a plane to define an extrude direction normal to the plane.

  6. To remove the faces defining the extrude from the model after extruding, click Delete original faces.

    The green area is the face defining the extrude.

    The resulting model is hollow where the face was deleted.

  7. To create a single body from the extrude when faces are deleted, select Knit result .

    Clearing Knit result produces two separate bodies.

  8. Set other options and click .

Related reference


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Extruding Surfaces from a 2D or 3D Face
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2011 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.