Hide Table of Contents

Configuring Toolbox in Enterprise PDM and SolidWorks

Important: If you already use Toolbox, see Migrating Existing Toolbox Libraries.

To configure Enterprise PDM to manage the SolidWorks Toolbox library:

  1. If Toolbox is not already in the Enterprise PDM vault, check it in.
    1. Copy the Toolbox root folder (SolidWorks Data by default) to a vault folder in your local vault view.

      The Toolbox root folder contains the Browser and lang folders.
      Important: In the lang\language folder, copy only the file SWBrowser.mdb. Do not copy the file SWBrowser.ldb if it exists. This is a temporary file that is present only when Toolbox is being configured. Copying it to the vault will prevent future Toolbox configuration changes from being saved.
      You can copy Toolbox to the vault root folder or create a subfolder such as Libraries. You can also rename the Toolbox root folder in the vault, such as renaming SolidWorks Data to Toolbox.

    2. Right-click the Toolbox vault folder and select Check in.

      Enterprise PDM reads file references and then displays the Check In dialog box.

    3. In the Check in dialog box, ensure that all Check In check boxes are selected and click the Check in button.
  2. From the Enterprise PDM Administration tool, configure Toolbox:
    1. Log in as a user with Can update Toolbox settings administrative permission.
    2. Expand the Toolbox vault and double-click Toolbox.
    3. In the Toolbox dialog box, select Manage SolidWorks Toolbox in the vault.

      This option enables complete Toolbox integration (recommended). Clear this option to use partial Toolbox integration.

    4. For When accessing Toolbox, use permissions from, select the Enterprise PDM user whose permissions are used by everyone accessing the Toolbox, or select <Logged in User> to manage Toolbox permissions individually.

      Use a combination of this setting and individual user permissions on the Toolbox folder to control access to Toolbox parts.

      These permissions apply only to the use of the Toolbox task pane functionality. Users who configure Toolbox in SolidWorks must have individual user permissions for the Toolbox folder that allow them to read, check out, and add files.

      See the description of this option in Toolbox Dialog Box.

    5. For Toolbox root folder path, type or browse to the Toolbox vault folder.
    6. Select Search subfolders for Toolbox parts on assembly check-in.
    7. Click OK.
  3. From SolidWorks, configure Toolbox:
    1. Click Tools > Options > Hole Wizard/Toolbox .

      • If you have more than one local vault view and Enterprise PDM cannot identify the Toolbox vault, you are prompted to select the Toolbox vault.
      • If you are not logged into the vault, you are prompted to log in.
      • If the current Hole Wizard and Toolbox folder setting does not match the setting from the Enterprise PDM Administration tool Toolbox dialog box, you are prompted to change the setting. Click Yes.

    2. In the System Options - Hole Wizard/Toolbox dialog box, for Hole Wizard and Toolbox folder, type or browse to the Enterprise PDM vault folder if necessary.

      Enterprise PDM copies the Toolbox database to your local cache.

    3. Click Configure.

      Toolbox must be configured once by an administrator. Each user does not need to configure Toolbox.

    4. From the prompt, click Yes to check out the Toolbox folder.
    5. Use the Toolbox configuration tool to select standards, assign part numbers and perform other configuration tasks.

      See Toolbox Help for details.

    6. Click 3-Define user settings to specify how new sizes of fasteners are saved.
    7. Select one of the following:

      • Create Configurations

        A configuration is added when you use a new fastener size.

      • Create Parts

        A part file is created when you use a new fastener size.

      • Create Parts on Ctrl-Drag

        A part file is create when you CTRL+drag a fastener from the Toolbox

    8. If you select Create Parts or Create Parts on Ctrl-drag, for Create parts in this folder, specify a folder for the created parts in the Enterprise PDM vault.
    9. It is recommended that you password protect Toolbox and set permissions by clicking 4-Permissions.
    10. To set a password, click Create/Change, complete the Create Password dialog box, and click OK.
    11. Set permissions and, under User Settings, select Set the same for all users.
    12. Click Save and Close.

      When you close the configuration tool, Enterprise PDM checks in the Toolbox folder automatically.

    13. Click OK to dismiss the System Options - Hole Wizard/Toolbox dialog box.
  4. Instruct all users to set their SolidWorks Hole Wizard and Toolbox folder (see steps 3a-3b) to the Toolbox vault folder.

    Consider exporting the correct path to users as a registry file using the Copy Settings Wizard ( Start > All Programs > SolidWorks <version> > SolidWorks Tools > Copy Settings Wizard ).

Users can now start using Toolbox components in their designs.



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Configuring Toolbox in Enterprise PDM and SolidWorks
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS PDM 2012 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.