Hide Table of Contents

Creating Reports

You can create detailed reports from file information in a vault.

You must be registered as user in the selected file vault to run reports in it.

  1. Click Tools > Report Generator.
  2. Select a vault in the toolbar's drop-down list.
  3. Under Queries, select the queries to run.

    If you run multiple queries at the same time, the result of each query search appears in a separate table under Result in the same order as used under Queries.

    If Queries is empty, you must add queries. See Adding Queries.

  4. Under Selected files, you can add files to include in the query.

    If the pane is empty, you can run only queries that do not require files as input.

  5. Click Execute Query on the toolbar or Edit > Execute Query .

    If SolidWorks Enterprise PDM requires additional information to create the report, dialog boxes appear.

  6. Supply the required information and click OK in the dialog boxes.

    The report appears under Results.



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Creating Reports
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS PDM 2012 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.