Hide Table of Contents

Assemblies Options

Set assembly options, including options for Large Assembly Mode.

To customize Assemblies options:

  1. Click Options (Standard toolbar) or Tools, Options.

  2. Click Assemblies.

  3. Change the settings, then click OK.

Click Reset to restore factory defaults for all system options or only for options on this page.

Assemblies options

  • Move components by dragging. Select to allow components to move or rotate within their degrees of freedom when you drag them in the graphics area. When cleared, you can still move or rotate a component with the Move with Triad function or the Move Component and Rotate Component tools (Assembly toolbar).

  • Prompt before changing mate alignments on edit. When changes that you make to mates result in errors that the software can fix by flipping mate alignments, the software asks if you want it to make the changes. Otherwise, the software makes the changes automatically (without asking).

  • Save new components to external files. If selected, prompts you to name and save new in-context components to external files. If cleared, saves new in-context components in the assembly file as virtual components.

Large assemblies

The selections you make under Large assemblies apply only when Large Assembly Mode is on. Set options for normal use (with Large Assembly Mode off) as indicated in the option descriptions below.

See Large Assembly Mode for a list of other conditions that are set automatically when Large Assembly Mode is activated.

  • Use Large Assembly Mode to improve performance whenever working with an assembly containing more than this number of components. Set the number of resolved components above which Large Assembly Mode automatically activates when opening or working in an assembly.

  • When Large Assembly Mode is active. Select the following options to improve performance:

    • Do not save auto recover info. Disables automatic save of your model. (Set in Backup Options for normal use.)

    • Hide all planes, axes, sketches, curves, annotations, etc. Selects Hide All Types on the View menu. When this option is selected, you can override it by clearing Hide All Types on the View menu, then selecting to show or hide individual types.

    • Do not display edges in shaded mode. Turns off edges in shaded mode. If the display mode of the assembly is Shaded With Edges , it changes to Shaded . When this option is selected, you can override it by clicking Shaded With Edges (View toolbar).

    • Suspend automatic rebuild. Defers the update of assemblies, so you can make many changes, then rebuild the assembly once. Use this option only when absolutely necessary. Rebuild errors created while this option is active will not become apparent until this option is deactivated (or you do a manual rebuild), which can make it difficult to determine the cause of the errors. When this option is selected, you can override it by right-clicking the assembly name at the top of the FeatureManager design tree and clearing Suspend Automatic Rebuild .

    • Use Large Design Review whenever working with an assembly containing more than this number of components. Sets the threshold above which Large Design Review Mode automatically activates when opening an assembly from the Open dialog box. When the number of resolved components exceeds the specified threshold, Mode is automatically set to Large Design Review, but you can select another mode from the list.

If you have a 32-bit Windows XP Professional operating system and are working with very large assemblies, you might benefit from the /3GB switch. The switch allows you to allocate more RAM for the SolidWorks application by decreasing RAM allocated to the operating system. For details, see Memory Allocation .

 



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Assemblies Options
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2012 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.