Welcome to eDrawings Help
Introduction
Solidworks eDrawings
Key Features of eDrawings
eDrawings Publishers
eDrawings for Macintosh
eDrawings Functionality Matrix
Legal Notices
Installation
eDrawings Basics
eDrawings Professional
Hide Table of Contents Show Table of Contents

SolidWorks eDrawings Publishers

SolidWorks eDrawings Publishers are plug-ins for CAD applications that enable you to create eDrawings files. You can view the eDrawings files with the SolidWorks eDrawings Viewer, and you can mark them up with SolidWorks eDrawings Professional.

See the SolidWorks eDrawings functionality matrix for a list of functions covered by the various publishers.

Publishers are available for:

SolidWorks eDrawings Publisher for AutoCAD

Create eDrawings drawing (*.edrw) files from AutoCAD drawing files.

Installation

NOTE: You must install AutoCAD before installing eDrawings.

The SolidWorks eDrawings Publisher for AutoCAD installs automatically when you install eDrawings. When you open AutoCAD, the eDrawings Publisher for AutoCAD opens.

To create eDrawings files using the eDrawings Publisher for AutoCAD:

From an AutoCAD drawing document, do one of the following:

  • Click eDrawings ®.

  • Click eDrawings, Publish.

  • Enter edw on the command line.

The new eDrawings file is displayed in the eDrawings Viewer.

NOTES:

Back to Top.

SolidWorks eDrawings Publisher for Autodesk Inventor

Create eDrawings part (*.eprt), assembly (*.easm), and drawing (*.edrw) files from Autodesk Inventor part, assembly, and drawing and presentation files. Geometric Limited develops and distributes the SolidWorks eDrawings Publisher for Autodesk Inventor. See also eDrawings Publisher for AutoCAD above.

eDrawings for Autodesk Inventor is a plug-in for Autodesk Inventor that allows users to publish, share, and collaborate representations of 2D and 3D product design data from Autodesk Inventor files as read only eDrawings files.

Installation

  1. Download the eDrawings Publisher for Autodesk Inventor from http://www.eDrawingsViewer.com/download.

  2. Double-click the downloaded executable file and follow the instructions to install the eDrawings Publisher for Autodesk Inventor.

The eDrawings Publisher for Autodesk Inventor appears as the eDrawings menu in Autodesk Inventor.

NOTES:

  • The installer detects and installs on all supported versions of Autodesk Inventor.

  • Enter your SolidWorks eDrawings Professional license key, if you have one, to install eDrawings Professional for Autodesk Inventor. If you do not enter the license key, you will get the complimentary eDrawings Publisher for Autodesk Inventor.

To create eDrawings files using eDrawings for Autodesk Inventor:

  1. Open the part, assembly, drawing, or presentation file in Autodesk Inventor.

  2. Click eDrawings and select from the following:

    NOTE
    : The eDrawings toolbar is also available with these options.

  • Publish. Opens the eDrawings Viewer with the eDrawings file displayed. The file currently open in Autodesk Inventor is exported using the options set in the Options dialog box (see Options below).

  • Options. Displays the Options dialog box.

    1. Select from these options which vary depending on the file type:

    • Export shaded data with drawings (drawings only). Saves the shaded data from the drawing document in the eDrawings file.

    • Export hidden components with assemblies (assemblies only): Exports hidden components in an Autodesk Inventor assembly file in the eDrawings file with the visibility set to hidden.

    • Export multiple configurations and drawings sheets: Exports iPart/iAssembly configurations or multiple drawings sheets in the eDrawings file.

    • Export BOM table: Exports bill of material information from an Autodesk Inventor assembly in the eDrawings file.

    • Alert on free publishing. Enables a pop-up dialog that appears if you publish an eDrawings file but do not have a SolidWorks eDrawings Professional license from the pool of available network licenses.

    • Allow recipient to measure. Enables measurement of this model by other SolidWorks eDrawings Professional users. If the file is review-enabled, then anyone can measure it. If you do not enable this option, measurement is disabled and no one can measure the model.

    • Allow recipient to export STL (parts and assemblies only). Allows recipients of the eDrawings file to save it as an STL file from the eDrawings Viewer.

    • Export mass properties (parts and assemblies only): Allows the model's mass properties to be exported.

  1. Click OK to save the options, or Reset to set the options to the original settings.

  • Save. Displays the eDrawings Save dialog box.

    1. Set the Options (see the Options section above).

    2. To protect the eDrawings file with a password, select Password required to open document, then enter and confirm the password.

    3. Enter the file name.

    4. Click OK to save the eDrawings file.

You can then view the eDrawings file using the eDrawings Viewer.

  • Batch Publish. Converts multiple CAD files to eDrawings files. Displays the Batch Publisher dialog box.

    1. Select the files to publish. You can also select folders.

    2. Specify the location for saving the eDrawings files.

    3. Set export Options.

    4. Click Start.

  • Help. Displays the eDrawings online help.

  • About. Displays information about the eDrawings for Autodesk Inventor applications, including the version.

Back to Top.

SolidWorks eDrawings Professional for CATIA V5

Create eDrawings part (*.eprt), assembly (*.easm), and drawing (*.edrw) files from CATIA V5 part, assembly, and drawing files. Geometric Limited developed and distributes SolidWorks eDrawings Professional for CATIA V5.

eDrawings for CATIA V5 is a plug-in for CATIA V5 that allows users to publish, share, and collaborate accurate representations of 2D and 3D product design data from CATIA V5 files as read-only eDrawings files.

Installation

  1. Download SoldWorks eDrawings Professional for CATIA V5 from http://www.eDrawingsViewer.com/download.

  2. Double-click the downloaded executable file and follow the instructions to install SolidWorks eDrawings Professional for CATIA V5.

SolidWorks eDrawings Professional for CATIA V5 appears as the Tools, eDrawings menu in the CATIA V5 application.

NOTES:

  • The installer detects and installs on all supported versions of CATIA V5.

  • Enter your SolidWorks eDrawings Professional license key to install SolidWorks eDrawings Professional for CATIA V5.

To create eDrawings files using SolidWorks eDrawings Professional for CATIA V5:

  1. Open the CATIA V5 file.

  2. Click Tools, eDrawings and select from the options below.

NOTE: The eDrawings toolbar is also available with these options.

  • Publish. Opens the eDrawings Viewer with the eDrawings file displayed. The file currently open in CATIA is exported using the options set in the Options dialog box (see Options below).

  • Options. Displays the Options dialog box.

    1. Select from these options which vary depending on the file type:

    • Export shaded data with drawings (drawings only). Saves the shaded data from the drawing document in the published eDrawings file.

    • Export hidden components with assemblies (assemblies only): Exports hidden components in a CATIA assembly file in the eDrawings file with the visibility set to hidden.

    • Export mass properties (parts and assemblies only). Allows the mass properties of the entire model to be exported.

    • Tessellation Quality. Controls the amount of tessellation. Lower settings have smaller file size but are less accurate, while higher settings are more accurate but have larger file size.

    • Allow recipient to measure. Enables measurement of this model by other SolidWorks eDrawings Professional users. If the file is review-enabled, then anyone can measure it. If you do not enable this option, measurement is disabled and no one can measure the model.

    • Allow recipient to export STL (parts and assemblies only). Allows recipients of the eDrawings file to save it as an STL file from the eDrawings Viewer.

    • Export BOM table: Exports bill of material information from a CATIA assembly in the eDrawings file.

    • Export FTA: Exports 3D annotations with 3D captures in the eDrawings file.

  1. Click OK to save the options, or Reset to set the options to the original settings.

  • Save. Displays the eDrawings Save dialog box.

    1. Set the Options (see the Options section above).

    2. To protect the eDrawings file with a password, select Password required to open document, then enter and confirm the password.

    3. Enter the file name.

    4. Click OK to save the eDrawings file.

You can then view the eDrawings file using the eDrawings Viewer.

  • Batch Publish (Requires a Batch Scheduler license). Converts multiple CAD files to eDrawings files. Displays the Batch Publisher dialog box.

    1. Select the files to publish. You can also select folders.

    2. Specify the location for saving the eDrawings files.

    3. Set export Options.

    4. Click Start.

  • Help. Displays the eDrawings online help.

  • About. Displays information about SolidWorks eDrawings Professional for CATIA V5 application, including the version.

Back to Top.

SolidWorks eDrawings Publisher for Google SketchUp

Create eDrawings files from Google SketchUp files. Geometric Limited developed and distributes the SolidWorks eDrawings Publisher for Google SketchUp.

eDrawings for Google SketchUp is a plug-in for Google SketchUp that allows users to publish, share, and collaborate accurate representations of Google SketchUp files as read-only eDrawings files.

Installation

  1. Download the SolidWorks eDrawings Publisher for Google SketchUp from www.eDrawingsViewer.com/download.

  2. Double-click the downloaded executable file and follow the instructions to install the eDrawings Publisher for Google SketchUp.

The eDrawings Publisher for Google SketchUp appears as a menu item eDrawings under the Plugins menu.

NOTES:

  • The installer detects and installs on all supported versions of Google SketchUp.

  • Enter your SolidWorks eDrawings Professional license key, if you have one, to install eDrawings Professional for Google SketchUp. If you do not enter the license key, you will get the complimentary eDrawings Publisher for Google SketchUp.

To create eDrawings files using the eDrawings Publisher for Google SketchUp:

  1. Open a file in Google Sketchup.

  2. Click Plugins, eDrawings, Publish.

  3. In the eDrawings Viewer, with the eDrawings file displayed, click File, Save.

  4. In the Save dialog box, select or clear:

  • Allow recipient to measure. Enables measurement of this model by other SolidWorks eDrawings Professional users. If the file is review-enabled, then anyone can measure it. If you do not enable this option, measurement is disabled and no one can measure the model.

  • Allow recipient to export STL (parts and assemblies only). Allows recipients of the eDrawings file to save it as an STL file from the eDrawings Viewer.

  1. Enter the file name, then click OK.

Back to Top.

SolidWorks eDrawings Professional for NX/Unigraphics

Create eDrawings part (*.eprt), assembly (*.easm), and drawing (*.edrw) files from NX/Unigraphics® part, assembly, and drawing files. Geometric Limited developed and distributes SolidWorks eDrawings Professional for NX/Unigraphics.

eDrawings for NX/Unigraphics is a plug-in for NX/Unigraphics that allows users to publish, share, and collaborate accurate representations of 2D and 3D product design data from NX/Unigraphics files as read-only eDrawings files.

Installation

  1. Download SolidWorks eDrawings Professional for NX/Unigraphics from http://www.eDrawingsViewer.com/download.

  2. Double-click the downloaded executable file and follow the instructions to install SolidWorks eDrawings Professional for NX/Unigraphics.

eDrawings Professional for NX/Unigraphics appears as the File>Export>eDrawings menu in the NX/Unigraphics application.

NOTES:

  • The installer detects and installs on all supported versions of NX/Unigraphics.

  • Enter your SolidWorks eDrawings Professional license key, if you have one, to install eDrawings Professional for NX/Unigraphics. If you do not enter the license key, you will get the complimentary eDrawings Publisher for NX/Unigraphics.

To create eDrawings files using SolidWorks eDrawings Professional for NX/Unigraphics:

  1. Open the NX/Unigraphics file.

  2. Click File, Export, eDrawings and select one of the following:

    NOTE
    : The eDrawings toolbar is also available with these options.

  • Publish. Opens the eDrawings Viewer with the eDrawings file displayed. The file currently open in NX/Unigraphics is exported using the options set in the Options dialog box (see Options below).

  • Options. Displays the Options dialog box.

    1. Select from these options which vary depending on the file type:

    • Export shaded data with drawings (drawings only).  Saves the shaded data from the drawing document in the published eDrawings file.

    • Export hidden components with assemblies (assemblies only): Exports hidden components in an NX/Unigraphics assembly file in the eDrawings file with the visibility set to hidden.

    • Export 3D annotations: Exports 3D annotations in the eDrawings file.

    • Export mass properties (parts and assemblies only). Allows the mass properties of the entire model to be exported.

    • Tessellation Quality. Controls the amount of tessellation. Lower settings have smaller file size but are less accurate, while higher settings are more accurate but have larger file size.

    • Allow recipient to measure. Enables measurement of this model by other SolidWorks eDrawings Professional users. If the file is review-enabled, then anyone can measure it. If you do not enable this option, measurement is disabled and no one can measure the model.

    • Allow recipient to export STL (parts and assemblies only). Allows recipients of the eDrawings file to save it as an STL file from the eDrawings Viewer.

    • Export BOM table: Exports bill of material information from an NX assembly in the eDrawings file.

    • Export multiple drawings sheets: Exports multiple drawings sheets in the eDrawings file.

    • Export arrangements: Exports arrangements from an assembly in the eDrawings file.

  1. Click OK to save the options, or Reset to set the options to the original settings.

  • Save. Displays the eDrawings Save dialog box.

    1. Set the Options (see the Options section above).

    2. To protect the eDrawings file with a password, select Password required to open document, then enter and confirm the password.

    3. Enter the file name.

    4. Click OK to save the eDrawings file.

You can then view the eDrawings file using the eDrawings Viewer.

  • Batch Publish. Converts multiple CAD files to eDrawings files. Displays the Batch Publisher dialog box.

    1. Select the files to publish. You can also select folders.

    2. Specify the location for saving the eDrawings files.

    3. Set export Options.

    4. Click Start.

  • Help. Displays the eDrawings online help.

  • About. Displays information about the eDrawings for NX/Unigraphics application, including the version.

Back to Top.

SolidWorks eDrawings Publisher for Pro/ENGINEER

Create eDrawings part (*.eprt), assembly (*.easm), and drawing (*.edrw) files from Pro/ENGINEER part, assembly, and drawing files. Geometric Limited developed and distributes the SolidWorks eDrawings Publisher for Pro/ENGINEER.

eDrawings for Pro/Engineer is a plug-in for Pro/Engineer that allows users to publish, share, and collaborate accurate representations of 2D and 3D product design data from Pro/Engineer files as read-only eDrawings files.

You can also open Pro/ENGINEER models (parts and assemblies) in eDrawings.

Installation

  1. Download the SolidWorks eDrawings Publisher for Pro/ENGINEER from http://www.eDrawingsViewer.com/download.

  2. Double-click the downloaded executable file and follow the instructions to install the eDrawings Publisher for Pro/ENGINEER.

The eDrawings Publisher for Pro/ENGINEER appears as the eDrawings menu in the Pro/ENGINEER application.

NOTES:

  • The installer detects and installs on all supported versions of Pro/ENGINEER.

  • Enter your SolidWorks eDrawings Professional license key, if you have one, to install eDrawings Professional for Pro/ENGINEER. If you do not enter the license key, you will get the complimentary eDrawings Publisher for Pro/ENGINEER.

To create eDrawings files using the eDrawings Publisher for Pro/ENGINEER:

  1. Open the Pro/ENGINEER file.

  2. Click eDrawings and select one of the following:

  • Publish. Opens the eDrawings Viewer with the eDrawings file displayed. The file currently open in Pro/ENGINEER is exported using the options set in the Options dialog box (see Options below).

  • Options. Displays the Options dialog box.

    1. Select from these options which vary depending on the file type:

    • Export shaded data with drawings (drawings only).  Saves the shaded data from the drawing document in the published eDrawings file.

    • Export hidden components with assemblies (assemblies only): Exports hidden components in a Pro/ENGINEER assembly file in the eDrawings file with the visibility set to hidden.

    • Tessellation Quality. Controls the amount of tessellation. Lower settings have smaller file size but are less accurate, while higher settings are more accurate but have larger file size.

    • Alert on free publishing. Enables a pop-up dialog that appears if you publish an eDrawings file but do not have a SolidWorks eDrawings Professional license from the pool of available network licenses.

    • Export mass properties (parts and assemblies only). Allows the mass properties of the entire model to be exported.

    • Export simplified representations/family table (parts and assemblies only): Exports simplified representations and family table instances in the published eDrawings file.

    • Export BOM table: Exports bill of material information from a Pro/ENGINEER assembly in the eDrawings file.

    • Export multiple drawings sheets: Exports multiple drawings sheets in the eDrawings file.

    • Allow recipient to measure. Enables measurement of this model by other SolidWorks eDrawings Professional users. If the file is review-enabled, then anyone can measure it. If you do not enable this option, measurement is disabled and no one can measure the model.

    • Allow recipient to export STL (parts and assemblies only). Allows recipients of the eDrawings file to save it as an STL file from the eDrawings Viewer.

  1. Click OK to save the options, or Reset to set the options to the original settings.

  1. Save. Displays the eDrawings Save dialog box.

    1. Set the Options (see the Options section above).

    2. To protect the eDrawings file with a password, select Password required to open the document, then enter and confirm the password.

    3. Enter the file name.

    4. Click OK to save the eDrawings file.

You can then view the eDrawings file using the eDrawings Viewer.

  • Batch Publish. Converts multiple CAD files to eDrawings files. Displays the Batch Publisher dialog box.

    1. Select the files to publish. You can also select folders.

    2. Specify the location for saving the eDrawings files.

    3. Set export Options.

    4. Click Start.

  • Help. Displays the eDrawings online help.

  • About. Displays information about the eDrawings for Pro/ENGINEER application, including the version.

Back to Top.

eDrawings Publisher for RapidFire Lite

Create eDrawings assembly (*.easm) and drawing (*.edrw) files from STEP/STP, IGES/IGS, DWG/DXF files, STL, OBJ, and Rhino file formats. Geometric Limited developed and distributes the SolidWorks eDrawings Publisher for RapidFire Lite.

eDrawings RapidFire Lite allows users to publish, share, and collaborate STEP/STP, IGES/IGS, DWG/DXF files, STL, OBJ, and Rhino files as read-only eDrawings files.

Installation

  1. Download the eDrawings Publisher for RapidFire Lite.

  2. Double-click the downloaded executable file and follow the instructions to install the eDrawings Publisher for RapidFire Lite.

The eDrawings Publisher for Solid Edge appears as the eDrawings toolbar, as well as in the Tools, Add-Ins menu, in the Solid Edge application.

NOTE: Enter your SolidWorks eDrawings Professional license key, if you have one, to install eDrawings Professional for RapidFire Lite. If you do not enter the license key, you will get the complimentary eDrawings Publisher for RapidFire Lite.

To create eDrawings files using the eDrawings Publisher for RapidFire Lite:

  1. Open the STEP/STP, IGES/IGS, DWG/DXF file, STL, OBJ, or Rhino file.

  2. Click:

    • Publish. Opens the eDrawings Viewer with the eDrawings file displayed. The file currently open is exported using the options set in the Options dialog box (see Options below).

    • Options. Displays the Options dialog box.

  1. Select from these options which vary depending on the file type:

  • Allow recipient to measure. Enables measurement of this model by other SolidWorks eDrawings Professional users. If the file is review-enabled, then anyone can measure it. If you do not enable this option, measurement is disabled and no one can measure the model.

  • Allow recipient to export STL (parts and assemblies only). Allows recipients of the eDrawings file to save it as an STL file from the eDrawings Viewer.

  • Export layers. Exports layer information in the eDrawings file.

  1. Click OK to save the options.

  • Save. Displays the eDrawings Save dialog box.

    1. Set the Options (see the Options section above).

    2. Enter the file name.

    3. Click OK to save the eDrawings file.

  • Help. Displays the eDrawings online help.

  • About. Displays information about the eDrawings for RapidFire Lite application, including the version.

Back to Top.

SolidWorks eDrawings Publisher for Solid Edge

Create eDrawings part (*.eprt), assembly (*.easm), and drawing (*.edrw) files from Solid Edge part, sheet metal, weldment, assembly, and draft files. Geometric Limited  developed and distributes the SolidWorks eDrawings Publisher for Solid Edge.

eDrawings for Solid Edge is a plug-in for Solid Edge that allows users to publish, share, and collaborate accurate representations of 2D and 3D product design data from Solid Edge files as read-only eDrawings files.

Installation

  1. Download the eDrawings Publisher for Solid Edge from http://www.eDrawingsViewer.com/download.

  2. Double-click the downloaded executable file and follow the instructions to install the eDrawings Publisher for Solid Edge.

The eDrawings Publisher for Solid Edge appears in the Tools, Add-Ins, eDrawings menu in the Solid Edge application.

NOTES:

  • The installer detects and installs on all supported versions of Solid Edge.

  • Enter your SolidWorks eDrawings Professional license key, if you have one, to install eDrawings Professional for Solid Edge. If you do not enter the license key, you will get the complimentary eDrawings Publisher for Solid Edge.

To create eDrawings files using the eDrawings Publisher for Solid Edge:

  1. Open the Solid Edge file.

  2. Click Tools, Add-Ins, eDrawings and select one of the following:

  • Publish. Opens the eDrawings Viewer with the eDrawings file displayed. The file currently open in Solid Edge is exported using the options set in the Options dialog box (see Options below).

  • Options. Displays the Options dialog box.

    1. Select from these options which vary depending on the file type:

    • Export shaded data with drawings (drawings only).  Saves the shaded data from the drawing document in the published eDrawings file.

    • Export hidden components with assemblies (assemblies only): Exports hidden components in a Solid Edge assembly file in the eDrawings file with the visibility set to hidden.

    • Alert on free publishing. Enables a pop-up dialog that appears if you publish an eDrawings file but do not have a SolidWorks eDrawings Professional license from the pool of available network licenses.

    • Allow recipient to measure. Enables measurement of this model by other SolidWorks eDrawings Professional users. If the file is review-enabled, then anyone can measure it. If you do not enable this option, measurement is disabled and no one can measure the model.

    • Allow recipient to export STL (parts and assemblies only). Allows recipients of the eDrawings file to save it as an STL file from the eDrawings Viewer.

    • Export multiple configurations: Exports multiple configurations in the eDrawings file.

    • Export multiple drawings sheets: Exports multiple drawings sheets in the eDrawings file.

    1. Click OK to save the options, or Reset to set the options to the original settings.

  • Save. Displays the eDrawings Save dialog box.

    1. Set the Options (see the Options section above).

    2. To protect the eDrawings file with a password, select Password required to open document, then enter and confirm the password.

    3. Enter the file name.

    4. Click OK to save the eDrawings file.

  • Batch Publish. Converts multiple CAD files to eDrawings files. Displays the Batch Publisher dialog box.

    1. Select the files to publish. You can also select folders.

    2. Specify the location for saving the eDrawings files.

    3. Set export Options.

    4. Click Start.

  • Help. Displays the eDrawings online help.

  • About. Displays information about the eDrawings for Solid Edge application, including the version.

Back to Top.

eDrawings Publisher for SolidWorks

Create eDrawings part (*.eprt), assembly (*.easm), and drawing (*.edrw) files from SolidWorks part, assembly, and drawing files.

Installation

The eDrawings publisher for SolidWorks is installed with SolidWorks.

To create eDrawings files using the eDrawings Publisher for SolidWorks:

  1. Open the SolidWorks file.

  2. Click File, Publish to eDrawings ( in the Save flyout toolbar).

The eDrawings Viewer appears with the published file displayed.

  1. Click Save or File, Save.

  2. In the Save As dialog box, select from the options, which vary depending on the file type.

  1. Click Save to save the eDrawings file.

An alternative method is to click File, Save As in SolidWorks and save the document as an eDrawings document.

Back to Top.



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   SolidWorks eDrawings Publishers
*Comment:  
x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: eDrawings 2012 SP05

The search functionality within the web help is in a beta test phase and you may experience periodic delays or interruptions in its performance. These are the normal and ordinary features of a beta test and shall not under any circumstances give rise to any liability on the part of Dassault Systèmes SolidWorks Corporation or its licensors. The topics within the Web-based help are not beta topics; they document eDrawings 2012 SP05.

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.