Hide Table of Contents Show Table of Contents

Opening Files

Use the Open tool_Open.gif tool to open an existing file in the SolidWorks eDrawings Viewer.
This information is specific to one or more CAD systems. See the SolidWorks eDrawings functionality matrix for availability information.

If you open either a read-only file or a file that is already open in your CAD application or another eDrawings Viewer, a message box advises you of this. You can open the file as read-only, but if you try to save changes to it, a message box appears. Click OK to close the message box, and a Save As dialog box appears. You can then save the file with another name.

eDrawings detects when the graphics data for a component may not be in sync with a later version that was modified and saved in a SolidWorks assembly. When you open a potentially outdated component, a watermark displays a warning and suggests that you rebuild the part in the SolidWorks software. To control the display of the watermark, click View > Show Warning Watermark.

The eDrawings Viewer does not display all information in detached drawing documents. To display all information in a detached drawing, publish an eDrawings drawing document from SolidWorks, or re-save the drawing document as a regular (undetached) drawing.

When you open a SolidWorks document in eDrawings, eDrawings checks the document's file references to see if the references have been updated. This helps you determine if the document is out of date. If eDrawings cannot determine whether file references are up to date, or if it confirms that the file references are not up to date, a watermark is displayed. You can click the warning icon warning_eDrawings.gif in the bottom of the eDrawings window and click any of the following:
  • Check if File is Out of Date
  • Always Show Warning Watermark
  • Show Warning Watermark for this document only
To use the file reference checking for standalone eDrawings installations, you must download and install the SolidWorks Document Manager when prompted. The Mac OS® version of eDrawings cannot check file references.

To open a file:

  1. Click Open tool_Open.gif or File > Open .

    The Open dialog box displays previews of eDrawings, SolidWorks, and published files if the files have been saved in 2008 or later applications. The previews display any changes to custom properties specified in Windows Explorer.

  2. Set the Files of type to one of the following:
    • eDrawings Files (*.eprt, *.easm, *.edrw)
    • SolidWorks Files (*.sldprt, *.sldasm, *.slddrw)
      In the eDrawings Viewer, you can open any SolidWorks document from SolidWorks 97Plus and higher.
    • DXF/DWG Files (*.dxf, *.dwg). eDrawings supports the following:
      • DXF and DWG files version 2.5 through 2010.
      • AutoCAD fonts (SHX), if AutoCAD® is installed. Otherwise the text is rendered in a default Simplex font.
      • Images and OLE objects in DWG files.
    • 3DXML Files (*.3dxml)
    • CALS Files (*.cal, *ct1)
    • XML Paper Specification (XPS) Files (*.edrwx, *.eprtx, *.easmx)
      You generate XPS files in SolidWorks with Save As and work with them in eDrawings the same as eDrawings files.

      XPS Viewer is included in the Vista operating system and is distributed with .NET Framework 3.0, which is installed with SolidWorks on Windows XP and Server 2003 operating systems.

      If eDrawings is installed on a computer, double-clicking an XPS file opens it in eDrawings rather than in the XPS Viewer.

      You can distribute XPS files to users with either the XPS Viewer or the eDrawings Viewer.

    • Pro/ENGINEER Files (*.prt, *.prt.*, *.xpr, *.asm, *.asm.*, *.xas)
      Pro/ENGINEER drawings cannot be imported.

      If a model uses Pro/ENGINEER family table instances, then the XPR and XAS accelerator instance files must be included for correct results. Although these instance accelerator files are optional for Pro/ENGINEER, they are required in eDrawings. When the family table instance modifies the top level of an assembly, open the XAS file corresponding to that instance, rather than the ASM file.

      Colors in part files are recognized, but colors applied at the assembly level are not.

      Certain Pro/ENGINEER items, such as annotations, sketches, and layers, are not imported.

    • STL Files (*.stl)
    • SolidWorks Template Files (*.prtdot, *.asmdot, *.drwdot)
    • All Files (*.*). Only the above supported files open in the eDrawings Viewer.
      eDrawings also supports display of SolidWorks Simulation and SolidWorks SimulationXpress data, when available, in eDrawings part or assembly files. For more information, see Viewing Simulation Data.
  3. To open the file as read-only, select Open as read-only.
  4. Select a file, then click Open.

    If you import a DXF/DWG file that has XREFs, eDrawings tries to automatically resolve the XREF. If the XREF cannot be resolved, the Resolve XRef dialog box appears. Click Skip file to import the DXF/DWG file without the XREF file, or navigate to the XREF file, select it, then click Open to open it. See DXF/DWG File XREFs for more information.

    See Review-Enabled Files for information about creating and using review-enabled files.



Related SolidWorks Forum Content

Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Opening Files
*Comment:  
x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: eDrawings 2012 SP05

The search functionality within the web help is in a beta test phase and you may experience periodic delays or interruptions in its performance. These are the normal and ordinary features of a beta test and shall not under any circumstances give rise to any liability on the part of Dassault Systèmes SolidWorks Corporation or its licensors. The topics within the Web-based help are not beta topics; they document eDrawings 2012 SP05.

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.