Hide Table of Contents

Using the Component Library

Use the Component Library to view and manage the component models that CircuitWorks has built.

To use the Component Library:

  1. Click the Tools tab (top of the CircuitWorks window), then click Library (Tools toolbar).
  2. In the left panel of the CircuitWorks Component Library window, you can:
    • Click a component to display a preview image and the component properties.
    • Double-click a component to open the model in SolidWorks.

    You can also add, edit, and delete components.

  3. When you are done using the Component Library, click File > Exit or click Close in the upper-right corner of the CircuitWorks Component Library window.


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Using the Component Library
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2013 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.