Hide Table of Contents

Derived Sketches

Derives a sketch from another sketch that belongs to the same part, or derives a sketch from another sketch in the same assembly.

When you derive a sketch from an existing sketch, you are assured that the two sketches will retain the characteristics that they share in common. Changes that you make to the original sketch are reflected in the derived sketch.

  • If you delete a sketch from which a new sketch was derived, you are prompted that all derived sketches will automatically be underived. Click Yes or No.
  • You cannot add or delete sketch entities in a derived sketch. However, you can re-orient it with dimensions and geometric relations.
  • When you make changes to the original sketch, the derived sketch updates automatically.
  • To break the link between the derived sketch and its parent sketch, right-click the derived sketch in the FeatureManager design tree and select Underive. (After the link is broken, the derived sketch no longer updates when you change the original sketch.)

Deriving Sketches in Parts

To derive a sketch from a sketch in the same part:

  1. Select the sketch from which you want to derive a new sketch.
  2. Hold the Ctrl key and click the face on which you want to place the new sketch.
  3. Click Insert > Derived Sketch.

    The sketch appears on the plane of the selected face, and the status line indicates that you are editing the sketch.

  4. Position the derived sketch by dragging and dimensioning it to the selected face. (The derived sketch is rigid and drags as a whole entity.)
  5. Exit the sketch.

Deriving Sketches in Assemblies

To derive a sketch from a sketch in the same assembly:

  1. Right-click the part on which you want to place a derived sketch.
  2. Select Edit Part.
  3. Select the sketch (in the same assembly) from which you want to derive a new sketch.
  4. Hold the Ctrl key and click the face on which you want to place the new sketch.
  5. Click Insert > Derived Sketch.

    The sketch appears on the plane of the selected face.

  6. Position the derived sketch by dragging and dimensioning it to the selected face. (The derived sketch is rigid and drags as a whole entity.)
  7. Exit the sketch.
  8. Click Edit Component Tool_Edit_Component_Assembly.gif on the Assembly toolbar.


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Derived Sketches
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2013 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.