Introduction
Administration
User Interface
SolidWorks Fundamentals
Moving from 2D to 3D
Assemblies
CircuitWorks
Configurations
SolidWorks Costing
Design Checker
Design Studies in SolidWorks
Detailing and Drawings
DFMXpress
DriveWorksXpress
FloXpress
Import and Export
Model Display
Mold Design
Motion Studies
Parts and Features
Parts
Materials
Multibody Parts
Controlling Parts
Parent and Child Relations
Parent/Child Relationships Dialog Box
Dependency Editing
Suppress and Unsuppress Features
Derived Parts
Splitting Parts and Saving Bodies
Split and Save Bodies
Assignment of Split or Saved Bodies Features
Create Assembly PropertyManager
Split and Save Bodies PropertyManager
Stock Part PropertyManager
File Management with External References
Feature Statistics
Checking Model Geometry
Check Entity
Displaying Entity Properties
Named Entities
Choose Option
Display States in Parts
Features
Reference Geometry
Routing
Sheet Metal
Simulation
SimulationXpress
Sketching
Sustainability Products
SolidWorks Utilities
Tolerancing
TolAnalyst
Toolbox
Weldments
Workgroup PDM
Troubleshooting
Glossary
Hide Table of Contents Show Table of Contents

Split and Save Bodies

Use the Split feature to create multiple parts from an existing part. You can create separate part files, and form an assembly from the new parts.

You can split a single part document into a multibody part document.
Before
After

To split a part:

  1. Click Split (Features toolbar) or Insert > Features > Split.
  2. In the PropertyManager, set the options:

    To split the part using trim tools, select Trimming Surfaces and click Cut Part.

    Split lines appear on the part, showing the different bodies formed by the split.

    Callout boxes appear in the graphics area for up to 10 bodies at one time. Click Next 10 or Previous 10 to scroll through all the callout boxes for a part.

  3. Under Resulting Bodies, select the bodies to save under , or click Auto-assign Names.

    All of the saved bodies appear in the graphics area and are listed in the FeatureManager design tree under Solid Bodies. The software automatically names all bodies. You can change the names.

  4. Double-click the body name under File, type a name for the new part in the dialog box, then click Save.

    The new part name appears in the Resulting Bodies list and in the callout box. Unsaved bodies are not split and remain with the original part.

    If you clear the check box for a split part after you save it, that part is no longer saved as a separate entity. It remains with the original part.

  5. Click .

Handling Split Parts

New Parts

The new parts are derived; they contain a reference to the parent part. Each new part contains a single feature named Stock- <parent part name> - n ->. You can reattach a derived part to a specified stock part, split feature, or body.

If you change the geometry of the original part, the new parts also change. If you change the split feature geometry, no new derived parts are created. The software updates the existing derived parts, preserving parent-child relations.

With multibody parts, the various split parts are listed in the FeatureManager design tree under Solid Bodies.

Original Part

The original part contains all its original features plus a new feature called Split.

If you selected Consume cut bodies under Resulting Bodies, the solid body displayed in the graphics area is the original solid body minus the new parts. If all bodies in the original part were saved as split bodies, no solid body is displayed. To see the original solid body, move the rollback bar in the FeatureManager design tree above the split feature or suppress the split feature.

If you delete the split feature in the original part, the new parts still exist, but the status of the external reference in the new parts is dangling.

Saving Split Bodies

You can also save solid bodies after you split the model using the Save Bodies feature. This enables you to save the bodies from a split part to a different folder or with different names to the same folder. You can also create an assembly from the split parts.

To save bodies from multibody parts:

  1. Click Insert > Features > Save Bodies.
  2. Select the bodies to save in the graphics area, or under in Resulting Parts.

    The callouts display the default path, file names, and location of the multibody part.

  3. Under Resulting Parts, double-click each file name under File to open the Save As dialog box. You can select a new location and file name for each part. You can also click Auto-assign Names to select and name all bodies.
  4. To create an assembly, under Create Assembly, click Browse, select a folder to save the assembly as SplitAssembly type (*.sldasm), and type a file name.
  5. Click .


Related SolidWorks Forum Content

Provide feedback on this topic

SolidWorks welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Split and Save Bodies
*Comment:  
x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SolidWorks 2013 SP05

The search functionality within the web help is in a beta test phase and you may experience periodic delays or interruptions in its performance. These are the normal and ordinary features of a beta test and shall not under any circumstances give rise to any liability on the part of DS SolidWorks or its licensors. The topics within the Web-based help are not beta topics; they document SolidWorks 2013 SP05.

To disable Web help from within SolidWorks and use local help instead, click Help > Use SolidWorks Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.