Hide Table of Contents

Editing Blocks

When you edit a block, you can add, remove, or modify sketch entities, as well as change existing relations and dimensions.

To edit a block:

  1. Right-click the sketch and select Edit Sketch.
  2. Expand the folder to display the blocks.
  3. Select a block and click Edit Block Tool_Edit_Block_Block.gif (Blocks toolbar) or Tools > Block > Edit.

    The block is identified by FM_block_sketch.gif in the FeatureManager design tree.

  4. Make changes to the block, and click the block confirmation corner block_confirmation_corner.gif to close the edit.
  5. If you want to save the block, select the block in the FeatureManager design tree, and click Save Block (Blocks toolbar) or Tools > Block > Save .

    If the block was previously saved, and you save the edits to the block using the same name, the change propagates to all other instances of the block.

Editing Blocks that are Linked to External Files

To edit the block, do one of the following:
  • Clear Link to File.

    This enables you to edit only instances of the block in the current sketch.

  • Edit the external file.

    This propagates changes to all instances of the block.



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Editing Blocks
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2013 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.