Introduction
Administration
User Interface
SolidWorks Fundamentals
Moving from 2D to 3D
Assemblies
CircuitWorks
Configurations
ConfigurationManager
Managing Configuration Data
Manual Configurations
Design Table Configurations
Summary of Design Table Parameters
Inserting a Design Table
Inserting a Design Table Automatically
Inserting a Blank Design Table
Inserting an External File as a Design Table
Preparing the Microsoft Excel File
Inserting the Microsoft Excel File
Numerical Configuration Name
Formatting a Design Table
Entering Parameters in a Design Table
Editing a Design Table
Deleting a Design Table
Deleting a Configuration Within a Design Table
Saving Design Tables
Design Tables in Drawings
Design Table PropertyManager
Dimensions Dialog Box
Add Rows and Columns Dialog Box
Modify Configurations
Configurable Parameters
Configuration Publisher
Configure Component PropertyManager for Toolbox Components
SolidWorks Costing
Design Checker
Design Studies in SolidWorks
Detailing and Drawings
DFMXpress
DriveWorksXpress
FloXpress
Import and Export
Model Display
Mold Design
Motion Studies
Parts and Features
Routing
Sheet Metal
Simulation
SimulationXpress
Sketching
Sustainability Products
SolidWorks Utilities
Tolerancing
TolAnalyst
Toolbox
Weldments
Workgroup PDM
Troubleshooting
Glossary
Hide Table of Contents Show Table of Contents

Inserting the Microsoft Excel File

You select From file in the Design Table PropertyManager to insert a Microsoft Excel file as a design table.

  1. In a part or assembly document, click Design Table (Tools toolbar) or Insert > Design Table.
  2. In the PropertyManager, under Source, select From file, then click Browse to locate the Excel file.
  3. Optionally, select Link to file, which links the table to the model.

    If you update a linked design table in Microsoft Excel, then open the SolidWorks model, you can choose to update either:
    • the model with the design table values
    • the design table with the model values
    You can set the update options in Tools > Options > System Options > External References. Set Update out-of-date linked design tables to to Prompt, Model, or Excel File.

  4. Set the Edit Control settings and Options, as desired.
  5. Click .

    The worksheet appears in the model document, and the Excel menus and toolbars replace the SolidWorks menus and toolbars.

  6. Edit the design table if necessary. When you finish editing, click anywhere outside the table to close it.

    A message indicates the names of any new configurations that were generated by the design table, and the SolidWorks menus and toolbars reappear.

    Design Table appears in the ConfigurationManager . Double-click the configuration name, or right-click the configuration name and select Show Configuration.



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Inserting the Microsoft Excel File
*Comment:  
x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2013 SP05

The search functionality within the web help is in a beta test phase and you may experience periodic delays or interruptions in its performance. These are the normal and ordinary features of a beta test and shall not under any circumstances give rise to any liability on the part of Dassault Systèmes SolidWorks Corporation or its licensors. The topics within the Web-based help are not beta topics; they document SOLIDWORKS 2013 SP05.

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.