> Sketching > Sketch Tools > Convert Entities > Using Convert Entities
Introduction
Administration
User Interface
SolidWorks Fundamentals
Moving from 2D to 3D
Assemblies
CircuitWorks
Configurations
SolidWorks Costing
Design Checker
Design Studies in SolidWorks
Detailing and Drawings
DFMXpress
DriveWorksXpress
FloXpress
Import and Export
Model Display
Mold Design
Motion Studies
Parts and Features
Routing
Sheet Metal
Simulation
SimulationXpress
Sketching
Sketch
Sketch Settings Menu
Sketch Complexity
Working in a Sketch
Inferencing
Sketch Modes
Autotransitioning
Selecting Contours
Exiting Sketches
Snaps
Sketch Options
Sketch Entities
Sketch Tools
Sketch Fillets
Sketch Chamfers
Offset Entities
Convert Entities
Using Convert Entities
Convert Entities PropertyManager
Intersection Curves
Face Curves
Trim Entities
Extend Entities
Split Entities
Jog Lines
Make Path
Construction Geometry
Mirror Entities
Dynamic Mirror Sketch Entities
Move, Copy, Rotate, Scale, or Stretch Entities
Align Grid/Origin PropertyManager
Modify Sketch Dialog Box
Repair Sketch
Sharing Sketches
Closing Sketches to Models
Sketch Picture
Sketch Patterns
Blocks
Splines
3D Sketching
Dimensions and Relations
Sustainability Products
SolidWorks Utilities
Tolerancing
TolAnalyst
Toolbox
Weldments
Workgroup PDM
Troubleshooting
Glossary
Hide Table of Contents Show Table of Contents

Using Convert Entities

To convert an entity:

  1. In an open sketch, click a model edge, loop, face, curve, external sketch contour, set of edges, or set of curves.

    You can also click an entity after clicking the Convert Entities Tool_Convert_Entities_Sketch.gif tool.
    Examples:
    convert_entities_face.gif

    Select a face to convert the edges of the face.


    convert_entities_loop.gif

    Select a face, then press Ctrl and select an edge of a loop. The software selects only the loop.
    convert_entities_contig_faces.gif

    Select contiguous faces to get an entire outline of the faces. The line segments correspond to each face.

  2. Click Convert Entities Tool_Convert_Entities_Sketch.gif (Sketch toolbar) or Tools > Sketch Tools > Convert Entities.

    The following relations are created:

    On Edge sketch_relation_On_Edge.gif Created between the new sketch curve and the entity, which causes the curve to update if the entity changes.
    Fixed Created internally on the endpoints of the sketch entity so the sketch remains in a "fully defined" state. This internal relation is not displayed when you use Display/Delete Relations. Remove the Fixed relation by dragging the endpoints.
    If you are creating a component or feature in the context of an assembly and Do not create references external to the model is selected in Tools > Options > External References, then the sketch relations described above are not created. See Controlling Creation of External References.

  3. In the PropertyManager, click Select chain to convert all contiguous sketch entities.
  4. Click PM_OK.gif.


Related SolidWorks Forum Content

Provide feedback on this topic

SolidWorks welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Using Convert Entities
*Comment:  
x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SolidWorks 2013 SP05

The search functionality within the web help is in a beta test phase and you may experience periodic delays or interruptions in its performance. These are the normal and ordinary features of a beta test and shall not under any circumstances give rise to any liability on the part of DS SolidWorks or its licensors. The topics within the Web-based help are not beta topics; they document SolidWorks 2013 SP05.

To disable Web help from within SolidWorks and use local help instead, click Help > Use SolidWorks Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.