Introduction
Administration
User Interface
SolidWorks Fundamentals
Basic Concepts
Basic Commands: Cut, Copy, Paste, Undo, and Redo
Help, Search, and Web Resources
Document Basics
SolidWorks Options
Display
Selection
File Properties
Measure Tool
Sensors
Equations
Industry-Specific Design Tools
Xperts Overview
Add-Ins
SolidWorks Fast Start
Object Linking and Embedding
Recording and Playing Macros
New Macro
Record/Pause Macro
Run Macro
Edit Macro
Macro Toolbar
VBA
Macro Feature Files
Previous Release Interoperability
SolidWorks API
SolidWorks Task Scheduler
Moving from 2D to 3D
Assemblies
CircuitWorks
Configurations
SolidWorks Costing
Design Checker
Design Studies in SolidWorks
Detailing and Drawings
DFMXpress
DriveWorksXpress
FloXpress
Import and Export
Model Display
Mold Design
Motion Studies
Parts and Features
Routing
Sheet Metal
Simulation
SimulationXpress
Sketching
Sustainability Products
SolidWorks Utilities
Tolerancing
TolAnalyst
Toolbox
Weldments
Workgroup PDM
Troubleshooting
Glossary
Hide Table of Contents Show Table of Contents

New Macro

You can create a new macro from the Macro toolbar or the Tools menu and then program the macro in a macro editing application.

Creating a new macro is different from recording a macro. When you create a new macro, you program the macro directly from a macro editing application such as Microsoft Visual Basic. When you record a macro, you create the macro from within the SolidWorks software.

To create a new macro:

  1. Click New Macro Tool_New_Macro.gif (Macro toolbar), or click Tools > Macro > New.
  2. Type a file name.
  3. Click Save.

    Your macro editing application opens ready for you to program the new macro.



Related SolidWorks Forum Content

Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   New Macro
*Comment:  
x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2013 SP05

The search functionality within the web help is in a beta test phase and you may experience periodic delays or interruptions in its performance. These are the normal and ordinary features of a beta test and shall not under any circumstances give rise to any liability on the part of Dassault Systèmes SolidWorks Corporation or its licensors. The topics within the Web-based help are not beta topics; they document SOLIDWORKS 2013 SP05.

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.