Hide Table of Contents

Running Build Checks

To run Build Checks:

  1. Click Build Checks (Design Checker flyout , Tools toolbar) or Tools > Design Checker > Build Checks.

    Use the Welcome to SolidWorks Design Checker dialog box to create additional standards files, open an existing standard file, get help, or work with a Design Checker tutorial.

  2. Do one of the following:
    • Click New or File > New to create a new requirements document.
    • Click Open or File > Open to open an existing requirements document.
  3. In the SolidWorks Design Checker window, click a tab below to set document requirements and a Criticality level.

    Settings in the Preferred auto correction values box are automatically applied to the failed checks when you select Auto Correct All or Correct Selected.

  4. Click Save or File > Save.

    The document is saved with a .swstd extension.

    You can set the location of Design Checker Files in Options > File Locations.

    You can now run Check Active Document to see if your document complies with the selected drafting standard.



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Running Build Checks
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2013 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.