Hide Table of Contents

Exporting Sheet Metal Parts to DXF or DWG Files

Creating DXF Files of Sheet Metal Flat Patterns

You can create *.dxf files of sheet metal flat patterns from sheet metal part documents without flattening the model or creating a drawing. This helps to export Dxf files to other applications, such as punch press or laser-cutter programming software.

Use one of these methods:

  • Click File > Save As and select Dxf (*.dxf) for Save as type.
  • Right-click Flat Pattern in the FeatureManager design tree and select Export to DXF/DWG.
The words Flat pattern are prepended to the file name.
In the DXF/ DWG Output PropertyManager, under Entities to Export, clear Bend Lines to generate the DXF file without bend lines in it.

Exporting and Mapping Bend Line Directions

You can map bend line directions to specific layers when you export sheet metal models as .dxf or .dwg files. For example, in sheet metal parts with up and down bend directions, you can map the different bend line directions to separate layers when you export the part.

To export and map bend line directions for a sheet metal part:

  1. Click File > Save As.
  2. For file type, select .dxf or .dwg.
  3. Click Options.
  4. Under Custom Map SolidWorks to DXF/DWG, select Enable.
  5. Set other export options and click OK.
  6. In the DXF/ DWG Output PropertyManager, under Entities to Export, select Bend lines.
  7. Select other options and click .
  8. In the SolidWorks to DXF/DWG Mapping dialog box:
    1. Assign layers to entities.
    2. Map other properties.
    3. Click OK.

Exporting a Bounding Box

When exporting a sheet metal part as a .dxf or .dwg file, you can export the bounding box and assign the bounding box to a specific layer.

To assign the bounding box sketch to a layer:

  1. Click File > Save As.
  2. For file type, select .dxf or .dwg.
  3. Click Options.
  4. In the DXF/ DWG Output PropertyManager, under Entities to Export, select Bounding box.
  5. Select other options and click .
  6. In the SolidWorks to DXF/DWG Mapping dialog box:
    1. Assign layers to entities.
    2. Map other properties.
    3. Click OK.


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Exporting Sheet Metal Parts to DXF or DWG Files
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2013 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.