Hide Table of Contents

Copy Settings Wizard

The Copy Settings Wizard saves, restores, and propagates system settings to users, computers, or profiles.

When you select options for the SolidWorks software, those settings are saved in a registry file, and the software recognizes the settings from one release of SolidWorks to the next. For most users, no action is necessary to maintain their settings. However, you can use the Copy Settings Wizard to distribute settings.

You can Save or Restore system settings for:

  • Keyboard shortcuts
  • Menu customization
  • System options
  • Toolbar layout (All toolbars or Macro toolbar only)

You save settings to a file and then restore them to the following registries:

Profile Registry
Current user CURRENT_USER of current user
One or more network computers LOCAL_MACHINE of selected computers
One or more roaming user profiles CURRENT_USER of selected users
Only system administrators should copy settings to network computers or roaming user profiles. When you restore settings to network computers, the settings apply to new SolidWorks users on the specified computers. You can restore settings to roaming user profiles only if your company uses roaming user profiles.

Starting the Copy Settings Wizard

You can launch the Copy Settings Wizard from the Tools > Save/Restore Settings in the SolidWorks software or click Start > All Programs > SolidWorks version > SolidWorks Tools > Copy Settings Wizard .

When you start the wizard from the SolidWorks software, the wizard runs in a special mode which allows the SolidWorks software to remain up and running, while you save or restore your current user settings.

If you start the wizard from the Start menu, you can save settings while SolidWorks is running but any options set during the current session are not saved. Also, if you are restoring settings, ensure that the computer or user to which you are restoring settings is not running SolidWorks.

Saving System Settings

To save system settings:

  1. In the Welcome dialog box, select Save Settings, then click Next.
  2. Browse to a location and file name, select the types of settings, then click Finish.

    The wizard confirms that the settings have been written to the specified file.

  3. Click OK.

    The settings files have a default extension of .sldreg. If you double-click a file with this extension, the Copy Settings Wizard appears.

Restoring System Settings

To restore system settings:

  1. In the Welcome dialog box, select Restore Settings, then click Next.
  2. Browse to a file from which to restore settings, select the types of settings to restore, then click Next.
  3. Select the type of destination (Current user, One or more network computers, or One or more roaming user profiles), then click Next.

    If you selected One or more network computers, a list of available computers is displayed.

    If you selected One or more roaming user profiles, a list of available users is displayed.

  4. If you selected One or more network computers or One or more roaming user profiles, select a user or a computer and click Add, repeat until you have specified all computers or users, then click Next.
  5. Select or clear Create backup of current settings for each_computer_or_user, then click Finish.

    The wizard confirms that the settings have been copied successfully.

  6. Click OK.


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Copy Settings Wizard
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2013 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.