Hide Table of Contents

Design Journal

A document called Design Journal.docx is embedded in SolidWorks documents. The document has the following properties:

  • Appears in the Design Binder folder in the FeatureManager design tree.
  • Is a Microsoft Word® document.
  • Resembles an engineering journal, with headings for File Name, Description, and Material. These fields are linked to document properties and updated whenever the journal is opened. File Name is the actual file name and Description and Material are SolidWorks document custom properties.
  • Appears initially as <Empty>, a designation that disappears when you activate the journal.
  • Is added to the SolidWorks file when you activate it, so the SolidWorks file size is not affected unless you activate the journal.
  • Accepts both text and embedded images.
  • Can be deleted, in which case it is again listed as <Empty>.
  • Can be printed.
You must have Microsoft Word on your computer to use the design journal.

Editing the Design Journal

To edit the design journal:

  1. In the FeatureManager design tree, double-click Design Journal.docx in the Design Binder folder .

    To view the Design Journal when the Design Binder folder is not visible, right-click the part, assembly, or drawing and click Hidden Tree Items > Design Binder > Design Journal.docx > Open.

  2. Type text, paste in images, format text, and so on.

    In Microsoft Office® 2002, you can drag images from the clipboard. In other versions of Microsoft Office, use the Paste command to paste in the image from the active window in SolidWorks. You can also paste in images from screen capture software, image editing software, and so on.

  3. Close the journal.

    Changes are saved automatically.

You can attach other documents to SolidWorks documents by adding them to the Design Binder folder .

Design Journal Template

You can specify the file location for the design template in Tools > Options > System Options > File Locations . In Show folders for, select Design Journal Template to add or delete a location. The default journal template folder is install_dir\lang\language\.

To edit the design journal template:

  1. On the File Explorer tab of the Task Pane, under install_dir\lang\language\, open journal.docx.
  2. Edit the document in Microsoft Word.
  3. Save and close the document.

    Your changes appear when you open a new embedded Design Journal.docx in a SolidWorks document.



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Design Journal
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2013 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.