Hide Table of Contents

Hole Callouts

The Hole Callout tool adds driven diameter dimensions to holes created by the Hole Wizard or circular cut features.

Hole callouts are available in drawings. If you change a hole dimension in the model, the callout updates automatically.

Hole callouts use Hole Wizard information when you create a hole with the Hole Wizard. The default formats for the Hole Wizard types are stored in <install_dir>\solidworks\lang\<language>\calloutformat.txt. A second file, calloutformat_2.txt, is a simplified version. You can edit either file. If you want to use the second file, you must rename the file to calloutformat.txt, which is the file name the SolidWorks software references. You can set the location of the default folder for Hole Callout Format File in Tools > Options > System Options > File Locations .

The number of instances is included in the hole callout if a hole in a linear or circular pattern was created in the Hole Wizard. In the JIS standard, you can change the number of instances indicator to "x" or "-".

Hole callout examples

A hole callout using information from the Hole Wizard:

drw_dims_HoleCallout_Wizard.gif

The same hole callout, but defined by geometry:

drw_dims_HoleCallout_Geometry.gif

A cut feature representing a hole. The cut feature must contain a circular sketch:

hole_callout_cut_feature.gif

You can add tolerances and precision to hole callouts:

hole_callout_tol_prec.gif

The axis of the hole must be normal to the drawing sheet.


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Hole Callouts
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2013 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.