Expand IntroductionIntroduction
Expand AdministrationAdministration
Expand User InterfaceUser Interface
Expand SolidWorks FundamentalsSolidWorks Fundamentals
Expand Moving from 2D to 3DMoving from 2D to 3D
Expand AssembliesAssemblies
Expand CircuitWorksCircuitWorks
Expand ConfigurationsConfigurations
Expand SolidWorks CostingSolidWorks Costing
Expand Design CheckerDesign Checker
Expand Design Studies in SolidWorksDesign Studies in SolidWorks
Expand Detailing and DrawingsDetailing and Drawings
Expand DFMXpressDFMXpress
Expand DriveWorksXpressDriveWorksXpress
Expand FloXpressFloXpress
Collapse Import and ExportImport and Export
Importing/Exporting SolidWorks Documents
General Import Options
Importing Documents
Importing Geometry
File Distribution Best Practices
Editing Imported Features
Expand Import Diagnostics OverviewImport Diagnostics Overview
Exporting Documents and Setting Options
DXF/DWG Native Format
Print3D
Expand Publishing to 3DVIA.comPublishing to 3DVIA.com
Collapse File TypesFile Types
3D XML Files
ACIS Files (*.sat)
Adobe Illustrator Files (*.ai)
Adobe Photoshop (*.psd) Files
Autodesk Inventor Files
CADKEY Files
CATIA Graphics Files
CATIA Part and Product File Import
DXF 3D Files
Collapse DXF/DWG Files (*.dxf, *.dwg Files)DXF/DWG Files (*.dxf, *.dwg Files)
Expand DXF/DWG File Export OptionsDXF/DWG File Export Options
DXF/DWG Output PropertyManager
Exporting Drawings as DXF or DWG
Preserving SolidWorks Drawing Layers on DXF/DWG Export
Copying and Pasting from AutoCAD to SolidWorks
Copying and Pasting from SolidWorks to a 2D Editor
DXF/DWG File Mapping
DXF/DWG PropertyManager
Imported DXF/DWG File Entities
Inserting DXF/DWG Files
Expand eDrawingseDrawings
Highly Compressed Graphics Files
HOOPS Files
IDF Files
IFC Files
Expand IGES Files (*.igs, *.iges)IGES Files (*.igs, *.iges)
JPEG Files
Exporting SolidWorks Models to *.lxo Files
Mechanical Desktop Files
Parasolid Files (*.x_t, *.x_b)
Expand Adobe Portable Document Format (*.pdf) FilesAdobe Portable Document Format (*.pdf) Files
Saving SolidWorks Files as Portable Network Graphics Files
Expand Pro/ENGINEER and Creo Parametric FilesPro/ENGINEER and Creo Parametric Files
Rhino Files
Solid Edge Files
Expand Step Files (*.step)Step Files (*.step)
Expand STL Files (*.stl)STL Files (*.stl)
TIFF Files (*.tif)
TIFF, Photoshop, and JPEG Export Options
Unigraphics Files
VDAFS Files (*.vda)
Viewpoint Files
Expand VRML Files (*.wrl)VRML Files (*.wrl)
XPS (XML Paper Specification) Files
Expand Import and Export File Version InformationImport and Export File Version Information
Expand 2D to 3D Conversion2D to 3D Conversion
Expand Scan to 3DScan to 3D
Expand DXF/DWG Import WizardDXF/DWG Import Wizard
Expand Model DisplayModel Display
Expand Mold DesignMold Design
Expand Motion StudiesMotion Studies
Expand Parts and FeaturesParts and Features
Expand RoutingRouting
Expand Sheet MetalSheet Metal
Expand SimulationSimulation
Expand SimulationXpressSimulationXpress
Expand SketchingSketching
Expand Sustainability ProductsSustainability Products
Expand SolidWorks UtilitiesSolidWorks Utilities
Expand TolerancingTolerancing
Expand TolAnalystTolAnalyst
Expand ToolboxToolbox
Expand WeldmentsWeldments
Expand Workgroup PDMWorkgroup PDM
Expand TroubleshootingTroubleshooting
Glossary
Hide Table of Contents

DXF/DWG Output PropertyManager

Use the DXF/DWG Output PropertyManager to export any planar face or named view from a part file to one or more DXF or DWG files. A preview lets you remove entities. An expanded set of geometrical entities is available when you export a sheet metal flat pattern.

To open this PropertyManager:

With a part open, do one of the following:

  • Save the part (File > Save As) to a .dxf or .dwg file type.
  • Select one or more planar faces, click File > Save As, and choose a .dxf or .dwg file type.
  • Select one or more planar faces and click Export to DXF / DWG.
  • In the FeatureManager design tree for a sheet metal part, right-click Flat-Pattern and click Export to DXF / DWG.

After you click Save, the PropertyManager appears.

Export

The type of export depends on the context from which you opened the PropertyManager:

Sheet metal Exports sheet metal flat patterns to DXF or DWG files for cutting.
Faces / loops / edges Exports planar faces to DXF or DWG files for machining.
Annotation views Exports views such as Front or Isometric.

What to Export

Entities to Export Sheet metal. Choose the type of entities to export. Geometry is selected by default.
Entities to Export Faces / loops / edges. When you select entities in the graphics area, their names are listed.
Views to Export Annotation views. Select the standard or custom views to export. Standard views are marked with an asterisk.

Output Alignment

coordsys_origin.png Origin Sets the origin. Click any vertex or leave blank to use the model origin.
  X axis, Y axis Sets the X and Y axes. Select orthogonal edges.
Reverse X Axis Direction, Reverse Y Axis Direction  

Export Options

Single file Exports all selections to a single file.
Separate files If you select multiple faces, edges, or sketches to export, exports each to its own file.

Preview Window

When you click , the DXF/DWG Cleanup window appears. Use standard view commands to examine the result. Remove entities that you do not want to export.

Previous Layout, Next Layout For exporting to more than one file, changes the preview to the previous or next file.
Previous View Returns to the previous view.
Zoom to Fit Displays the entire entity within the Cleanup window.
tool_Zoom_to_Area_View.png Zoom to Window Selects a smaller area of the entity to view in the window.
Tool_Zoom_In_Out_View.png Zoom In/Out Displays the preview in more or less detail.
tool_Pan_View.gif Pan Changes the position of the preview display.
  Remove Entities Deletes all selected entities.
Undo Restores the entities you last removed.
Redo Deletes the entities you last restored.


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   DXF/DWG Output PropertyManager
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2014 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.