Expand IntroductionIntroduction
Expand AdministrationAdministration
Expand User InterfaceUser Interface
Expand SolidWorks FundamentalsSolidWorks Fundamentals
Expand Moving from 2D to 3DMoving from 2D to 3D
Expand AssembliesAssemblies
Expand CircuitWorksCircuitWorks
Expand ConfigurationsConfigurations
Expand SolidWorks CostingSolidWorks Costing
Expand Design CheckerDesign Checker
Expand Design Studies in SolidWorksDesign Studies in SolidWorks
Expand Detailing and DrawingsDetailing and Drawings
Expand DFMXpressDFMXpress
Expand DriveWorksXpressDriveWorksXpress
Expand FloXpressFloXpress
Collapse Import and ExportImport and Export
Importing/Exporting SolidWorks Documents
General Import Options
Importing Documents
Importing Geometry
File Distribution Best Practices
Editing Imported Features
Expand Import Diagnostics OverviewImport Diagnostics Overview
Exporting Documents and Setting Options
DXF/DWG Native Format
Print3D
Expand Publishing to 3DVIA.comPublishing to 3DVIA.com
Collapse File TypesFile Types
3D XML Files
ACIS Files (*.sat)
Adobe Illustrator Files (*.ai)
Adobe Photoshop (*.psd) Files
Autodesk Inventor Files
CADKEY Files
CATIA Graphics Files
CATIA Part and Product File Import
DXF 3D Files
Expand DXF/DWG Files (*.dxf, *.dwg Files)DXF/DWG Files (*.dxf, *.dwg Files)
Expand eDrawingseDrawings
Highly Compressed Graphics Files
HOOPS Files
IDF Files
IFC Files
Expand IGES Files (*.igs, *.iges)IGES Files (*.igs, *.iges)
JPEG Files
Exporting SolidWorks Models to *.lxo Files
Mechanical Desktop Files
Parasolid Files (*.x_t, *.x_b)
Expand Adobe Portable Document Format (*.pdf) FilesAdobe Portable Document Format (*.pdf) Files
Saving SolidWorks Files as Portable Network Graphics Files
Expand Pro/ENGINEER and Creo Parametric FilesPro/ENGINEER and Creo Parametric Files
Rhino Files
Solid Edge Files
Expand Step Files (*.step)Step Files (*.step)
Expand STL Files (*.stl)STL Files (*.stl)
TIFF Files (*.tif)
TIFF, Photoshop, and JPEG Export Options
Unigraphics Files
VDAFS Files (*.vda)
Viewpoint Files
Expand VRML Files (*.wrl)VRML Files (*.wrl)
XPS (XML Paper Specification) Files
Expand Import and Export File Version InformationImport and Export File Version Information
Expand 2D to 3D Conversion2D to 3D Conversion
Expand Scan to 3DScan to 3D
Expand DXF/DWG Import WizardDXF/DWG Import Wizard
Expand Model DisplayModel Display
Expand Mold DesignMold Design
Expand Motion StudiesMotion Studies
Expand Parts and FeaturesParts and Features
Expand RoutingRouting
Expand Sheet MetalSheet Metal
Expand SimulationSimulation
Expand SimulationXpressSimulationXpress
Expand SketchingSketching
Expand Sustainability ProductsSustainability Products
Expand SolidWorks UtilitiesSolidWorks Utilities
Expand TolerancingTolerancing
Expand TolAnalystTolAnalyst
Expand ToolboxToolbox
Expand WeldmentsWeldments
Expand Workgroup PDMWorkgroup PDM
Expand TroubleshootingTroubleshooting
Glossary
Hide Table of Contents

Parasolid Files (*.x_t, *.x_b)

  • Data exported to or imported from Parasolid format retains its color when displayed in Shaded mode.
  • Component names in assemblies are retained for both import and export.
  • The Parasolid translator does not support the import or export of point data.
  • The Parasolid translator supports import and export of curves and wireframes.

Import

  • The Parasolid translator imports Parasolid text files or binary files as SolidWorks documents.
  • The Parasolid translator imports files with the extension .x_t, .x_b, .xmt_txt, or .xmt_bin.

Export

The Parasolid translator exports SolidWorks part or assembly documents as Parasolid text files or binary files. Binary files are smaller than text files, but binary files are not supported in some target applications.

If you export a SolidWorks assembly document that has hidden or suppressed components to a Parasolid text or binary file, a dialog box appears asking if you want to resolve these components.

The Parasolid translator includes export options.

Parasolid Export Options

You can set the export options when you export SolidWorks part or assembly documents as Parasolid files.

To set the Parasolid export options:

  1. Open the SolidWorks document that you want to export as a Parasolid file.
  2. Click File > Save As.

    The Save As dialog box appears.

  3. Set Save as type to Parasolid (*.x_t) or Parasolid Binary (*.x_b), then click Options.

    The Export Options dialog box appears with Parasolid selected on the File Format tab.

  4. Select from the following options:
    Option Description
    Version Select the type supported by the target system.
    Flatten assembly hierarchy (assemblies only) Flattens the assembly to one level of only part bodies. A flattened file contains a top-level assembly and a series of parts that contain imported features.
    Output coordinate system Select a coordinate system to apply for export. If you select -- default --, no transformation matrix is applied.
  5. Click OK, then click Save to export the document.


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Parasolid Files (*.x_t, *.x_b)
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2014 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.