Hide Table of Contents

Working with Blocks in Drawings

Specifying a Default Path for Locating Blocks

  1. Click Tools > Options > System Options > File Locations.
  2. Under Show folders for, select Blocks from the list, then click Add.
  3. In the Browse For Folder dialog box, browse to the desired folder, then click OK.

    The list can include more than one directory; the first path in the list is displayed by default in the Open dialog box when you insert a block.

Creating a New Block

  1. In a drawing document, click Make Block Tool_Make_Block_Block.gif (Blocks toolbar) or Tools > Block > Make.

    The Make Block PropertyManager appears.

  2. Select sketch entities or annotations (text, sketch entities, balloons, imported entities and text, and area hatch).
    block_entities.gif

    If you link a note to a system or custom property, the block stores the system variable ($PRPMODEL, for example) that identifies the entity to which the note is attached and resolves the link when the block is attached to the model, view, sheet, or document. It also stores and later resolves the system or custom variable name ("SW-Created Date", for example).

  3. Close any sketches or PropertyManagers and click PM_OK.gif to add the block to the FeatureManager design tree.
The block name appears under the Blocks FM_block.gif folder in the FeatureManager design tree. The block is created in the local drawing. You can also save the block to file.

Moving or Copying a Block

To move a block:

Select the block and drag it.

To copy a block:

Press Ctrl while dragging the block.

To copy a block from a sketch:

  1. In a part or assembly, in the FeatureManager design tree, expand the Sketch that includes the block you want to copy.
  2. Drag the block FM_block_sketch.gif icon from the FeatureManager design tree into the drawing document.

Saving a Block

You can save local blocks to external files.

To save a block:

  • Select the block and click Save Block Tool_Save_Block_Block.gif (Blocks toolbar) or Tools > Block > Save .

    The Save As dialog box appears. The default extension for block files is .sldblk. The SolidWorks software still supports .sldsym for inserting blocks and editing blocks, but all new blocks saved to external files use the .sldblk extension.

To use the block in the Design Library, save it to the annotations folder in the Design Library.
Properties of the block (scale and rotation angle) are saved in the file.

Inserting a Block into a Drawing

You can drag-and-drop pre-made blocks from the Design Library.

  1. Click Insert Block Tool_Insert_Block_Block.gif (Blocks toolbar) or Insert > Annotations > Block .

    The Insert Block PropertyManager appears.

    You can also drag a block from the Blocks folder in the FeatureManager design tree into the graphics area.

  2. Under Blocks to Insert, do one of the following:
    • Select a block from the list of blocks in the drawing document.
    • Click Browse and browse to an external file that contains a block definition.

    You can insert files with extensions .sldblk, .sldsym, .dwg, and .dxf. If desired, select Create external reference to file to link the block in the document to the external file.

  3. Set options in the Insert Block PropertyManager.
  4. In the graphics area, use inferencing to locate the blocks relative to one another and to drawing geometry.
  5. Click in the graphics area as many times as necessary to place as many copies of the block as you want. The block is positioned so that the block insertion point is at the point in the graphics area where you click.
  6. Click PM_OK.gif.

Editing Properties of a Block

  1. Select a block in the graphics area.
  2. Set options in the Block PropertyManager.
  3. Click PM_OK.gif.

Editing a Block

  1. Do one of the following:
    • Select the block in the FeatureManager design tree and click Tools > Block > Edit.
    • Right-click the block in the FeatureManager design tree or in the graphics area, and select Edit Block.
    • Select the block in the graphics area, then click Edit under Definition in the Block PropertyManager.
  2. You can add, delete, and edit entities in the graphics area.
  3. Click block_confirmation_corner.gif in the Confirmation Corner to save changes and remake the block.

Exploding a Block

  1. Do one of the following:
    • Right-click the block in the graphics area and select Explode Block.
    • Select the block and click Tools > Block > Explode.
  2. To remake the block, select the entities to include and clickTools > Block > Make.

    The name of the new block appears in the FeatureManager design tree with the next sequence number.

Changing the Position of the Block Insertion Point or Leader Point

  1. Select the block in the graphics area.

    In the PropertyManager, under Definition, click Leader & Insertion Points.

    The insertion point is identified in the graphics area by block_Base_Point.gif.

    The leader point is identified in the graphics area by block_leader_point.gif.

  2. Drag the insertion or leader point to any position in the graphics area.
  3. Click PM_OK.gif.

Changing the Style and Size of Arrowheads on Block Leaders

  1. Select a block with an existing leader.
  2. Right-click the leader handle closest to the arrowhead and click a style or click Size to change the size.
    block_with_leader.gif

Deleting All Instances of a Block

When you delete a block from the FeatureManager design tree, you also delete all of its instances in the drawing.
  1. In the FeatureManager design tree, expand Blocks FM_block.gif.
  2. Right-click the block and select Delete.
  3. Click Yes.

Deleting One Instance of a Block

When you delete a block from the graphics area, the block still remains in the FeatureManager design tree, even though the block is removed from the graphics area.

Right-click a block in the graphics area and select Delete.



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Working with Blocks in Drawings
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2014 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.