Expand IntroductionIntroduction
Expand AdministrationAdministration
Expand User InterfaceUser Interface
Expand SolidWorks FundamentalsSolidWorks Fundamentals
Expand Moving from 2D to 3DMoving from 2D to 3D
Expand AssembliesAssemblies
Expand CircuitWorksCircuitWorks
Expand ConfigurationsConfigurations
Expand SolidWorks CostingSolidWorks Costing
Expand Design CheckerDesign Checker
Expand Design Studies in SolidWorksDesign Studies in SolidWorks
Expand Detailing and DrawingsDetailing and Drawings
Expand DFMXpressDFMXpress
Expand DriveWorksXpressDriveWorksXpress
Expand FloXpressFloXpress
Collapse Import and ExportImport and Export
Importing/Exporting SolidWorks Documents
General Import Options
Importing Documents
Importing Geometry
File Distribution Best Practices
Editing Imported Features
Expand Import Diagnostics OverviewImport Diagnostics Overview
Exporting Documents and Setting Options
DXF/DWG Native Format
Print3D
Expand Publishing to 3DVIA.comPublishing to 3DVIA.com
Collapse File TypesFile Types
3D XML Files
ACIS Files (*.sat)
Adobe Illustrator Files (*.ai)
Adobe Photoshop (*.psd) Files
Autodesk Inventor Files
CADKEY Files
CATIA Graphics Files
CATIA Part and Product File Import
DXF 3D Files
Expand DXF/DWG Files (*.dxf, *.dwg Files)DXF/DWG Files (*.dxf, *.dwg Files)
Expand eDrawingseDrawings
Highly Compressed Graphics Files
HOOPS Files
IDF Files
IFC Files
Expand IGES Files (*.igs, *.iges)IGES Files (*.igs, *.iges)
JPEG Files
Exporting SolidWorks Models to *.lxo Files
Mechanical Desktop Files
Parasolid Files (*.x_t, *.x_b)
Expand Adobe Portable Document Format (*.pdf) FilesAdobe Portable Document Format (*.pdf) Files
Saving SolidWorks Files as Portable Network Graphics Files
Expand Pro/ENGINEER and Creo Parametric FilesPro/ENGINEER and Creo Parametric Files
Rhino Files
Solid Edge Files
Expand Step Files (*.step)Step Files (*.step)
Expand STL Files (*.stl)STL Files (*.stl)
TIFF Files (*.tif)
TIFF, Photoshop, and JPEG Export Options
Unigraphics Files
VDAFS Files (*.vda)
Viewpoint Files
Expand VRML Files (*.wrl)VRML Files (*.wrl)
XPS (XML Paper Specification) Files
Expand Import and Export File Version InformationImport and Export File Version Information
Expand 2D to 3D Conversion2D to 3D Conversion
Expand Scan to 3DScan to 3D
Expand DXF/DWG Import WizardDXF/DWG Import Wizard
Expand Model DisplayModel Display
Expand Mold DesignMold Design
Expand Motion StudiesMotion Studies
Expand Parts and FeaturesParts and Features
Expand RoutingRouting
Expand Sheet MetalSheet Metal
Expand SimulationSimulation
Expand SimulationXpressSimulationXpress
Expand SketchingSketching
Expand Sustainability ProductsSustainability Products
Expand SolidWorks UtilitiesSolidWorks Utilities
Expand TolerancingTolerancing
Expand TolAnalystTolAnalyst
Expand ToolboxToolbox
Expand WeldmentsWeldments
Expand Workgroup PDMWorkgroup PDM
Expand TroubleshootingTroubleshooting
Glossary
Hide Table of Contents

Adobe Illustrator Files (*.ai)

You can import Adobe® Illustrator® files into SolidWorks and SolidWorks models and drawings to Adobe Illustrator files.

Graphic objects are imported as outline shapes, and text objects are imported as SolidWorks text objects. Part and assembly models are exported as bitmap images.

To import an Adobe Illustrator file into SolidWorks, Version CS3 or later must be installed on your system.

You can copy SolidWorks parts, assemblies, sketches, and drawing views to Adobe Illustrator by means of the clipboard.

Functionality

  • When you import an Adobe Illustrator object, it appears on the Front plane. You can copy the object onto other planes.
  • You can import Adobe Illustrator objects into SolidWorks part documents, but not into assembly sketches.

Typical Uses

  • Product concept sketches mapped to planes and traced to model styling characteristics of the product.
  • Decals placed on faces of a product for photo-realistic rendering.
  • Logos used in SolidWorks modeling commands to place the product logo in the part geometry.
  • Product labels (such as electrical characteristics or instructions for use) extruded into the part geometry.


  1. To import Adobe Illustrator files, click Open (Standard toolbar) or File > Open and select Adobe Illustrator (*.ai) for Files of type.
  2. To export Adobe Illustrator files, click File > Save As and select Adobe Illustrator (*.ai) for Files of type.
  3. To copy SolidWorks data to the clipboard for pasting into Adobe Illustrator , click Edit > Copy to Adobe Illustrator.

    You can copy the following to the clipboard for pasting into Adobe Illustrator:
    • One or more selected drawing views
    • One or more selected faces or components in parts or assemblies
    Shading does not appear when you paste the clipboard data into Adobe Illustrator. To export shaded models to Adobe Illustrator, follow the procedure in Step 2.



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Adobe Illustrator Files (*.ai)
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2014 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.