Expand IntroductionIntroduction
Expand AdministrationAdministration
Expand User InterfaceUser Interface
Expand SolidWorks FundamentalsSolidWorks Fundamentals
Expand Moving from 2D to 3DMoving from 2D to 3D
Expand AssembliesAssemblies
Expand CircuitWorksCircuitWorks
Expand ConfigurationsConfigurations
Expand SolidWorks CostingSolidWorks Costing
Expand Design CheckerDesign Checker
Expand Design Studies in SolidWorksDesign Studies in SolidWorks
Expand Detailing and DrawingsDetailing and Drawings
Expand DFMXpressDFMXpress
Expand DriveWorksXpressDriveWorksXpress
Expand FloXpressFloXpress
Collapse Import and ExportImport and Export
Importing/Exporting SolidWorks Documents
General Import Options
Importing Documents
Importing Geometry
File Distribution Best Practices
Editing Imported Features
Expand Import Diagnostics OverviewImport Diagnostics Overview
Exporting Documents and Setting Options
DXF/DWG Native Format
Print3D
Expand Publishing to 3DVIA.comPublishing to 3DVIA.com
Collapse File TypesFile Types
3D XML Files
ACIS Files (*.sat)
Adobe Illustrator Files (*.ai)
Adobe Photoshop (*.psd) Files
Autodesk Inventor Files
CADKEY Files
CATIA Graphics Files
CATIA Part and Product File Import
DXF 3D Files
Expand DXF/DWG Files (*.dxf, *.dwg Files)DXF/DWG Files (*.dxf, *.dwg Files)
Expand eDrawingseDrawings
Highly Compressed Graphics Files
HOOPS Files
IDF Files
IFC Files
Expand IGES Files (*.igs, *.iges)IGES Files (*.igs, *.iges)
JPEG Files
Exporting SolidWorks Models to *.lxo Files
Mechanical Desktop Files
Parasolid Files (*.x_t, *.x_b)
Expand Adobe Portable Document Format (*.pdf) FilesAdobe Portable Document Format (*.pdf) Files
Saving SolidWorks Files as Portable Network Graphics Files
Expand Pro/ENGINEER and Creo Parametric FilesPro/ENGINEER and Creo Parametric Files
Rhino Files
Solid Edge Files
Expand Step Files (*.step)Step Files (*.step)
Expand STL Files (*.stl)STL Files (*.stl)
TIFF Files (*.tif)
TIFF, Photoshop, and JPEG Export Options
Unigraphics Files
VDAFS Files (*.vda)
Viewpoint Files
Expand VRML Files (*.wrl)VRML Files (*.wrl)
XPS (XML Paper Specification) Files
Expand Import and Export File Version InformationImport and Export File Version Information
Expand 2D to 3D Conversion2D to 3D Conversion
Expand Scan to 3DScan to 3D
Expand DXF/DWG Import WizardDXF/DWG Import Wizard
Expand Model DisplayModel Display
Expand Mold DesignMold Design
Expand Motion StudiesMotion Studies
Expand Parts and FeaturesParts and Features
Expand RoutingRouting
Expand Sheet MetalSheet Metal
Expand SimulationSimulation
Expand SimulationXpressSimulationXpress
Expand SketchingSketching
Expand Sustainability ProductsSustainability Products
Expand SolidWorks UtilitiesSolidWorks Utilities
Expand TolerancingTolerancing
Expand TolAnalystTolAnalyst
Expand ToolboxToolbox
Expand WeldmentsWeldments
Expand Workgroup PDMWorkgroup PDM
Expand TroubleshootingTroubleshooting
Glossary
Hide Table of Contents

IDF Files

Using CircuitWorks Lite, you can import Intermediate Data Format (IDF) circuit board files (.emn, .brd, .bdf, .idb) and create solid models of the circuit boards and their components. The model is a single part with the board and each component as extruded features.

If you have SolidWorks Premium, use the full version of CircuitWorks to import IDF files. See CircuitWorks Help for details.
  • Each IDF file has two parts: the board file and the library file; for example, .emn and .emp. Other possible combinations include .brd/.lib, .brd/.pro, .bdf/.ldf, and .idb/.idl. The software looks for a library file with the same name and extension corresponding to the board file. If it does not find the library file, it prompts you to browse for the file.

  • The name in the FeatureManager design tree of each extruded feature is based on the component name.
  • Components of the same type appear in the same color.
  • If the board thickness is not defined in the IDF file, you are prompted to specify a value and units.

To import IDF files:

  1. Click Open or File > Open.
  2. In the dialog box, set Files of type to IDF (*.emn,*.brd,*.bdf,*.idb).
  3. To select options, click Options, select from the options, then click OK.
  4. Select the file to open, then click Open to import the file as a SolidWorks document.

    A status bar displays the progress and the number of components.

IDF Import Options

You can set import options when you import Intermediate Data Format (IDF) circuit board files with CircuitWorks Lite.

To set IDF import options:

  1. Click Open or File > Open.
  2. In the dialog box, set Files of type to IDF (*.emn,*.brd,*.bdf,*.idb), then click Options.

    The Import Options dialog box appears with IDF selected on the File Format tab.

  3. Select from the following options:
    Option Description
    Add board drilled holes If holes have been drilled in the circuit board, the holes appear in the SolidWorks part.
    Reverse underside components In cases where import data causes the components to be rotated incorrectly, selecting this option compensates for the misplacement and allows proper location of the component features.
  4. Click OK to return to the Open dialog box.
  5. Select the file to open, then click Open to import the file as a SolidWorks document.


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   IDF Files
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2014 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.