Expand IntroduzioneIntroduzione
Expand AmministrazioneAmministrazione
Expand Interfaccia utenteInterfaccia utente
Expand Nozioni fondamentali su SolidWorksNozioni fondamentali su SolidWorks
Expand Migrazione da 2D a 3DMigrazione da 2D a 3D
Expand AssiemiAssiemi
Expand CircuitWorksCircuitWorks
Expand ConfigurazioniConfigurazioni
Expand SolidWorks CostingSolidWorks Costing
Expand Design CheckerDesign Checker
Expand Studi progettuali in SolidWorksStudi progettuali in SolidWorks
Collapse Disegni e dettagliDisegni e dettagli
Panoramica dettagli
Impostazione delle opzioni Dettagli
Elementi modello
PropertyManager Elementi del modello
Expand eDrawings AnnotazionieDrawings Annotazioni
Expand StileStile
Aggiungi o aggiorna uno stile
Collapse AnnotazioniAnnotazioni
Panoramica delle annotazioni
Panoramica opzioni delle annotazioni
Expand Viste dell'annotazioneViste dell'annotazione
Annotazioni multiple
Expand Barra degli strumenti AllineamentoBarra degli strumenti Allineamento
Elementi di dettaglio svincolati
Raggruppamento delle annotazioni
Annotazioni 3D
PropertyManager Orientamento dell'annotazione
Expand Linee di associazioneLinee di associazione
Expand BollatureBollature
Expand Tacche di centratura e linee di mezzeriaTacche di centratura e linee di mezzeria
Dettagli per asole di schizzo
Expand Didascalie foriDidascalie fori
Expand Filettature cosmeticheFilettature cosmetiche
Expand SimboliSimboli
Expand Tratteggio/riempimento areaTratteggio/riempimento area
Expand Fumetti di revisioneFumetti di revisione
Collapse Blocchi nei disegniBlocchi nei disegni
Panoramica dei blocchi nei disegni
Utilizzo di blocchi nei disegni
Ad esempio: Uso dei blocchi
Inserimento della geometria di riferimento nei disegni
Expand NoteNote
Controllo ortografico
Proprietà distinta di taglio
Expand Uso di Copia formatoUso di Copia formato
Expand TabelleTabelle
Expand Distinta materiali (BOM)Distinta materiali (BOM)
Expand Standard di disegnoStandard di disegno
Expand Impostazioni di stampaImpostazioni di stampa
Expand DisegniDisegni
Expand DFMXpressDFMXpress
Expand DriveWorksXpressDriveWorksXpress
Expand FloXpressFloXpress
Expand Importazione ed esportazioneImportazione ed esportazione
Expand Visualizzazione modelloVisualizzazione modello
Expand Progettazione di stampiProgettazione di stampi
Expand Studi del movimentoStudi del movimento
Expand Parti e funzioniParti e funzioni
Expand InstradamentoInstradamento
Expand LamieraLamiera
Expand SimulationSimulation
Expand SimulationXpressSimulationXpress
Expand Tecniche di schizzoTecniche di schizzo
Expand Prodotti SustainabilityProdotti Sustainability
Expand SolidWorks UtilitiesSolidWorks Utilities
Expand TolerancingTolerancing
Expand TolAnalystTolAnalyst
Expand ToolboxToolbox
Expand SaldatureSaldature
Expand Workgroup PDMWorkgroup PDM
Expand DiagnosticaDiagnostica
Glossario
Nascondi Sommario

Utilizzo di blocchi nei disegni

Specifica di un percorso di default per identificare i blocchi

  1. Selezionare Strumenti > Opzioni > Opzioni del sistema > Posizioni dei file.
  2. In Mostra cartelle, selezionare Blocchi dalla lista quindi, fare clic su Aggiungi.
  3. Nella finestra Navigare alla cartella, trovare la cartella desiderata quindi, fare clic su OK.

    La lista può comprendere più di una directory; il primo percorso nella lista viene visualizzato di default nella finestra Apri quando si inserisce un blocco.

Creazione di un nuovo blocco

  1. In un documento di disegno, fare clic su Crea blocco Tool_Make_Block_Block.gif nella barra degli strumenti Blocchi oppure selezionare Strumenti > Blocco > Crea .

    Apparirà il PropertyManager Crea blocco.

  2. Selezionare le entità di schizzo o le annotazioni (testo, entità di schizzo, bollature, entità importate e il testo e il tratteggio area).
    block_entities.gif

    Se una nota viene collegata ad un sistema o a una proprietà personalizzata, il blocco conserverà la variabile del sistema ($PRPMODEL, per esempio) che identifica l'entità alla quale la nota è allegata e risolve il collegamento quando il blocco viene allegato al modello, vista, foglio o documento. Conserva inoltre e successivamente risolve il sistema o il nome della variabile personalizzata ("SW-Created Date", per esempio).

  3. Chiudere tutti gli schizzi o i PropertyManager e fare clic su PM_OK.gif per aggiungere il blocco all'albero di disegno FeatureManager.
Il nome del blocco apparirà sotto la cartella Blocchi FM_block.gif nell'albero di disegno FeatureManager. Il blocco viene creato nel disegno locale. Inoltre è possibile salvare il blocco nel file.

Spostamento o copia di un blocco

Per spostare un blocco:

selezionare il blocco e trascinarlo.

Per copiare un blocco:

premere CTRL mentre si trascina il blocco.

Per copiare un blocco da uno schizzo:

  1. In una parte o assieme, nell'albero di disegno FeatureManager, espandere lo Schizzo che comprende il blocco da copiare.
  2. Trascinare l'icona del blocco FM_block_sketch.gif dall'albero di disegno FeatureManager al documento di disegno.

Salvataggio di un blocco

I blocchi locali si possono salvare nei file esterni.

Per salvare un blocco:

  • Selezionare il blocco e fare clic su Salva blocco Tool_Save_Block_Block.gif nella barra degli strumenti Blocchi oppure selezionare Strumenti > Blocco > Salva .

    Si visualizza la finestra di dialogo Salva con nome. L'estensione di default per i file del blocco è .sldblk. Il software SolidWorks supporta ancora l'estensione .sldsym per l'inserimento dei blocchi e la loro modifica, mentre tutti i blocchi nuovi salvati su file esterni utilizzano l'estensione .sldblk.

Per usare il blocco nella libreria del progetto, salvarlo nella cartella annotazioni nella libreria del progetto.
le proprietà del blocco (scala e angolo di rotazione) sono salvate nel file.

Inserimento di un blocco in un disegno

È possibile trascinare e rilasciare blocchi precostituiti dalla Libreria del progetto.

  1. Fare clic su Inserisci blocco Tool_Insert_Block_Block.gif nella barra degli strumenti Blocchi oppure selezionare Inserisci > Annotazioni > Blocco .

    Apparirà il PropertyManager Inserisci blocco.

    Un blocco può inoltre essere trascinato dalla cartella Blocchi nell'albero di disegno FeatureManager nell'area grafica.

  2. In Blocchi da inserire, procedere in uno dei modi seguenti:
    • selezionare un blocco dalla lista dei blocchi nel documento di disegno.
    • Fare clic su Sfoglia e navigare ad un file esterno che contiene la definizione di un blocco.

    È possibile inserire file con estensioni .sldblk, .sldsym, .dwg e .dxf. Se desiderato, selezionare Crea riferimenti esterni al file per collegare il blocco al file esterno.

  3. Impostare le opzioni nel PropertyManager Inserisci blocco.
  4. Nell'area grafica, usare la deduzione per identificare i blocchi relativamente l'uno all'altro e nella geometria del disegno.
  5. Fare clic nell'area grafica più volte fino a posizionare tutte le copie del blocco desiderate. Il blocco viene posizionato in modo che il punto di inserimento del blocco sia nel punto in cui si fa clic nell'area grafica.
  6. Fare clic su PM_OK.gif.

Modifica delle proprietà di un blocco

  1. Selezionare un blocco nell'area grafica.
  2. Impostare le opzioni nel PropertyManager Blocco.
  3. Fare clic su PM_OK.gif.

Modifica di un blocco

  1. procedere in uno dei modi seguenti:
    • selezionare il blocco nell'albero di disegno FeatureManager e fare clic su Strumenti > Blocco > Modifica.
    • Fare clic con il pulsante destro del mouse sul blocco nell'albero di disegno FeatureManager o nell'area grafica e selezionare Modifica blocco.
    • Selezionare il blocco nell'area grafica e fare clic su Modifica in Definizione nel PropertyManager Blocco.
  2. Le entità nell'area grafica possono essere aggiunte, cancellate e modificate.
  3. Fare clic su block_confirmation_corner.gif nello Spigolo di conferma per salvare le modifiche e ricreare il blocco.

Esplosione di un blocco

  1. procedere in uno dei modi seguenti:
    • Fare clic con il tasto destro sul blocco nell'area grafica e selezionare Esplodi blocco.
    • Selezionare il blocco e fare clic su Strumenti > Blocco > Esplodi.
  2. Per ricreare il blocco, selezionare le entità da includere e fare clic suStrumenti > Blocco > Crea.

    Il nome del nuovo blocco appare nell'albero di disegno FeatureManager con il numero di sequenza successiva.

Modifica della posizione del punto di inserimento del blocco o del punto della linea di associazione

  1. Selezionare il blocco nell'area grafica.

    Nel PropertyManager, in corrispondenza di Definizione, fare clic su Linea di associazione & Punto di inserimento.

    Il punto di inserimento è identificato nell'area grafica da block_Base_Point.gif.

    Il punto della linea di associazione è identificato nell'area grafica da block_leader_point.gif.

  2. Trascinare il punto d'inserimento o della linea di associazione in un qualsiasi punto nell'area grafica.
  3. Fare clic su PM_OK.gif.

Modifica dello stile e della dimensione delle teste a freccia sulle linee di associazione del blocco

  1. Selezionare un blocco con una linea di associazione esistente.
  2. Fare clic con il pulsante destro del mouse sul quadratino della linea di associazione più vicino alla testa a freccia e fare clic su uno stile o su Dimensione per modificare la dimensione.
    block_with_leader.gif

Eliminazione di tutte le istanze di un blocco

Quando si elimina un blocco dall'albero di disegno FeatureManager, vengono anche eliminate tutte le relative istanze dal disegno.
  1. Nell'albero di disegno FeatureManager, espandere BlocchiFM_block.gif.
  2. Fare clic con il pulsante destro del mouse sul blocco e selezionare Cancella.
  3. Fare clic su .

Eliminazione di un'istanza di un blocco

Quando si elimina un blocco dall'area grafica, questo rimane nell'albero di disegno FeatureManager.

Fare clic con il tasto destro sul blocco nell'area grafica e selezionare Cancella.



Fornisci il feedback su questo argomento

SOLIDWORKS apprezza il feedback degli utenti relativamente alla presentazione, la precisione e l'esaustività della documentazione. Usare il modulo riportato di seguito per inviare i propri commenti e suggerimenti su questo argomento direttamente al nostro team della documentazione. Questo team non è in grado di rispondere a domande di natura tecnica. Fare clic qui per informazioni sul supporto tecnico.

* Obbligatoria

 
*Email:  
Oggetto:   Feedback sugli argomenti della guida
Pagina:   Utilizzo di blocchi nei disegni
*Commento:  
*   Confermo di aver letto e accettato l'informativa sulla privacy che regola l'utilizzo dei miei dati personali da parte di Dassault Systèmes

Stampa argomento

Selezionare il contenuto da stampare:



x

L'utente utilizza una versione di Internet Explorer precedente alla versione 7. Per una visualizzazione ottimale, consigliamo di fare l'upgrade del proprio browser a Internet Explorer 7 o successiva.

 Non mostrare nuovamente questo messaggio
x

Versione contenuto guida Web: SOLIDWORKS 2014 SP05

Per disattivare la guida Web dall'interno di SOLIDWORKS e usare invece la guida locale, fare clic su ? > Usa la guida Web di SOLIDWORKS.

Per segnalare i problemi riscontrati con l'interfaccia e la funzionalità di ricerca della guida Web, contattare il rappresentante del supporto locale. Per fornire un feedback su singoli argomenti della guida, usare il link "Feedback su questo argomento" nella pagina del singolo argomento.