Expand IntroductionIntroduction
Expand AdministrationAdministration
Expand User InterfaceUser Interface
Collapse SOLIDWORKS FundamentalsSOLIDWORKS Fundamentals
Basic Concepts
Basic Commands: Cut, Copy, Paste, Undo, and Redo
Expand Help, Search, and Web ResourcesHelp, Search, and Web Resources
Expand Document BasicsDocument Basics
Collapse Overview of SOLIDWORKS OptionsOverview of SOLIDWORKS Options
Accessing the Options Dialog Box
Collapse System OptionsSystem Options
Expand System Options - GeneralSystem Options - General
Expand Drawings OptionsDrawings Options
System Colors Options
Expand Sketch OptionsSketch Options
Display and Selection Options
Expand Performance OptionsPerformance Options
Assemblies Options
External References Options
Default Templates Options
File Locations Options
FeatureManager Options
Spin Box Increments Options
View Options
Backup/Recover Options
System Options - Touch
Hole Wizard/Toolbox Options
File Explorer Options
Search Options
Collaboration Options
System Options - Messages/Errors/Warnings
Expand Document PropertiesDocument Properties
Expand DisplayDisplay
Expand SelectionSelection
Expand File PropertiesFile Properties
Expand Measure ToolMeasure Tool
Expand SensorsSensors
Expand EquationsEquations
Expand Industry-Specific Design ToolsIndustry-Specific Design Tools
Xperts Overview
Add-Ins
Expand SOLIDWORKS Fast StartSOLIDWORKS Fast Start
Expand Object Linking and EmbeddingObject Linking and Embedding
Expand Recording and Playing MacrosRecording and Playing Macros
Expand  Future Version Components in Earlier Releases Future Version Components in Earlier Releases
SOLIDWORKS API
SOLIDWORKS Task Scheduler
About SOLIDWORKS
Expand Moving from 2D to 3DMoving from 2D to 3D
Expand AssembliesAssemblies
Expand CircuitWorksCircuitWorks
Expand ConfigurationsConfigurations
Expand SOLIDWORKS CostingSOLIDWORKS Costing
Expand Design CheckerDesign Checker
Expand Design Studies in SOLIDWORKSDesign Studies in SOLIDWORKS
Expand Detailing and DrawingsDetailing and Drawings
Expand DFMXpressDFMXpress
Expand DriveWorksXpressDriveWorksXpress
Expand FloXpressFloXpress
Expand SLDXML Data ExchangeSLDXML Data Exchange
Expand Import and ExportImport and Export
Expand Model DisplayModel Display
Expand Mold DesignMold Design
Expand Motion StudiesMotion Studies
Expand Parts and FeaturesParts and Features
Expand RoutingRouting
Expand Sheet MetalSheet Metal
Expand SimulationSimulation
Expand SimulationXpressSimulationXpress
Expand SketchingSketching
Expand Sustainability ProductsSustainability Products
Expand SOLIDWORKS MBDSOLIDWORKS MBD
Expand SOLIDWORKS UtilitiesSOLIDWORKS Utilities
Expand TolerancingTolerancing
Expand TolAnalystTolAnalyst
Expand ToolboxToolbox
Expand WeldmentsWeldments
Expand Workgroup PDMWorkgroup PDM
Expand TroubleshootingTroubleshooting
Glossary
Hide Table of Contents

Sketch Options

Sets the default system options for sketching.

To set the default sketching options:

Click Options > Sketch or Tools > Options > Sketch.

Reset Restores factory defaults for all system options or only for options on this page.
Auto-rotate view normal to sketch plane on sketch creation Rotates views to be normal to the sketch plane whenever you open a sketch on a plane.
Use fully defined sketches Requires sketches to be fully defined before they are used to create features.
Display arc centerpoints in part/assembly sketches Displays arc centerpoints in sketches.
Display entity points in part/assembly sketches Displays endpoints of sketch entities as filled circles. The color of the circle indicates the status of the sketch entity:

Black

Fully defined

Blue

Under defined

Red

Over defined

Green

Selected

Over defined and dangling points are always displayed, regardless of this option.
Prompt to close sketch Displays a dialog box with the question, Close Sketch With Model Edges? if you create a sketch with an open profile, then click Extruded Boss/Base to create a boss feature. Use the model edges to close the sketch profile and select the direction in which to close the sketch.
Create sketch on new part Opens a new part with an active sketch on the Front Plane.
Override dimensions on drag/move Overrides dimensions when you drag sketch entities or move the sketch entity in the Move PropertyManager. The dimension updates after the drag is complete.
This option is also available in Tools > Sketch Settings > Override Dims on Drag/Move.
Display plane when shaded Displays the sketch plane when you edit a sketch in Shaded With Edges or Shaded mode.
If the display is slow due to the shaded plane, it may be because of the Transparency options. With some graphics cards, the display speed improves if you use low transparency. To set a low transparency, click Tools > Options > System Options > Performance and clear High quality for normal view mode and High quality for dynamic view mode.
Line length measured between virtual sharps in 3d Measures the line length from virtual sharps, as opposed to end points in 3D sketches.
Enable spline tangency and curvature handles Displays spline handles for tangency and curvature.
Show spline control polygon by default Displays a control polygon to manipulate the shape of a spline.
Ghost image on drag Displays a ghost image of a sketch entities' original position while you drag a sketch.
Show curvature comb bounding curve Displays or hides the bounding curve used with curvature combs. Example: Setting Curvature Comb Bounding Curve Option
Enable on screen numeric input on entity creation Displays numeric input fields to specify sizes when creating sketch entities. To use this option, you can also right-click in a sketch and click Sketch Numeric Input.
enable_on_screen_numeric_input.gif

This option is helpful for building design intent into sketches because you do not have to exit the sketch entity tool to dimension the entity.

When Enable on screen numeric input on entity creation is selected, you can also select Create dimension only when value is entered. This option dimensions the sketch entity only if you enter a value and press Enter or Tab.
create_dim_only_when_value_is_entered.gif

These options are not available for slot sketch entities.
Over defining dimensions

Prompt to set driven state

Displays a dialog box with the question, Make Dimension Driven? when you add an over defining dimension to a sketch.

Set driven by default

Sets the dimension to be driven by default when you add an over defining dimension to a sketch.

Use Prompt to set driven state alone or with Set driven by default. Depending on your selections, one of four actions occur when you add an over defining dimension to a sketch:
  • A dialog box appears that defaults to driven.
  • A dialog box appears that defaults to driving.
  • The dimension is driven.
  • The dimension is driving.


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Sketch Options
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2015 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.