Hide Table of Contents

Simplify Splines

Use the Simplify Spline tool to reduce the number of points in a spline and to increase system performance in models with complex spline curves.

simplify_spline01.gif
simplify_spline02.gif
simplify_spline03.gif

You can also simplify splines that were created from imported models or from tools such as Convert Entities, Offset Entities, Intersection Curve, and Face Curves.

Simplifying Splines

To simplify a spline:

  1. In an open sketch, select the spline in the graphics area, then click Simplify Spline Tool_Simplify_Spline_Tools.gif (Spline Tools toolbar) or Tools > Spline Tools > Simplify Spline.
  2. Do one of the following:
    • In the dialog box, set a value for Tolerance and click OK.
    • Click Smooth to continue simplifying the spline. You can click Smooth until only two spline points remain. The SOLIDWORKS software:
      • Adjusts the tolerance and calculates a new curve with fewer spline points. The original spline is displayed in the graphics area along with a preview of the smoothed curve.
      • Displays the Number of spline points for In original and In simplified curve.
      • Displays the simplified Tolerance, which measures the intended deviation of the simplified curve from the original curve.

    Click Previous to return through the sequence as far as the original curve.

  3. Click OK.


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Simplify Splines
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2015 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.