Expand IntroductionIntroduction
Expand AdministrationAdministration
Collapse User InterfaceUser Interface
User Interface Overview
Accessibility
Expand Windows and DisplaysWindows and Displays
Expand Graphics AreaGraphics Area
Manager Pane
Collapse FeatureManager Design TreeFeatureManager Design Tree
FeatureManager Design Tree Overview
FeatureManager Design Tree Conventions
FeatureManager Design Tree Views
FeatureManager Tree Display Options
Viewing Feature Relationships
FeatureManager Design Tree Response to Selections
Expand Rollback BarRollback Bar
FeatureManager Options
FeatureManager Design Tree Arrow Navigation
Selecting from the FeatureManager Design Tree
Accessing Recent Features Through History
Find in FeatureManager Design Tree
Filtering the FeatureManager Design Tree
Adding Folders and Subfolders
FeatureManager Design Tree Favorites
Grouping Features in Favorites Folders
Displaying the Design Binder
Design Journal
Add Attachment
Comments
Tags
Showing Feature Descriptions
Changing a Feature Description
What's Wrong?
Flyout FeatureManager Design Tree
PropertyManager Overview
Sticky Settings
ConfigurationManager
Expand Commands, Menus, and ToolbarsCommands, Menus, and Toolbars
Display Pane
Expand Task PaneTask Pane
Status Bar
Expand Instant3DInstant3D
Expand SOLIDWORKS FundamentalsSOLIDWORKS Fundamentals
Expand Moving from 2D to 3DMoving from 2D to 3D
Expand AssembliesAssemblies
Expand CircuitWorksCircuitWorks
Expand ConfigurationsConfigurations
Expand SOLIDWORKS CostingSOLIDWORKS Costing
Expand Design CheckerDesign Checker
Expand Design Studies in SOLIDWORKSDesign Studies in SOLIDWORKS
Expand Detailing and DrawingsDetailing and Drawings
Expand DFMXpressDFMXpress
Expand DriveWorksXpressDriveWorksXpress
Expand FloXpressFloXpress
Expand SLDXML Data ExchangeSLDXML Data Exchange
Expand Import and ExportImport and Export
Expand Model DisplayModel Display
Expand Mold DesignMold Design
Expand Motion StudiesMotion Studies
Expand Parts and FeaturesParts and Features
Expand RoutingRouting
Expand Sheet MetalSheet Metal
Expand SimulationSimulation
Expand SimulationXpressSimulationXpress
Expand SketchingSketching
Expand Sustainability ProductsSustainability Products
Expand SOLIDWORKS MBDSOLIDWORKS MBD
Expand SOLIDWORKS UtilitiesSOLIDWORKS Utilities
Expand TolerancingTolerancing
Expand TolAnalystTolAnalyst
Expand ToolboxToolbox
Expand WeldmentsWeldments
Expand Workgroup PDMWorkgroup PDM
Expand TroubleshootingTroubleshooting
Glossary
Hide Table of Contents

Design Journal

A document called Design Journal.docx is embedded in SOLIDWORKS documents. The document has the following properties:

  • Appears in the Design Binder folder in the FeatureManager design tree.
  • Is a Microsoft Word® document.
  • Resembles an engineering journal, with headings for File Name, Description, and Material. These fields are linked to document properties and updated whenever the journal is opened. File Name is the actual file name and Description and Material are SOLIDWORKS document custom properties.
  • Appears initially as <Empty>, a designation that disappears when you activate the journal.
  • Is added to the SOLIDWORKS file when you activate it, so the SOLIDWORKS file size is not affected unless you activate the journal.
  • Accepts both text and embedded images.
  • Can be deleted, in which case it is again listed as <Empty>.
  • Can be printed.
You must have Microsoft Word on your computer to use the design journal.

Editing the Design Journal

To edit the design journal:

  1. In the FeatureManager design tree, double-click Design Journal.docx in the Design Binder folder .

    To view the Design Journal when the Design Binder folder is not visible, right-click the part, assembly, or drawing and click Hidden Tree Items > Design Binder > Design Journal.docx > Open.

  2. Type text, paste in images, format text, and so on.

    In Microsoft Office® 2002, you can drag images from the clipboard. In other versions of Microsoft Office, use the Paste command to paste in the image from the active window in SOLIDWORKS. You can also paste in images from screen capture software, image editing software, and so on.

  3. Close the journal.

    Changes are saved automatically.

You can attach other documents to SOLIDWORKS documents by adding them to the Design Binder folder .

Design Journal Template

You can specify the file location for the design template in Tools > Options > System Options > File Locations . In Show folders for, select Design Journal Template to add or delete a location. The default journal template folder is install_dir\lang\language\.

To edit the design journal template:

  1. On the File Explorer tab of the Task Pane, under install_dir\lang\language\, open journal.docx.
  2. Edit the document in Microsoft Word.
  3. Save and close the document.

    Your changes appear when you open a new embedded Design Journal.docx in a SOLIDWORKS document.



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Design Journal
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2015 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.