Hide Table of Contents

Loft PropertyManager

Set the PropertyManager options based on the type of loft feature.

To open the PropertyManager, do one of the following:

  • Click Lofted Boss/Base (Features toolbar) or Insert > Boss/Base > Loft.
  • Click Lofted Cut (Features toolbar) or Cut > Loft > Insert.
  • Click Lofted Surface (Surfaces toolbar) or Insert > Surface > Loft.

Profiles

Profile Determines the profiles used to create a loft. Select sketch profiles, faces, or edges to connect. Lofts are created based on the order of profile selection.
For each profile, select the point from which you want the path of the loft to travel.
Move Up and Move Down Adjusts the order of the profiles. Select a Profile and adjust the profile order.
If the loft preview shows an undesirable loft, re-select or reorder the sketches to connect different points on the profiles.

Start/End Constraints

Start constraint and End constraint Applies a constraint to control tangency to the start and end profiles. Select one of the following:

Default

(Available with three profiles minimum). Approximates a parabola scribed between the first and last profiles. The tangency from this parabola drives the loft surface, which results in a more predictable and natural loft surface when matching conditions are not specified.

None

No tangency constraint (zero curvature) is applied.

Direction Vector

Applies a tangency constraint based on a selected entity used as a direction vector. Select a Direction Vector , then set the Draft angle and Start or End Tangent Length.

Normal to Profile

Applies a tangency constraint normal to the start or end profile. Set the Draft angle and Start or End Tangent Length.

Tangency to Face

(Available when attaching a loft to existing geometry). Makes the adjacent faces tangent at the selected start or end profile.

Curvature to Face

(Available when attaching a loft to existing geometry). Applies a smooth, visually appealing curvature continuous loft at the selected start or end profile.

Preview of loft with no start or end constraints applied

Loft with Curvature to Face applied

Next Face (Available with Tangency to Face or Curvature to Face selected for Start or End constraint) Toggles the loft between available faces.
Direction Vector (Available with Direction Vector selected for Start or End constraint) Applies a tangency constraint based on a selected entity used as a direction vector. The loft is tangent to the selected linear edge or axis, or to the normal of a selected face or plane. You can also select a pair of vertices to set the direction vector.
Draft angle (Available with Direction Vector or Normal to Profile selected for Start or End constraint) Applies a draft angle to the start or end profile. If necessary, click Reverse Direction . You also apply a draft angle along guide curves.
Start and End Tangent Length (Not available with None selected for Start or End constraint) Controls the amount of influence on the loft. The effect of tangent length is limited up to the next section. If necessary, click Reverse Tangent Direction .
Apply to all Displays one handle that controls all the constraints for the entire profile. Clear this option to display multiple handles that permit individual segment control. Drag the handles to modify the tangent length.
Apply to All selected

One handle per profile controls the constraints for that entire profile.

Apply to All cleared

Multiple handles per profile control the weight of the constraints at individual segments within each profile.

Guide Curves

  Guide curves influence Controls the influence of guide curves on the loft.

Example: Two profiles and one guide curve

Select one of the following:

To next guide

Extends the guide curve influence to the next guide curve only.

To next sharp

Extends the guide curve influence to the next sharp only. A sharp is a hard corner of the profile. Any two contiguous sketch entities that do not have a common tangent or an equal curvature relation with respect to each other define a sharp.

To next edge

Extends the guide curve influence only to the next edge.

Global

Extends the guide curve influence to the entire loft.

Guide Curves Select guide curves to control the loft.
Move Up and Move Down Adjusts the order of the guide curves. Select a Guide Curve and adjust the profile order.
  Guide tangency type Controls the tangency where the loft meets the guide curves. Select one of the following:

None

No tangency constraint is applied.

Normal to Profile

Applies a tangency constraint normal to the plane of the guide curve. Set the Draft angle.

Direction Vector

Applies a tangency constraint based on a selected entity used as a direction vector. Select a Direction Vector , then set the Draft angle.

Tangency to Face

(Available when a guide curve lies on the edge of existing geometry). Adds side tangency between adjacent faces that lie along the path of a guide curve, creating a smoother transition between adjacent faces.

For best results, the profiles should also be tangent to the tangency faces at the point where each profile meets the guide curve. The ideal tolerance is 2 degrees or less. You can use profiles with connection points up to 30 degrees off tangency before the loft fails.

  Direction Vector (Available with Direction Vector selected for Guide tangency type). Applies a tangency constraint based on a selected entity used as a direction vector. The loft is tangent to the selected linear edge or axis, or to the normal of a selected face or plane.
  Draft angle (Available with Direction Vector or Normal to Profile selected for Start or End constraint). Applies a draft angle to the loft along the guide curve, whenever geometrically possible. If necessary, click Reverse Direction .

Centerline Parameters

Centerline Guides the loft shape using a centerline. Select a sketch in the graphics area.
Centerlines can co-exist with guide curves.
  Number of Sections Adds sections between the profile and around the centerline. Move the slider to adjust the number of sections.
Show Sections Displays the loft sections. Click the arrows to display the sections. You can also enter a section number and click Show Sections to jump to that section.

Sketch Tools

Use the SelectionManager to help select sketch entities.

  Drag Sketch Enables drag mode. When editing the loft feature, you can drag any 3D sketch segments, points, or planes from the 3D sketch from which contours have been defined for the loft. The 3D sketch updates as you drag. You can also edit the 3D sketch to dimension the contours using dimensioning tools. The loft preview updates when the drag ends or when you edit the 3D sketch dimensions. To exit drag mode, click Drag Sketch again or another selection list in the PropertyManager. Video: Dragging a Sketch in a Loft
undo.png Button Undo sketch drag Undoes the previous sketch drag and returns the preview to its previous state. You can undo multiple drags and dimension edits.

Thin Feature

Select to create a thin feature loft.

Thin feature type Sets the type of thin feature loft. Select one of the following:

One-Direction

Creates the thin feature in one direction from the profiles using the Thickness value. If necessary, click Reverse Direction .

Mid-Plane

Creates the thin feature in both directions from the profiles, applying the same Thickness value in both directions.

Two-Direction

Creates the thin feature in both directions from the profiles. Set individual values for Thickness and Thickness dim_lin_t2.png.

Options

Merge tangent faces Causes the corresponding surfaces in the resulting loft to be tangent if the corresponding lofting segments are tangent. Faces that can be represented as a plane, cylinder, or cone are maintained. Other adjacent faces are merged, and the sections are approximated. Sketch arcs may be converted to splines.
  Sketch profile with preview
  Loft without using Merge tangent faces option
  Loft using Merge tangent faces option
Close loft Creates a closed body along the loft direction. This connects the last sketch and the first sketch automatically.
  Loft with Close loft cleared
  Loft with Close loft selected
Show preview Displays shaded previews of the loft. Clear this option to view the path and the guide curves only. You can also right-click and toggle between Transparent Preview and Opaque Preview on the shortcut menu.
  Transparent Preview
  Opaque Preview
Merge result Merges all the loft elements. Clear this option to not merge all the loft elements.

Curvature Display

Mesh preview Applies a preview mesh on the selected faces to better visualize the surfaces.
Mesh density Available when you select Mesh preview.

Adjusts the number of lines of the mesh.

Zebra stripes Displays zebra stripes, to make it easier to see surface wrinkles or defects.
Curvature combs Activates the display of curvature combs.

Select at least one of these options:

Direction 1

Toggle the display of curvature combs along Direction 1.

Direction 2

Toggle the display of curvature combs along Direction 2.

For either direction, select Edit Color to modify the comb color.

Scale Available when you select Curvature combs.

Adjusts the size of the curvature combs.

Density Available when you select Curvature combs.

Adjusts the number of lines of the curvature combs display.

Feature Scope

Specifies which bodies you want the feature to affect.



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Loft PropertyManager
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2015 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.