Expand IntroductionIntroduction
Expand AdministrationAdministration
Expand User InterfaceUser Interface
Collapse SOLIDWORKS FundamentalsSOLIDWORKS Fundamentals
Basic Concepts
Basic Commands: Cut, Copy, Paste, Undo, and Redo
Expand Help, Search, and Web ResourcesHelp, Search, and Web Resources
Expand Document BasicsDocument Basics
Collapse Overview of SOLIDWORKS OptionsOverview of SOLIDWORKS Options
Accessing the Options Dialog Box
Collapse System OptionsSystem Options
Expand System Options - GeneralSystem Options - General
Expand Drawings OptionsDrawings Options
System Colors Options
Expand Sketch OptionsSketch Options
Display and Selection Options
Expand Performance OptionsPerformance Options
Assemblies Options
External References Options
Default Templates Options
File Locations Options
FeatureManager Options
Spin Box Increments Options
View Options
Backup/Recover Options
System Options - Touch
Hole Wizard/Toolbox Options
File Explorer Options
Search Options
Collaboration Options
System Options - Messages/Errors/Warnings
Expand Document PropertiesDocument Properties
Expand DisplayDisplay
Expand SelectionSelection
Expand File PropertiesFile Properties
Expand Measure ToolMeasure Tool
Expand SensorsSensors
Expand EquationsEquations
Expand Industry-Specific Design ToolsIndustry-Specific Design Tools
Xperts Overview
Add-Ins
Expand SOLIDWORKS Fast StartSOLIDWORKS Fast Start
Expand Object Linking and EmbeddingObject Linking and Embedding
Expand Recording and Playing MacrosRecording and Playing Macros
Expand  Future Version Components in Earlier Releases Future Version Components in Earlier Releases
SOLIDWORKS API
SOLIDWORKS Task Scheduler
About SOLIDWORKS
Expand Moving from 2D to 3DMoving from 2D to 3D
Expand AssembliesAssemblies
Expand CircuitWorksCircuitWorks
Expand ConfigurationsConfigurations
Expand SOLIDWORKS CostingSOLIDWORKS Costing
Expand Design CheckerDesign Checker
Expand Design Studies in SOLIDWORKSDesign Studies in SOLIDWORKS
Expand Detailing and DrawingsDetailing and Drawings
Expand DFMXpressDFMXpress
Expand DriveWorksXpressDriveWorksXpress
Expand FloXpressFloXpress
Expand SLDXML Data ExchangeSLDXML Data Exchange
Expand Import and ExportImport and Export
Expand Model DisplayModel Display
Expand Mold DesignMold Design
Expand Motion StudiesMotion Studies
Expand Parts and FeaturesParts and Features
Expand RoutingRouting
Expand Sheet MetalSheet Metal
Expand SimulationSimulation
Expand SimulationXpressSimulationXpress
Expand SketchingSketching
Expand Sustainability ProductsSustainability Products
Expand SOLIDWORKS MBDSOLIDWORKS MBD
Expand SOLIDWORKS UtilitiesSOLIDWORKS Utilities
Expand TolerancingTolerancing
Expand TolAnalystTolAnalyst
Expand ToolboxToolbox
Expand WeldmentsWeldments
Expand Workgroup PDMWorkgroup PDM
Expand TroubleshootingTroubleshooting
Glossary
Hide Table of Contents

System Options - Messages/Errors/Warnings

You can control whether certain warning messages are displayed. You can restore messages that have been suppressed.

Click Tools > Options > System Options > Messages/Errors/Warnings.

Show errors every rebuild Displays the What's Wrong dialog box every time you rebuild the model. If cleared, the dialog box appears only once.
Treat missing mate references as errors When enabled, if a mate is missing a reference (for example, because of a deleted or modified part), an error appears in the FeatureManager design tree and the mate that is missing the reference is suppressed.

When disabled, the mate with the missing reference is suppressed without showing an error.

Warn before saving documents with update errors Displays the What's Wrong dialog box when you save a document with rebuild errors, and gives you the opportunity to fix the errors before saving the document.
Warn when starting a sketch in the context of an assembly When enabled, users who start a sketch while they are in an assembly receive a warning that they are not adding the sketch to a part.

To use a sketch to create a feature in a part, a user must open the part for edit.

This warning is enabled by default and can be turned off by the user.

Display FeatureManager tree warnings Select one of the following:

Always

Never

All but top level

Warnings appear at feature and mate group level, but not at the top level.

This option applies to warnings only. Errors are always displayed.
Display circular references in equations Select one of the following:

Everywhere

In equation dialog only

Never

Display potential circular references in equations Select one of the following:

Everywhere

In equation dialog only

Never

Dismiss reference/update dialog boxes when opening assemblies after n seconds Sets reference/update dialog boxes to automatically dismiss after the selected number of seconds when opening assemblies. You can later view the dismissed dialog boxes in an Open Summary Report. See Opening Large Assemblies.

Dismissed messages

Lists messages that you suppress by selecting Don't ask me again (or other similar option) in a dialog box. Select dismissed messages to restore them.

Click Reset to restore factory defaults for all system options or only for options on this page.


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   System Options - Messages/Errors/Warnings
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2015 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.