Expand IntroductionIntroduction
Expand AdministrationAdministration
Expand User InterfaceUser Interface
Collapse SOLIDWORKS FundamentalsSOLIDWORKS Fundamentals
Basic Concepts
Basic Commands: Cut, Copy, Paste, Undo, and Redo
Expand Help, Search, and Web ResourcesHelp, Search, and Web Resources
Expand Document BasicsDocument Basics
Collapse Overview of SOLIDWORKS OptionsOverview of SOLIDWORKS Options
Accessing the Options Dialog Box
Collapse System OptionsSystem Options
Expand System Options - GeneralSystem Options - General
Expand Drawings OptionsDrawings Options
System Colors Options
Expand Sketch OptionsSketch Options
Display and Selection Options
Expand Performance OptionsPerformance Options
Assemblies Options
External References Options
Default Templates Options
File Locations Options
FeatureManager Options
Spin Box Increments Options
View Options
Backup/Recover Options
System Options - Touch
Hole Wizard/Toolbox Options
File Explorer Options
Search Options
Collaboration Options
System Options - Messages/Errors/Warnings
Expand Document PropertiesDocument Properties
Expand DisplayDisplay
Expand SelectionSelection
Expand File PropertiesFile Properties
Expand Measure ToolMeasure Tool
Expand SensorsSensors
Expand EquationsEquations
Expand Industry-Specific Design ToolsIndustry-Specific Design Tools
Xperts Overview
Add-Ins
Expand SOLIDWORKS Fast StartSOLIDWORKS Fast Start
Expand Object Linking and EmbeddingObject Linking and Embedding
Expand Recording and Playing MacrosRecording and Playing Macros
Expand  Future Version Components in Earlier Releases Future Version Components in Earlier Releases
SOLIDWORKS API
SOLIDWORKS Task Scheduler
About SOLIDWORKS
Expand Moving from 2D to 3DMoving from 2D to 3D
Expand AssembliesAssemblies
Expand CircuitWorksCircuitWorks
Expand ConfigurationsConfigurations
Expand SOLIDWORKS CostingSOLIDWORKS Costing
Expand Design CheckerDesign Checker
Expand Design Studies in SOLIDWORKSDesign Studies in SOLIDWORKS
Expand Detailing and DrawingsDetailing and Drawings
Expand DFMXpressDFMXpress
Expand DriveWorksXpressDriveWorksXpress
Expand FloXpressFloXpress
Expand SLDXML Data ExchangeSLDXML Data Exchange
Expand Import and ExportImport and Export
Expand Model DisplayModel Display
Expand Mold DesignMold Design
Expand Motion StudiesMotion Studies
Expand Parts and FeaturesParts and Features
Expand RoutingRouting
Expand Sheet MetalSheet Metal
Expand SimulationSimulation
Expand SimulationXpressSimulationXpress
Expand SketchingSketching
Expand Sustainability ProductsSustainability Products
Expand SOLIDWORKS MBDSOLIDWORKS MBD
Expand SOLIDWORKS UtilitiesSOLIDWORKS Utilities
Expand TolerancingTolerancing
Expand TolAnalystTolAnalyst
Expand ToolboxToolbox
Expand WeldmentsWeldments
Expand Workgroup PDMWorkgroup PDM
Expand TroubleshootingTroubleshooting
Glossary
Hide Table of Contents

Assemblies Options

Set assembly options, including options for Large Assembly Mode.

To customize Assemblies options:
Click Options Tool_Options_Standard.gif or Tools > Options and click Assemblies.
Click Reset to restore factory defaults for all system options or only for options on this page.

Assemblies options

Move components by dragging Select to allow components to move or rotate within their degrees of freedom when you drag them in the graphics area. When cleared, you can still move or rotate a component with the Move with Triad function or the Move Component and Rotate Component tools (Assembly toolbar).
Prompt before changing mate alignments on edit When changes that you make to mates result in errors that the software can fix by flipping mate alignments, the software asks if you want it to make the changes. Otherwise, the software makes the changes automatically (without asking).
Save new components to external files If selected, prompts you to name and save new in-context components to external files. If cleared, saves new in-context components in the assembly file as virtual components.
Update model graphics when saving files Prevents display list data from becoming out-of-date. Updates model graphics data for components that are edited in-context, when you save assemblies.

Large assemblies

The selections you make under Large assemblies apply only when Large Assembly Mode is on. Set options for normal use (with Large Assembly Mode off) as indicated in the option descriptions below.
See Large Assembly Mode for a list of other conditions that are set automatically when Large Assembly Mode is activated.
Use Large Assembly Mode to improve performance whenever working with an assembly containing more than this number of components Set the number of resolved components above which Large Assembly Mode automatically activates when opening or working in an assembly.
When Large Assembly Mode is active Select the following options to improve performance:

Do not save auto recover info

Disables automatic save of your model. (Set in Backup Options for normal use.)

Hide all planes, axes, sketches, curves, annotations, etc

Selects Hide All Types on the View menu. When this option is selected, you can override it by clearing Hide All Types on the View menu, then selecting to show or hide individual types.

Do not display edges in shaded mode

Turns off edges in shaded mode. If the display mode of the assembly is Shaded With Edges , it changes to Shaded . When this option is selected, you can override it by clicking Shaded With Edges (View toolbar).

Do not rebuild when switching to assembly window

When you switch back to the assembly window after editing a component in a separate window, skips the message that asks if you want to rebuild. Skips the rebuild of the assembly even if you have previously selected Don't show again and clicked Yes (to rebuild).

When a rebuild is skipped, a yellow warning triangle appears on Rebuild (Standard toolbar), and a tooltip states Assembly not up to date.

Use Large Design Review whenever working with an assembly containing more than this number of components Sets the threshold above which Large Design Review Mode automatically activates when opening an assembly from the Open dialog box. When the number of resolved components exceeds the specified threshold, Mode is automatically set to Large Design Review, but you can select another mode from the list.
When Large Design Review is active

Automatic check and update all components

Envelope Components

Sets the mode in which envelope components are loaded when you open an assembly. Select one or both:

Automatically load lightweight Loads all envelopes as lightweight.
Load read-only Loads all envelopes as read-only.


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Assemblies Options
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2015 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.