Hide Table of Contents

DrawCompare

Use DrawCompare to compare all entities between two drawing documents. The differences between the drawings are displayed in color codes. You can also compare a detached drawing to its associated fully-loaded drawing.

DrawCompare compares the bitmaps of two drawings at the bit level. Only visual changes are captured when the drawings are compared. For example, if you move an annotation 2mm to the left, this change is reflected in the comparison. Conversely, if you change a custom property such as the Description, this does not reflect in the comparison.

Using DrawCompare

To use DrawCompare:

  1. Click Tools > Compare > DrawCompare.
  2. For Drawing 1, click Browse to locate a drawing.

    Click Change Drawing 1 Color PM_blue.gif to change the color used to display the differences in drawing 1.

  3. Repeat step 2 for Drawing 2.

    Click Change Drawing 2 Color PM_green.gif to change the color used to display the differences in drawing 2.

  4. Click Compare Drawings button_compare_drawings.gif.

    When the comparison is complete, the following appears in the dialog box:

    • Differences. Shows both drawings superimposed.
    • Drawing 1 and Drawing 2. Shows an image of both drawings that were compared.

  5. After the comparison, select from the following:
    • Additions. Clears Drawing 2 from the Differences display.
    • Removals. Clears Drawing 1 from the Differences display.
    • Open Results button_compare_drawings_open.gif. Opens previously saved DrawCompare results.
    • Save Results button_compare_drawings_save.gif. Saves the DrawCompare results as a compared bitmap file (*.Compare.BMP).
  6. Close the dialog box.

Using DrawCompare with Detached Drawings

When you compare a detached drawing, DrawCompare compares a bitmap of the detached drawing to a bitmap of the same drawing with the models fully-loaded.

To use DrawCompare with detached drawings:

  1. Click Tools > Compare > DrawCompare.
  2. For Drawing 1, click Browse to locate a detached drawing.
  3. Click Compare Detached Drawing button_compare_drawings_detached.gif or File > Compare Detached Drawing.

    The detached drawing opens and the models are fully-loaded for the comparison.



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   DrawCompare
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2015 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.