Hide Table of Contents

Machine Design Tools Overview

This overview lists typical machine design tasks and the SOLIDWORKS solutions that help you complete them.

Working With Sketches and Parts

Tasks Solutions
Start with a bottom-up or top-down design method. Bottom-up Design:

In bottom-up design, you design individual parts that you add to assemblies.

To create parts, start by creating a sketch with sketch tools, or by importing an existing sketch (for example, from an IGES or DXF/DWG file).

You can also convert a 2D sketch into a 3D model. The 2D sketch can be an imported drawing, or it can be a sketch constructed in SOLIDWORKS.

Top-down Design:

In top-down design, you use a layout inside an assembly to drive part and assembly design.

Create parts. Add shapes called features to create parts. Use ScanTo3D to create surface or solid models from 3D mesh or point cloud scan data.
Create weldments.

Use Weldments tools to create weldments. To learn more about weldments, click Help > SOLIDWORKS Tutorials > All SOLIDWORKS Tutorials and complete the Weldments tutorial.
Create sheet metal parts.

Use Sheet Metal tools to create sheet metal parts. You can also use the Convert to Sheet Metal command.

To learn more about sheet metal, click Help > SOLIDWORKS Tutorials > All SOLIDWORKS Tutorials and complete the Sheet Metal tutorial.

Add parts into a part document. Use the Insert Part tool to add parts into a multibody part document. You can add parts multiple times into the same document.
Create multiple versions of parts within a single document. Create different configurations of a part in a single document. You can create configurations using any of the following methods:

To learn more about creating configurations using design tables, click Help > SOLIDWORKS Tutorials > All SOLIDWORKS Tutorials and complete the Design Tables tutorial.

Determine the volume and weight of parts. Use the Mass Properties tool to calculate a part's properties such as density, mass, and volume.
Determine the factor of safety to see how parts perform when forces are applied to them. Use the SOLIDWORKS SimulationXpress analysis wizard to determine the factor of safety of parts. Click Tools > SimulationXpress to start the wizard.

To learn more about SOLIDWORKS SimulationXpress, click Help > SOLIDWORKS Tutorials > All SOLIDWORKS Tutorials and complete the SOLIDWORKS SimulationXpress tutorial.

Working with Assemblies

Tasks Solutions
Drive a part or assembly design using a layout. In an assembly, create an assembly layout sketch to make sure your components are positioned properly.
Add parts to an assembly. Create a new assembly from an existing part or assembly, then add components to the assembly.

You can also create a part in the context of an assembly so you can use the geometry of other assembly components while designing the part. The new part is saved within the assembly file as a virtual component. You can also save the new part in a separate part file so you can modify it independently from the assembly.

To learn more about assemblies, click Help SOLIDWORKS Tutorials All SOLIDWORKS Tutorials and complete the Lesson 2 - Assemblies tutorial.

Manipulate component location, orientation, and display states. Use the Move Component and Rotate Component tools to move assembly components. See Moving and Rotating Components.

Use Display States to set a separate display mode (Wireframe, Hidden Lines Removed, etc.) for each component in an assembly.

Control assembly movement and define the design intent.

For example, you can constrain a shaft to remain concentric to the cylinder in which it moves.

Use mate tools to add mate relations that control movement of parts:

Standard mates set standard mate relations between components, such as concentric, parallel, perpendicular, and so on.

Gear mates control the rotation of one component with respect to another component.

Lock mates maintain the position and orientation between two components.

Rack and pinion mates allow linear translation of one component (the rack) to cause circular rotation in another component (the pinion), and vice versa.

Limit mates limit component movement to a specified range.

Width mates center a tab within the width of a groove.

SmartMates automatically add mates when you drag components into place.

Path mates constrain a selected point on a component to a path.

Universal joint mates drive the rotation of the output shaft of a universal joint by the rotation of the input shaft about its axis.

Hinge mates limit the movement between components to one rotational degree of freedom.

To learn more about mates, click Help > SOLIDWORKS Tutorials > All SOLIDWORKS Tutorials and complete the Assembly Mates tutorial.

Create holes and add fasteners or components that require other components and features. Create holes for fasteners with the Hole Wizard tool, then use Smart Fasteners to automatically add standard fasteners into the holes.

You can access a customizable library of standard parts using the SOLIDWORKS Toolbox add-in. Select a standard and the type of part you want to insert, then drag the component into the assembly. For details, see Toolbox Help.

Click Tools > Add-Ins, and select SOLIDWORKS Toolbox and SOLIDWORKS Toolbox Browser to activate this add-in.

To learn more about SOLIDWORKS Toolbox, click Help > SOLIDWORKS Tutorials > All SOLIDWORKS Tutorials and complete the Toolbox tutorial.

Create Smart Components that require the addition of associated components and features such as bolts and mounting holes. When you insert the Smart Component into an assembly, you can choose whether or not to insert the associated components and features.

To learn more about Smart Components, click Help > SOLIDWORKS Tutorials > All SOLIDWORKS Tutorials and complete the Smart Components tutorial.

Add supplier-certified models. Use the 3D ContentCentralSM web site to save design time by accessing supplier-certified CAD models that you can download and add to an assembly.
Build efficient, modular assemblies using subassemblies. See Working with Subassemblies for tips and links to related topics.
Create simulations of machine movement. To display machine movement:
  • To check how components interact while you are creating an assembly, use the Physical Dynamics option in Collision Detection. When you drag or rotate a component, it applies a force to any components it touches, and you view the motion of assembly components.
  • To record and play back a simulation of movement, use Motion Studies.

You can

  • Create animations of models, such as a rotating or exploding model with the Assembly Motion level of Motion Studies.
  • Add more physics and realism to your animation with either the Physical Simulation or SOLIDWORKS Motion (available in SOLIDWORKS premium). You can add Simulation Elements that move components, such as springs, motors, and gravity, to control and automate motion.

To learn more about motion studies, click Help > SOLIDWORKS Tutorial > All SOLIDWORKS Tutorials and complete the Assembly Motion tutorial.

Troubleshoot problems you have when moving assembly components, such as components that collide. Use the Interference detection tool to check a file for components that interfere with each other. A list gives you the names of the components that interfere and the interference volume. The area of interference highlights in the graphics area.

Use the Collision Detection option when you move or rotate components to detect if multiple components collide.

Use Clearance Verification to check the minimum distance between selected components.

If a problem with mates is causing problems with the assembly motion, use MateXpert to identify mate problems.

Maximize performance of large assemblies. Use lightweight components, which loads only a subset of a model's data in memory. The remaining model data is loaded on an as-needed basis. You can also open subassemblies as lightweight components.

Use large assembly mode to maximize system option settings for large assemblies.

Use SpeedPak to create a simplified representation of an assembly without losing references. SpeedPak can significantly improve performance when you work in large and complex assemblies and related drawings.

Simplify assemblies and vary the assembly design with component configurations.

Working with Drawings

Tasks Solutions
Make drawings from a part or assembly. Use the Make Drawing from Part/Assembly tool on the Standard toolbar to assist you in creating a drawing.

To learn more about drawings, click Help > SOLIDWORKS Tutorials > All SOLIDWORKS Tutorials and complete the Lesson 3 - Drawings and Advanced Drawings tutorials.

Add views. SOLIDWORKS offers tools to create various drawing views:

Add detail views, section views, broken views, and broken out sections to a drawing.

Use Alternate Position Views to superimpose one drawing view precisely on another. Alternate position views are often used to show the range of motion of an assembly.

Add dimensions and annotations from part and assembly documents. Use Insert Model Items to insert dimensions marked for drawings and annotations already in model documents.

Use 3D annotations to create annotation views in the model. You can use these views in a drawing. The annotation views are converted into 2D drawing views; the annotations you inserted in the model appear in the drawing.

Use DimXpert to apply dimensions in drawings so that manufacturing features (patterns, slots, pockets, etc.) are fully-defined.

Add annotations and balloons to views. Add Center Marks , Centerlines , Geometric Tolerance Symbols , Notes , Surface Finish Symbols , and other annotations.

Specify in Options > Document Properties > Drafting Standard for center marks, centerlines, balloons, and dimensions to be inserted automatically on view creation.

Use the Auto Balloon Tool_auto_balloon_annotations.gif tool to automatically insert balloons in a drawing.

Add a bill of materials and other tables. Use the Bill of Materials tool to add a bill of materials to a drawing.

You can create bills of materials in assembly files. After you save the assembly, you can insert the BOM into a referenced drawing.

You can also add hole tables, revision tables, and weldment cut lists.

File Management and Design Collaboration

Tasks Solutions
Manage product data and control revisions. Use one of the following product data management (PDM) add-ins:
  • SOLIDWORKS Workgroup PDM (installed with SOLIDWORKS Premium and SOLIDWORKS Professional)

    Click Tools > Add-Ins, and select SOLIDWORKS Workgroup PDM to activate this add-in.

    To learn more about SOLIDWORKS Workgroup PDM, click Help SOLIDWORKS Tutorials All SOLIDWORKS Tutorials and complete the SOLIDWORKS Workgroup PDM tutorial.

  • SOLIDWORKS Enterprise PDM (separate installation and licensing)

    Click Tools > Add-Ins and select SOLIDWORKS Enterprise PDM to activate this add-in.

    To learn more about SOLIDWORKS Enterprise PDM, when you are logged in to a local file vault, click Help > SOLIDWORKS Enterprise PDM Help.

Get the newest version of a document. Reload the document to get the latest version.
Replace a component in an assembly document. Use the Replace Components tool to replace components in order to update the assembly. See Replace Components PropertyManager.
Store documents in a common place. Use the Save tool to save the assembly document and all referenced component documents.
Copy a document to use it in a new design. Use the Save As command to create a copy of a document with a different name that you can use in other designs.
Change the location where parts and subassemblies of an assembly are stored. Edit part location to save parts or subassemblies of an assembly to a new location or file name.
Send part, assembly, and drawing documents to others for review. Publish a eDrawings file from SOLIDWORKS, then send it to others who can use the free eDrawings Viewer to view the file.

To learn more about eDrawings, click Help > SOLIDWORKS Tutorials > All SOLIDWORKS Tutorials and complete the eDrawings tutorial.



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Machine Design Tools Overview
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2015 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.