Hide Table of Contents

Creating a Sweep

To create a sweep:

  1. Sketch a closed, non-intersecting profile on a plane or a face.

    If you use guide curves:
    • Create the path first if you want to add pierce relations between the path and a sketch point on the profile.
    • Create the guide curve first if you want to add pierce relations between the guide curves and a sketch point on the profile.

  2. Create the path for the profile to follow. Use a sketch, existing model edges, or curves.

    1 = Profile

    2 = Path

  3. Click one of the following:
    • Swept Boss/Base on the Features toolbar or Insert > Boss/Base > Sweep
    • Swept Cut on the Features toolbar or Insert > Cut > Sweep
    • Swept Surface on the Surfaces toolbar or Insert > Surface > Sweep
  4. In the PropertyManager:
    • Select a sketch in the graphics area for Profile .
    • Select a sketch in the graphics area for Path .
  5. Set the other PropertyManager options.
  6. Click OK .

    Sweep preview
    Orientation/twist Type: Keep normal constant Orientation/twist Type: Follow path



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Creating a Sweep
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2015 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.