Hide Table of Contents

Deforming a Model Using Point

You can combine different point deform options to achieve different results. The examples in this topic demonstrate only some of these options.

See Deform - Point Options for details on how these options interact with each other and on the models to deform.
Point deformation that affects a small area may not display if you are using the default image quality settings. To increase the quality, click Tools > Options > Document Properties > Image Quality . Move the Shaded and draft quality HLR/HLV resolution slider to the right, or select Optimize edge length.

To deform a model using point:

  1. Click Deform TOOL_DEFORM_FEATURES.GIF on the Features toolbar, or click Insert > Features > Deform.
  2. In the PropertyManager, under Deform Type, select Point.
  3. Under Deform Point, select one of these entities in the graphics area for Deform Point select_edge_faces_vertex.png:
    • Point on a face or plane
    • Point on an edge
    • Vertex
    • Point in space

    Examples of Deform Point selections:

    Point on Face or Plane
    Initial part

    Point on face is a simple method for quickly making changes to complex models.

    Point on face is useful for performing multiple design iterations and adding complex feature changes to models.

    faucet_handle_face_pt.gif

    Select a point on a face or plane. The pull direction is normal to the face.

    faucet_handle_face_pt_2.gif

    Result of point-on-face deform

    Note the degree of change that can be made with a point deform operation.

    faucet_handle_face_pt_3.gif

    Point on Edge
    Initial part

    Using a point on an edge allows a more predictable movement and location for a deform.

    base_edge_1.gif

    Select a point on an edge. The pull direction is calculated as an averaged normal from the two adjoining faces.

    If you move the point along the edge, the center of the deform moves with it.

    base_edge_2.gif

    Result of point-on-edge deform

    Point-on-edge deform allows you to make complex and quick design changes to any type of model.

    base_edge_3.gif

    Point on Vertex
    Initial part

    Using a point on a vertex is a predictable way to locate the deform when the normal to adjacent faces is the desired pull direction.

    phone_vertex_1.gif

    Select a vertex. This example uses the vertex of a rib.

    The pull direction is an average normal of all adjacent faces.

    phone_vertex_2.gif

    Result of point-on-vertex deform

    phone_vertex_3.gif

    Point in Space
    Select a point in space for Deform point select_edge_faces_vertex.png and select one of the following for Deform direction:
    • edge
    • sketch line
    • two points or vertices
    • plane
    • planar face

    (Point in space and sketch line for direction shown)

    pt_in_spc_1.gif

    Preview of deform using a point in space

    The direction is determined by the sketch line in this case.

    If the point you select is on a plane, the pull direction is normal to the plane.

    pt_in_spc_2.gif

    Result of deform using a point in space

    pt_in_spc_3.gif

  4. When you use a point in space as the Deform point select_edge_faces_vertex.png, select a linear edge, two points or vertices, a planar face, or a plane as the Deform direction.

    With a point on a face, edge, or vertex, you only need to select a Deform direction to use a different direction than the default. If necessary, click Reverse deform direction PM_reverse_direction.gif.

  5. In the Deform distance PM_deform_deform_distance.gif box, set a value.
  6. Under Deform Region:
    1. In the Deform radius PM_deform_deform_radius.gif box, set a value. This radius value determines a spherical influence around the selected point.

      Point deform showing how the Deform radius PM_deform_deform_radius.gif value around the point influences the shape.

      The theoretical sphere (red arrow) represents the value of the Deform radius PM_deform_deform_radius.gif.

      pt def - def dist ex.gif

    2. Select Deform region to confine the deformation to an area enclosed by the perimeter of the selected face.

      When you select a point on a face and select Deform region, by default you confine the deformation to the area enclosed by the perimeter of the face selected. When you select a point on an edge, vertex, or point in space, the deformation is not directly affected by Deform region.

      With Deform region selected, you can also select Fixed Curves/Edges/Faces PM_deform_fixed-edges-curves-faces.gif and any Additional Faces to be Deformed PM_face.gif.

      Example of how Deform region affects the deform:

      Initial part

      def_reg_checkbox_init.gif

      Deform region cleared

      def_reg_checkbox_cleared.gif

      Result with Deform region cleared

      When using a point on a face, clearing or selecting Deform region affects the deformation.

      def_reg_checkbox_clrd_fin.gif

      Deform using the same point with Deform region selected.

      def_reg_checked.gif

      If you select an edge or vertex, clearing or selecting Deform region does not affect the deformation.

      This preview (edge selected) is the same with Deform region selected or cleared.

      def_reg_checkbox_edge_checked.gif

    3. Select Bodies to be deformed solid_bodies.png Button.

      This option is useful for making changes to multibody parts. For example, use Bodies to be deformed solid_bodies.png Button when a symmetry must be maintained among all bodies affected using one set of Deform distance PM_deform_deform_distance.gif and Deform radius PM_deform_deform_radius.gif values, as shown in the following example.

      pt_multi_body_1.gif
      Initial multibody part
      pt_multi_body_2.gif
      Single body selected
      pt_multi_body_3.gif
      Result of single body deform
      pt_multi_body_4.gif
      All four bodies selected
      pt_multi_body_5.gif
      Result of multibody deform

  7. Under Shape Options:
    1. Select a level of stiffness. Stiffness determines the rigidity of the deform shape, whether constrained within a face (Deform region selected) or free (Deform region cleared). The level of stiffness to apply is determined by the shape you want to create.

      All stiffness examples use a Deform distance PM_deform_deform_distance.gifof 10, Deform radius PM_deform_deform_radius.gif of 50, and the same point on the face.
      Deform region selected Deform region cleared
      stiff_min_def_reg_checked.gif stiff_min_def_reg_cleared.gif
      Stiffness - Minimum PM_deform_stiffness_minumum.gif
      stiff_med_def_reg_checked.gif stiff_med_def_reg_cleared.gif
      Stiffness - Medium PM_deform_stiffness_medium.gif
      stiff_max_def_reg_checked.gif stiff_max_def_reg_cleared.gif
      Stiffness - Maximum PM_deform_stiffness_maximum.gif

    2. When Deform region is cleared, you can optionally select a Deform axis axis.png to further control the shape of the deformation. The Deform axis axis.png is defined by selecting a linear edge, two points or vertices, a sketch line, a planar face, or a plane. This results in a bending-like deformation, parallel to the axis you select.

      Initial part

      bend 0.gif

      Initial part

      Point deformation with two vertices (red arrows) selected for Deform axis axis.png.

      bend 1.gif

      Result using two vertices to create an axis line

      bend 2.gif

      Point deformation using an axis line defined by two different vertices (red arrows) for Deform axis axis.png.

      bend 3.gif

      Result using the new axis line

      bend 4.gif

      Point deformation using a plane (red arrow) for Deform axis axis.png. The axis of bend is perpendicular to the plane and centered around the centroid of the bodies.

      bend 5.gif

      Result using a plane for the axis line

      bend 6.gif

    3. When Deform region is selected, clear Maintain boundary to achieve the following:

      Initial part

      A point in space deformation is used.

      The deform face (red arrow) is the same in all examples.

      add_face_nomaintain_0.gif

      Maintain boundary cleared

      Additional faces only selected

      The top face is selected for Additional Faces to be Deformed PM_face.gif

      add_face_nomaintain_1.gif

      Result:

      Only the top face is deformed, while the sides are essentially extruded to meet the top face.

      add_face_nomaintain_2.gif

      Maintain boundary selected

      add_face_nomaintain_3.gif

      Result:

      Only the top face is affected. All other faces remain unchanged.

      add_face_nomaintain_4.gif

    4. Move the Shape accuracy PM_deform_shape accuracy.gif slider to control surface quality. Increasing the quality also increases the success rate of the deform feature. For example, if you get an error message Could not replace geometries, move the slider towards the right. Move the slider only as needed; increasing surface accuracy decreases performance.
  8. Click PM_OK.gif.


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Deforming a Model Using Point
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2015 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.