Hide Table of Contents

Creating a New OLE Object

To create a new OLE Object:

  1. Click Insert > Object.
  2. In the dialog box, select Create New.
  3. In the Object Type box, click the type of document you want to create (for example, Microsoft Excel Worksheet). Only documents from OLE-compliant applications that are installed on your computer appear in the list.
  4. Select Display As Icon for the new object to appear as an icon.
  5. Click OK. A new document appears inside the active document. The toolbars and menus for this new document appear in place of the SOLIDWORKS toolbars and menus.

    If you chose Display As Icon, an icon appears in your SOLIDWORKS document, and the parent application opens in another window.

  6. Edit the object as though you were working in the parent application.
  7. When you finish editing, click in the SOLIDWORKS document window anywhere outside the embedded object. The SOLIDWORKS toolbars and menus become available again.

    If you chose Display As Icon, click File > Exit or File > Close & Return to part_name in the parent application.



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Creating a New OLE Object
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2015 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.