Expand IntroductionIntroduction
Expand AdministrationAdministration
Expand User InterfaceUser Interface
Expand SOLIDWORKS FundamentalsSOLIDWORKS Fundamentals
Expand Moving from 2D to 3DMoving from 2D to 3D
Collapse AssembliesAssemblies
Expand The FeatureManager Design Tree in an AssemblyThe FeatureManager Design Tree in an Assembly
Collapse Basic Component OperationsBasic Component Operations
Creating an Assembly from a Part
Collapse Adding Components to an AssemblyAdding Components to an Assembly
Collapse Inserting Components from the PropertyManagerInserting Components from the PropertyManager
Inserting One Component at a Time
Inserting Several Components in Succession
Inserting Several Components at the Same Location
Rotating Inserted Components in Assemblies
Insert Components/Begin Assembly PropertyManager
Adding Components from an Open Document Window
Adding Components from Windows Explorer
Adding Components from Internet Explorer
Expand Adding Instances of a ComponentAdding Instances of a Component
Inferencing to the Assembly Origin
Adding Future Version Files as Components in an Assembly
Expand Editing Assembly ComponentsEditing Assembly Components
Deleting Components from an Assembly
Expand Selecting ComponentsSelecting Components
Positioning Components in an Assembly
Expand Moving and Rotating ComponentsMoving and Rotating Components
Expand Component Patterns and MirroringComponent Patterns and Mirroring
Expand Component PropertiesComponent Properties
Design Methods (Bottom-up and Top-down Design)
Expand Top-Down DesignTop-Down Design
Expand MatesMates
Expand SubassembliesSubassemblies
Expand Controlling Display and Appearance in AssembliesControlling Display and Appearance in Assemblies
Expand External FilesExternal Files
Expand Detecting ProblemsDetecting Problems
Expand Exploded Views in AssembliesExploded Views in Assemblies
Expand Other Assembly TechniquesOther Assembly Techniques
Expand Large AssembliesLarge Assemblies
Expand CircuitWorksCircuitWorks
Expand ConfigurationsConfigurations
Expand SOLIDWORKS CostingSOLIDWORKS Costing
Expand Design CheckerDesign Checker
Expand Design Studies in SOLIDWORKSDesign Studies in SOLIDWORKS
Expand Detailing and DrawingsDetailing and Drawings
Expand DFMXpressDFMXpress
Expand DriveWorksXpressDriveWorksXpress
Expand FloXpressFloXpress
Expand SLDXML Data ExchangeSLDXML Data Exchange
Expand Import and ExportImport and Export
Expand Model DisplayModel Display
Expand Mold DesignMold Design
Expand Motion StudiesMotion Studies
Expand Parts and FeaturesParts and Features
Expand RoutingRouting
Expand Sheet MetalSheet Metal
Expand SimulationSimulation
Expand SimulationXpressSimulationXpress
Expand SketchingSketching
Expand Sustainability ProductsSustainability Products
Expand SOLIDWORKS MBDSOLIDWORKS MBD
Expand SOLIDWORKS UtilitiesSOLIDWORKS Utilities
Expand TolerancingTolerancing
Expand TolAnalystTolAnalyst
Expand ToolboxToolbox
Expand WeldmentsWeldments
Expand Workgroup PDMWorkgroup PDM
Expand TroubleshootingTroubleshooting
Glossary
Hide Table of Contents

Inserting Several Components at the Same Location

You can insert several components at a time at the same location. You can insert multiple instances of the group of components without closing the PropertyManager.

To insert several components at once:

  1. Do one of the following to open the PropertyManager:
    • Create a new assembly document by clicking New (Standard toolbar) or File > New.
    • In an existing assembly, click Insert Components (Assembly toolbar) or Insert > Component > Existing Part/Assembly.

    Previously saved documents that are currently open appear under Part/Assembly to Insert.

    Click to pin the PropertyManager if you want to insert multiple instances of the group of components without having to re-open the PropertyManager.

  2. Under Part/Assembly to Insert, do one of the following:
    • Ctrl + select several components from the list.
    • Click Browse. In the dialog box, Ctrl + select several components and then click Open.

    In the graphics area, a preview of the first component is attached to the pointer.
    insert_components_succession_1.gif

  3. In the graphics area, double-click where you want to place the components.

    • If you double-click the origin, all the components are inserted at the assembly origin. The origin of each component is coincident with the assembly origin, and the planes of each component are aligned with the planes of the assembly. In the FeatureManager design tree, (f) beside each component indicates that the component locations are fixed.
      insert_components_same_location_origin.gif
    • If you double-click somewhere other than the origin, the components are placed near that location but not overlapping. The planes of each component are parallel with the planes of the assembly. The origins are not coincident. If the assembly was empty, then the first component is fixed and the others are floating. Otherwise, all components are floating.
      insert_components_same_location_not_origin.gif

    If the PropertyManager is not pinned, it closes.

    If the PropertyManager is pinned, you can double-click again in the graphics area to place another instance of the components.



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Inserting Several Components at the Same Location
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2015 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.