Welcome
Collapse Getting StartedGetting Started
Overview
Expand Types of SOLIDWORKS API ApplicationsTypes of SOLIDWORKS API Applications
Expand SOLIDWORKS API Object Model and Class HierarchySOLIDWORKS API Object Model and Class Hierarchy
Collapse Programming with the SOLIDWORKS APIProgramming with the SOLIDWORKS API
Expand Add-insAdd-ins
API Dependent on SOLIDWORKS Being Visible
Arrays
Attributes Imported from ACIS SAT Files
Bitmasks
Block Definitions and Block Instances
Bodies in Body Folders
BOOL and VARIANT_BOOL
Bounding Box and Note Text
COM vs. Dispatch
CommandManager and CommandGroups
Components, Configurations, and Suppression States
Compound Note
ComVisibleAttribute in in VB.NET and C# Macros and Add-ins
Controls, Visual Basic 6.0, and Windows XP
Drawing Views and Model Entities
Early and Late Binding
Expand EventsEvents
Features of Components
Helper Functions
Hole Wizard Features and Objects
IDispatch Object Arrays as Input in .NET
Implementation Guidelines
Import and Export File Options
In-process Methods
Instantiate ActiveX Controls as Tabs
Interface Pointers
ISafeArrayUtility Interface Overview
Keystrokes and Accelerator Keys
Library Features and Objects
Lightweight Components
Line Attributes for View::GetPolyLinesAndCurves
Line Weights
Long vs. Integer
Expand Macro FeaturesMacro Features
Manipulators
Mass Properties
Expand Multibody PartsMultibody Parts
Option Explicit Statement
Expand Packing and Unpacking Double Arrays and Integer PairsPacking and Unpacking Double Arrays and Integer Pairs
Partition Rollback and API Handles
Persistent Reference IDs
Presentation Transforms
Expand PropertyManager PagesPropertyManager Pages
.NET Interop Assemblies
Quick Tips and Bubble ToolTips
Return Values
Expand SafeArraysSafeArrays
Selection Criteria
Selection Lists
Selections that Define Features
Setup Project to Distribute SOLIDWORKS Add-in
Smart Pointers
SOLIDWORKS Objects
Sorting Tables
Splines
SQLite
STL Container Classes and Smart Pointers
Suspend Automatic Rebuilds
System Options and Document Properties
Tessellation and Edges
Third-party Data in SOLIDWORKS Files
Tracking IDs
Expand Type LibrariesType Libraries
Units
Unmanaged C++ and C++/CLI Code
VBA and SOLIDWORKS x64
Examples and Projects
Expand SOLIDWORKS API HelpSOLIDWORKS API Help
Expand SOLIDWORKS Enterprise PDM API HelpSOLIDWORKS Enterprise PDM API Help
Expand FeatureWorks API HelpFeatureWorks API Help
Expand SOLIDWORKS Costing API HelpSOLIDWORKS Costing API Help
Expand SOLIDWORKS Document Manager API HelpSOLIDWORKS Document Manager API Help
Expand SOLIDWORKS Routing API HelpSOLIDWORKS Routing API Help
Expand SOLIDWORKS Simulation API HelpSOLIDWORKS Simulation API Help
Expand SOLIDWORKS Sustainability API HelpSOLIDWORKS Sustainability API Help
Expand SOLIDWORKS Toolbox API HelpSOLIDWORKS Toolbox API Help
Expand SOLIDWORKS Utilities API HelpSOLIDWORKS Utilities API Help
Expand SOLIDWORKS Workgroup PDM API HelpSOLIDWORKS Workgroup PDM API Help
Expand eDrawings API HelpeDrawings API Help
Hide Table of Contents

System Options and Document Properties

You can get and set SOLIDWORKS system options and document properties (also called user preferences) using SOLIDWORKS API enumerators and methods.

To determine which enumerator corresponds with which system option or document property, you can:

  • change a system or document setting in the user interface while recording a macro. Then edit the macro to identify the name and value of the enumerator that corresponds to the setting you just changed and to also identify the name of the method used to change (i.e., set) it. See the System Options and Document Properties Get/Set Methods table in this topic for a list of methods that get and set system-option and document-property enumerators.

    - or -

  • locate the system option or document property in the SOLIDWORKS user interface and click the link that corresponds to it in the System Options and Document Properties Settings and Enumerators table in this topic. Each link opens a topic that contains a:

    • screen shot of the user-interface dialog or menu corresponding to that system option or document property.

    • table containing all of the settings for that system option or document property and the enumerator and methods that get or set it.

Remember to reset any option or property back to its original state after the operation completes. System-option settings persist across SOLIDWORKS sessions.

System Options, Document Properties, Customize, File menu, and View menu Settings and Enumerators

NOTE: Unlinked text indicates that an enumerator does not exist for that system option, document property, customization, or menu item. Unlinked text is shown to help you more easily map the text in the table with the text shown on the specified tabs and menus in the user interface.
 

Tools > Options > System Options tab

Tools > Options > Document Properties tab

 

Tools menu

File menu

View menu

Appears on tab:

General

Drawings

 - Display Style

 - Area Hatch/Fill

 - Performance

Colors

Sketch

 - Relations/Snaps

Display/Selection

Performance

Assemblies                                                       

External References

Default Templates

File Locations

FeatureManager

Spin Box Increments

View

Backup/Recover

Touch

Hole Wizard/Toolbox

File Explorer

Search

Collaboration

Messages/Errors/Warnings

 

Does not appear on tab:

Miscellaneous

Appears on tab:

Drafting Standard

Annotations

  - Balloons

  - Datums

  - Geometric

     Tolerances

  - Location Label
    (drawings only)

  - Notes

  - Revision Clouds

  - Surface

     Finishes

  - Weld Symbols

Dimensions

  - Angle

  - Angular Running

  - Arc Length

  - Chamfer

  - Diameter

  - Hole Callout

  - Linear

  - Ordinate

  - Radius

Centerlines/Center Marks (drawings only)

DimXpert (drawings only)

Tables

 - Bend (drawings only)

 - Bill of Materials

 - General

 - Hole (drawings only)

 - Punch (drawings only)

 - Revision (drawings only)

 - Title Block Table (parts and assemblies only)

 - Weld (drawings only)

Views (drawings only)

 - Auxiliary

 - Detail

 - Section

 - Orthographic

 - Other

Virtual Sharps (parts and drawings only)

Detailing

Drawing Sheets

Grid/Snap

Units

Line Font (drawings only)

Line Style (drawings only)

Line Thickness (drawings only)

Model Display (parts and assemblies only)

Material Properties (parts only)

Image Quality

Sheet Metal

Weldments

Plane Display (parts and assemblies only)

Configurations (parts and assemblies only)

DimXpert (parts only)

 - Size Dimension

 - Location Dimension

 - Chain Dimension

 - Geometric Tolerance

 - Chamfer Controls

 - Display Options

Configurations

 

Does not appear on tab:

- Miscellaneous

> Sketch Entities

  > Corner Rectangle or Center Rectangle or 3 Point Corner Rectangle or 3 Point Center Rectangle
or Parellelogram

> Customize

  > Toolbars

    > Mouse Gestures

> New > Open

   > Files of type

      (All Files(*.*) button)

      > VRML or STL

          > Options

             > STL/VRML

     > SLDXML

         > Options

            > SLDXML

      > type of file

         > Options

            > General

      > IDF

         > Options

            > IDF
 

> Save As

     > Save as type:

        > Part (assemblies only)

        > Parasolid or Parasolid

           Binary

           > Save

               > Export (sheet

                  metal parts only)

        > IGES

           > Options

               > IGES 5.3

        > STEP (AP203 or AP214)

           > Options

               > STEP

        > IFC 2x3

            > Options

               > IFC

        > ACIS

            > Options

                > ACIS

        > VDAFS

            > Options

                > VDA

        > VRML

            > Options

                > VRML

        > STL

           > Options

                > STL/AMF

       > Additive Manufacturing
          File (*.amf)

          > Options

             > STL/AMF

       > eDrawings

           > Options

               > EDRW/EPRT/EASM

       > Adobe Portable

          Document Format

           > Options

                > PDF

       > Adobe Photoshop Files

          > Options

                > TIF/PSD/JPG/PNG

       > JPEG

          > Options

                > TIF/PSD/JPG/PNG

       > Dwg or Dxf

          (drawings only)

             > Options

                 > DXF/DWG

        > Tif

             > Options

                > TIF/PSD/JPG/PNG

> Page Setup

     > Print

          > Margins

> Print

 

Does not appear on a menu:

    Line Thickness

 

> Display

> Modify

> Hide All Types

> Planes

> Live Section Planes

> Axes

> Temporary Axes

> Origins

> Coordinate Systems

> Curves

> Sketches

> Top Level Annotations

> Component Annotations

> Dimension Names

> Routing Points

> Lights

> Cameras

> Simulation Symbols

> Sketch Relations

> Zone Lines

Back to top

System Options and Document Properties Get/Set Methods

System Options

Document Properties

 

Back to top



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   System Options and Document Properties
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: API Help (English only) 2015 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.