Hide Table of Contents

Assigning Revision Numbers to Workflow States

You can assign revision numbers to workflow states so that revision numbers are set on files or items only in certain states, such as Approved. Typically, you assign revision numbers to workflow states as part of setting up automatic revision numbers. However, users with sufficient rights can also set revision numbers manually.

To assign a revision number to a workflow state:

  1. Expand Workflows and double-click the workflow to open it.
  2. In the workflow editor, click the workflow state that will use revision numbers.

    The Properties dialog box for the workflow state opens.

  3. On the upper-left side of the Revision Numbers tab, expand the State revision number list and select the revision number to use.
    If your revision number is not listed, you probably had the workflow open when you created the revision number. Exit and re-open the workflow.

    The component counters of the selected revision number appear in the Name column.

  4. For each component, do one of the following:
    • To increment the counter, under Increment by, type the increment number (typically 1) .
    • To reset a counter, under Reset to, type the number to which you want the component set.

      The revision number that will be used for the component is shown in the Preview column.

    • To leave a counter unchanged, leave both Increment by and Reset to empty.
    For example, if using major and minor revision components, you might set the major component to increment by 1 and the minor component to reset to 1.
  5. Click OK to save the workflow state.
  6. Click Save or File > Save to save the workflow.
  7. To test the revision numbering, manually set the revision number on a file from SOLIDWORKS PDM Explorer View:
    1. Select a checked in file that is in the workflow state you just edited and select Modify > Set Revision .
      You must have sufficient rights to set revision numbers.
    2. In the Set Revision dialog box, confirm that the Current Revision column shows the current revision number and that New revision shows the appropriate revision number based on the revision increment you set for the state.
      Instead of using the next revision, you can click in the New Revision field to select a different revision number to set on the file.
    3. Click OK.
      The History dialog box, Explorer Version tab, and Get Version listing for this file should all show the new revision number.


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Assigning Revision Numbers to Workflow States
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS PDM 2016 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.