Hide Table of Contents

Split and Save Bodies PropertyManagers

Use the Split PropertyManager to divide parts into multiple bodies. You can use the Split PropertyManager to save the new bodies when you split the part or use the Save Bodies PropertyManager to save them after the split is complete.

Split PropertyManager

To use the Split PropertyManager to divide a part into multiple bodies:

  1. In a part, create a sketch to be used to cut the part into bodies.
  2. Click Split (Features toolbar) or Insert > Features > Split.
Trimming Surfaces Select entities to use to trim the part into multiple bodies.
  • Reference planes (Planes extend infinitely in all directions.)
   
  • Planar model faces (Faces extend infinitely in all directions.)
   
Original Part Revised Original Part New Part
   
  • Sketches (Sketches extrude through all in both directions.)
   
Original Part Revised Original Part New Part
   
  • Reference surfaces and non-planar model faces (These do not extend their boundaries. Internal holes on reference surfaces or non-planar model faces are closed when splitting the part.)
   
Original Part New Parts
  Cut Part Cuts the part into multiple bodies using the Trimming Tools geometry. Split lines appear on the part, showing the different bodies formed by the split.

(Appears in single body parts)

Callout boxes appear in the graphics area for up to 10 bodies at one time. Click Next 10 or Previous 10 to scroll through all the callout boxes for a part.

Target Bodies

Available in multibody parts.
  All bodies Trims all bodies that the Trimming Surfaces intersect when extended infinitely in all directions.
  Selected bodies Trims only selected bodies.
Solids or Surfaces to Split Sets which solid or surface bodies to split.

To split a surface, select the surface in the graphics area or the Surface Bodies folder in the FeatureManager design tree.

  Cut Bodies Cuts the selected bodies into multiple bodies using the Trimming Tools geometry. Split lines appear on the bodies, showing the different bodies formed by the split.

Resulting Bodies

Lists the split bodies in the part after you click Cut Part or Cut Bodies.

Select the bodies to save You can also click Auto-assign Names to name the bodies as Body< n >.sldprt and save them.
  File After you split the bodies, they are listed in the FeatureManager design tree under Solid Bodies. Double-click the body name under File, type a name for the new part in the dialog box, then click Save. The new part name appears under File and in the callout box. The bodies that you do not save are not split. They remain with the original part. You can also save bodies from a multibody part using the Save Bodies PropertyManager.
 
If you clear the check box for a split part after you save it, that part is no longer saved as a separate entity. It remains with the original part.
  Consume cut bodies Removes the body from the part. Consumed bodies are not listed in the FeatureManager design tree under Solid Bodies.
  Propagate visual properties Preserves the appearances that are applied to the bodies that are created when you save the part.
  Origin location Places the origin of the split body at the vertex you select.
  Copy custom properties to new parts Copies the custom properties of solid bodies to new parts you create.
  Copy cut list properties to new parts Copies the cut list properties of structural members to the bodies that are created when you split a weldment part.

File properties

Transfers the cut list properties to the file properties of the derived part.

Only available if Copy custom properties to new parts is cleared.

Cut list properties

Transfers the cutlist properties to the cut list properties of the new part.

Template Settings

Lets you override the default template from Tools > Options > System Options > File Locations.

Override default template settings Specifies to use an alternate template. The selected template is applied to all new part or assembly files you create during the current Split or Save Bodies operation.
Part template Lists the selected part template. Click Browse (...) to browse to a different template.

Save Bodies PropertyManager

To use the Save Bodies PropertyManager to save bodies after a part has been split:

  • Click Insert > Features > Save Bodies.
Select the parts to save. You can also click Auto-assign Names to generate part names automatically.
  File Lets you save parts from a multibody part.
  Consume cut bodies Removes the body from the part. Consumed bodies are not listed in the FeatureManager design tree under Solid Bodies.
  Propagate visual properties Preserves the appearances that were applied to the bodies that were created when you saved the part.
  Origin location Places the origin of the split body at the vertex you select.

Create Assembly

  Assembly path and name is displayed after you browse to a location for the assembly.
Browse Opens the Save as dialog box with .sldasm as the file type.
Derive resulting parts from similar bodies or cut list Identical bodies, for example weldment structural members, are saved as a single part.

The assembly is created with multiple instances of the part.

Bodies must have identical material properties to be instanced in this way.

Template Settings

Lets you override the default template from Tools > Options > System Options > File Locations.

Override default template settings Specifies to use an alternate template. The selected template is applied to all new part or assembly files you create during the current Split or Save Bodies operation.
Part template Lists the selected part template. Click Browse (...) to browse to a different template.
Assembly template Lists the selected assembly template. Click Browse (...) to browse to a different template.


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Split and Save Bodies PropertyManagers
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2016 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.