Hide Table of Contents

File Explorer

The File Explorer tab in the Task Pane duplicates Windows Explorer from your local computer and displays the following directories:

  • Recent Documents
  • Open in SOLIDWORKS
If Workgroup PDM is added in, the tab changes to tab_File_Explorer_PDMWorks.gif.
You can specify whether to show the following folders:
  • My Documents
  • My Computer
  • My Network Places
  • Recent Documents (duplicates the list that appears when you click File > Open Recent.)
  • Hidden referenced documents
  • Samples (for SOLIDWORKS Tutorials and What's New examples)

Open in SOLIDWORKS

  • Files in bold have been modified since they were last saved.
  • Files in orange are read-only.
  • The icon for files open in SOLIDWORKS is solid. The icon for referenced components that are in memory but not open in SOLIDWORKS is transparent.

Working with File Explorer Contents

You can drag documents from the File Explorer into the graphics area.

Tooltips on files in the File Explorer display the file name, path, date modified, and size. For documents with models, such as SOLIDWORKS and AutoCAD documents, a preview of the model is also displayed in the tooltip.

You can view models and their configurations in a Preview Window.

Ctrl+C and Ctrl+V both copy files and folders in SOLIDWORKS File Explorer.

Showing or Hiding Folders in File Explorer

To show or hide folders in File Explorer:

  1. Click Options Tool_Options_Standard.gif (Standard toolbar) or Tools > Options and select File Explorer.
  2. Select or clear the folder names, then click OK.
All folders are shown by default when collaboration settings are accepted when Workgroup PDM is added in.

Displaying or Hiding Referenced Components in File Explorer

You can display or hide referenced components in Open in SOLIDWORKS. For assemblies, selecting this option displays component files that are in memory but not open in SOLIDWORKS.

To display or hide referenced components:

Do one of the following:
  • Right-click Open in SOLIDWORKS and select or clear Show hidden referenced documents.
  • Click Tools > Options > System Options > File Explorer and select or clear Hidden referenced documents.

Previewing Models from the File Explorer Tab

Preview models on the File Explorer tab in the Task Pane. You can select configurations, and you can leave the window open to view additional models.

To preview models:

  1. In the Task Pane, select the File Explorer tab .
  2. Right-click a file and select Preview Window.
  3. In the dialog box, select a configuration in Config.
    The model appears in Document preview. The document path and file name appear (read-only) in Document.

Refreshing the File Explorer View

To refresh the File Explorer view:

  1. In the Task Pane, select the File Explorer tab .
  2. Right-click anywhere in the pane and select Refresh View.


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   File Explorer
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS 2016 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.