Hide Table of Contents

Client Overview

The client enables users to check documents in and out of the vault, increment revision and lifecycle status, and generate reports.

To use the client, the vault administrator must have issued you an account with a user name and password (which are usually not the same as your Windows user name and password). To check documents into a project in the vault, you must have write permission for the project. The vault administrator creates projects and sets permissions on the Project tab of the VaultAdmin.

You can access the client from inside SOLIDWORKS (SOLIDWORKS Workgroup PDM for SOLIDWORKS client) or within SOLIDWORKS Explorer (SOLIDWORKS Workgroup PDM Contributor).

Workgroup PDM for SOLIDWORKS Client

The Workgroup PDM for SOLIDWORKS client is also referred to as the SOLIDWORKS client.

To use the SOLIDWORKS client, you must add it in.

  1. Click Tools > Add-Ins.
  2. In the Add-Ins dialog box, locate SOLIDWORKS Workgroup PDM version.
    • To load Workgroup PDM for the current session, select the check box under Active Add-ins
    • To load Workgroup PDM for every Solidworks session, select the check box under Start Up.

The SOLIDWORKS client is integrated into the File Explorer tab in the SOLIDWORKS Task Pane. The tab is split into the local view (upper pane) and vault view (lower pane), with tools for Find/Search, Document Information, Reporting, and Refresh above the vault view.

To access the context-sensitive menus, right-click in the local view or vault view.

A Workgroup PDM toolbar contains commonly-used commands.

Quick Reference

The following topics serve as quick references for project and document status:

Batch Printing

You can schedule batch printing of documents with the Print Workgroup PDM Files operation in the SOLIDWORKS Task Scheduler.

Compare Documents

You can compare documents in the Workgroup PDM vault, including comparing different revisions of the same document with SOLIDWORKS utilities.

Workgroup PDM Contributor

The Workgroup PDM Contributor is also referred to as the SOLIDWORKS Explorer client.

To open the Workgroup PDM Contributor in SOLIDWORKS Explorer:

  1. Click Start in Windows and select All Programs > SOLIDWORKS version > SOLIDWORKS Explorer version.
  2. In SOLIDWORKS Explorer, click Options .
  3. In the Options dialog box, on the Add-Ins tab, select SOLIDWORKS Workgroup PDM.
    If you do not have a license, the option says Workgroup PDM - requires license, and the option is unavailable.
To access the SOLIDWORKS Explorer client context-sensitive menus, right-click in the local view or vault view. When you select an item, the Mini Toolbar shows commonly-used tools that you can use with the selected document.

You cannot check SOLIDWORKS documents into the vault and you can only check SOLIDWORKS documents out of the vault if the SOLIDWORKS software is installed. However, you can perform the following operations:

  • Open any document
  • Check in non-SOLIDWORKS documents
  • Modify document properties
  • Bump a document's revision
  • Change a document's lifecycle status


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Client Overview
*Comment:  

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS Workgroup PDM 2017 SP03

The search functionality within the web help is in a beta test phase and you may experience periodic delays or interruptions in its performance. These are the normal and ordinary features of a beta test and shall not under any circumstances give rise to any liability on the part of Dassault Systèmes SolidWorks Corporation or its licensors. The topics within the Web-based help are not beta topics; they document SOLIDWORKS Workgroup PDM 2017 SP03.

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.