Hide Table of Contents

Copy Tree Dialog Box

The Copy Tree dialog box lets you copy a parent file with all its references to create a second instance unrelated to the original.

If your administrator has excluded a folder from copy, a warning appears in the Warnings column and the Copy option is unavailable.

To display the dialog box:

Select the parent file and click Tools > Copy Tree.

The Copy Tree options include the following:

Default Destination

Displays the current folder location of the selected file. You can enter a new path or browse to specify the destination path.

Settings

This group is a collapsible interface that includes:

Version to Use Latest Copies the latest versions.
Referenced Copies the referenced versions.
Copy Type Files Copies the selected files to the Destination folder.
Compressed Archive Copies the selected files to the archive file.
When you select this option:
  • Preserve relative paths, Regenerate serial number in cards, and Name drawings after their models options are unavailable.
  • Destination Folder Path and Target File Name columns are cleared.
If the archive file is in the vault and you have not configured a Zip program using the Local Settings section of the Administration tool, a warning appears in the Warnings column and the Copy option is unavailable.

SOLIDWORKS PDM supports 7-zip and WinZip. For details, see Configuring 7-zip as Copy Tree Compressed Archive Program in the Administration Tool Help.

Options Include simulation Copies SOLIDWORKS Simulation results associated with the selected files.
Preserve relative paths Keeps the paths of references relative to the copied parent file, creating a folder structure as needed. When you clear Preserve relative paths, the folder hierarchy is flattened and all referenced files are copied to the same destination folder as the parent.
Include drawings Shows any related drawing files in the file list so you can include them when copying the reference tree.
Regenerate serial number in cards If serial numbers are used in data cards, assigns the next number in the sequence. For Rename with serial number transformations, the same serial numbers used to name the files are used in data cards.
Name drawings after their models Sets drawing file names to the same as their associated assembly or part file names.

Transform Operations

Modifies the file names of selected files using the transformation you select.
Transformations other than Rename with Serial Number are cumulative. For example, you can add both a prefix and a suffix.
Add Prefix Adds the prefix you type to the file names.
Add Suffix Adds the suffix you type to the file names.
Rename with serial number Replaces file names with serial numbers.
Only available if serial numbers have been defined in the SOLIDWORKS PDM Administration tool.
You can also right-click files in the file list and select Rename with Serial Number and the serial number to use. If all selected files have the same serial number defined in the SOLIDWORKS Add-in, that serial number is bold and is first in the list.
Replace Replaces strings in file or folder names.
In the Replace dialog box:
  1. For Find what, type the string to replace.
  2. For Replace with, type the replacement string.
  3. Select whether to apply the change to all files or only the selected files.
  4. Select to apply the change to file names, folder names, or both.

Filter Display

Lets you enter text to refine the list of files displayed. A column selection drop-down lets you limit the filtering to a specific column, for example, File name, or for All Columns.

By default, the filter is applied to All Columns. You can expand the All Columns list and select a specific column to apply the filter to. The software searches for the text that you enter, displays rows that contain the text, and highlights the text for easy identification.

The search field supports these wildcard characters: *, ?, %, -, ., "".
*string Displays rows that contain text that ends with the string. The string in the filtered rows is highlighted in pink.
string* Displays rows that contain text that starts with the string. The string in the filtered rows is highlighted in pink.
Instead of *, you can use ? or %.
-string or string- Displays rows that contain the string.
If the hyphen is at the beginning, the text ending with the string is highlighted in pink. If the hyphen is at the end, the text starting with the string is highlighted.
"string" Displays rows that contain the string. The string in the filtered rows is highlighted in pink.
.string or string. Displays rows that contain the string and highlights the string with a preceding or a succeeding character depending on the position of the dot.

The filter options include:

Invert filter or ! You can invert the filter by clicking or by entering the ! character as a prefix to the text in the search field.

Files that do not include the entered text are displayed.

Filter
  • File Type
    • Assemblies
    • Parts
    • Drawings
    • Others
  • Selected For Copy
    • Yes, Selected
    • No, Not Selected
  • Name/Path Changed
    • Yes, Changed
    • No, Not Changed

When you apply filter, an icon with the X symbol appears. Click the icon to clear the filter.

All Columns Filters the file list based on the text you enter and the column you select. You can select one of the following columns:
  • File name
  • Warnings
  • Version
  • Checked out by
  • Checked out in
  • Found in
  • Destination Folder Path
  • Target File Name
  • State
This filter supports all custom columns that appear in the file list.
Clear All Removes all filters. This appears when you select an option in Filter.

Toolbar Buttons

EPDM_next_warning EPDM_previous_warning Next Warning / Previous Warning

In the file list, changes the focus to the next file with a warning or the previous file with a warning.

Contains_show_one_or_all_levels Levels Displays file references for the entire file hierarchy (Show All Levels) or just the top level of the file hierarchy (Top Level Only).

The setting defaults to the most recent setting you used.

You can also expand or collapse the hierarchy using the EPDM_expanded_arrow and EPDM_collapsed_arrow controls in the File name column.

Open File List Open All opens a list of files in Microsoft Excel.
Open Visible opens a list of visible files in Microsoft Excel.
Save File List Export All exports the list of all files as a comma-separated .txt file.
Export Visible exports the list of visible files as a comma-separated .txt file.

File List

Use the file list to:
  • Select the files to copy.
  • Select files to rename using transforms.
  • Verify new file names and paths.

To change the columns that are displayed, right-click any column heading and select columns to display them or clear columns to hide them. You can add up to 10 columns based on SOLIDWORKS PDM variables by clicking More and choosing variables from the Choose Columns dialog box.

You can sort the default and custom columns in tables in ascending, descending, or default order by clicking column headers. Column sorting is useful within large datasets. If you sort a column in ascending or descending order, the column is highlighted in green and an arrowhead appears. When you sort a column in a table, SOLIDWORKS PDM removes the file structure hierarchy. Sorting turns off Show Tree Lines and Show Reference Selection Control.

Drag a column head to change the position of a column.

Type Displays a thumbnail preview of the file when you hover over the file type icon.
File name

Displays selected files and files referenced by them. For assemblies, the list can include drawings, parts, subassemblies, and SOLIDWORKS Simulation files.

The related drawings can be in the current folder or in a folder elsewhere in the vault. By default, SOLIDWORKS PDM checks the entire vault for related drawings. The scope of the search depends on administrative settings.
Warnings Displays the warnings such as Target file already exists, Outside of the vault, or The file is not rebuilt can block a check in if your administrator has configured blocking for warnings.
Until you specify a new default destination, the warning Target file already exists appears because the Default Destination and Destination Folder Path are same by default.
You can click the warning The file is not rebuilt to display a list of references that require a rebuild.
To quickly locate files with warnings or errors, use the Next Warning EPDM_next_warning and Previous Warning EPDM_previous_warning toolbar buttons or Ctrl + the up-arrow or down-arrow on the numeric keypad.
Copy Lets you select files to copy.
Version The first number is the local (cached) version, or a hyphen (-) if locally modified. The second number is the latest version in the vault.

For example, 4/6 means version 4 of 6.

Checked out by User who has the file checked out, or blank if not checked out. You can only check in files that you have checked out.

If you hover over a user name, a pop-up window displays user information such as log in status, number of files checked out, and a link to email the user.

Checked out in Computer and local folder where the file is checked out, or blank if not checked out.
Found in Vault folder containing the file.
Destination Folder Path Displays the path that you specify in the Default Destination field. You can edit it to change the destination of a copied file.
When you hover over the destination folder path, the button lets you choose a new destination for the copied file.
Target File Name Displays the target file name after the copy.

For example, if you use transformations to rename files, the new name is displayed.

You can edit the name of the target file.

Check-in on Copy

Checks in files on copying.

You can optionally enter the check-in comments.

Total to Copy

Displays the number and type of files you have selected for copying.
The warning indicates that other files are selected for copy but do not appear in the file list because of the current filter.

Reset All

Resets all transform operations settings to the defaults.

Shortcut Menu Options

Right-click in the file list to access these menu options:

Columns Lists column heads so you can display or hide columns.

Currently displayed columns are indicated by a check mark.

Click More to open the Choose Columns dialog box, where you can add up to 10 additional columns by selecting SOLIDWORKS PDM variables on which to base column heads.

Show Reference Selection Controls For files with references (such as assemblies with parts), turns on a second check box to the right of parent files.

Use the left check box to select or clear only the parent file.

Use the right check box to select or clear the parent file and all of its references.

If all check boxes are not in the same state, the added check box displays workflow_box_inherited.gif.

Select All Selects all files, so that you can check or clear the Copy column.
Select Files Displays a dialog box where you can specify wildcards to select a group of files. You can then use a single keystroke to check or clear the files in the Copy column.
Show Tree Lines Adds tree lines to the File name column.
Change Thumbnail Preview Size Changes the size of thumbnail previews as Small, Medium, or Large. By default, Medium is selected.
When you select the size in one table, SOLIDWORKS PDM sets the same size in applicable tables and on tabs. The thumbnail previews for non-SOLIDWORKS files may not be clear when you select Medium or Large.
Copy All Files Selects all files in the Copy column.
Uncheck All Clears all files in the Copy column.


Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Copy Tree Dialog Box
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: SOLIDWORKS PDM 2017 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.