Welcome
Collapse Getting StartedGetting Started
Overview
Expand Types of SOLIDWORKS API ApplicationsTypes of SOLIDWORKS API Applications
Expand SOLIDWORKS API Object Model and Class HierarchySOLIDWORKS API Object Model and Class Hierarchy
Collapse Programming with the SOLIDWORKS APIProgramming with the SOLIDWORKS API
Expand Add-insAdd-ins
API Dependent on SOLIDWORKS Being Visible
Arrays
Attributes Imported from ACIS SAT Files
Bitmasks
Block Definitions and Block Instances
Bodies in Body Folders
BOOL and VARIANT_BOOL
Bounding Box and Note Text
COM vs. Dispatch
CommandManager and CommandGroups
Components, Configurations, and Suppression States
Compound Note
ComVisibleAttribute in VB.NET and C# Macros and Add-ins
Controls, Visual Basic 6.0, and Windows XP
Default Paths
Drawing Views and Model Entities
Early and Late Binding
Expand EventsEvents
Features of Components
Helper Functions
Hole Wizard Features and Objects
IDispatch Object Arrays as Input in .NET
Implementation Guidelines
Import and Export File Options
In-process Methods
Instantiate ActiveX Controls as Tabs
Interface Pointers
ISafeArrayUtility Interface Overview
Keystrokes and Accelerator Keys
Library Features and Objects
Lightweight Components
Line Attributes for View::GetPolyLinesAndCurves
Line Weights
Long vs. Integer
Expand Macro FeaturesMacro Features
Manipulators
Mass Properties
Expand Multibody PartsMultibody Parts
Option Explicit Statement
Expand Packing and Unpacking Double Arrays and Integer PairsPacking and Unpacking Double Arrays and Integer Pairs
Partition Rollback and API Handles
Persistent Reference IDs
Presentation Transforms
Expand PropertyManager PagesPropertyManager Pages
.NET Interop Assemblies
Quick Tips and Bubble ToolTips
Return Values
Expand SafeArraysSafeArrays
Selection Criteria
Selection Lists
Selections that Define Features
Setup Project to Distribute SOLIDWORKS Add-in
Smart Pointers
SOLIDWORKS Add-ins
SOLIDWORKS Objects
Sorting Tables
Splines
SQLite
STL Container Classes and Smart Pointers
Suspend Automatic Rebuilds
Sweep Features and SweepFeatureData Objects
System Options and Document Properties
Tessellation and Edges
Third-party Data in SOLIDWORKS Files
Thread Features and ThreadFeatureData Objects
Tracking IDs
Expand Type LibrariesType Libraries
Units
Unmanaged C++ and C++/CLI Code
VBA and SOLIDWORKS x64
Examples and Projects
Expand SOLIDWORKS API HelpSOLIDWORKS API Help
Expand SOLIDWORKS PDM Professional API HelpSOLIDWORKS PDM Professional API Help
Expand FeatureWorks API HelpFeatureWorks API Help
Expand SOLIDWORKS Costing API HelpSOLIDWORKS Costing API Help
Expand SOLIDWORKS Document Manager API HelpSOLIDWORKS Document Manager API Help
Expand SOLIDWORKS Routing API HelpSOLIDWORKS Routing API Help
Expand SOLIDWORKS Simulation API HelpSOLIDWORKS Simulation API Help
Expand SOLIDWORKS Sustainability API HelpSOLIDWORKS Sustainability API Help
Expand SOLIDWORKS Toolbox API HelpSOLIDWORKS Toolbox API Help
Expand SOLIDWORKS Utilities API HelpSOLIDWORKS Utilities API Help
Expand eDrawings API HelpeDrawings API Help
Hide Table of Contents

System Options and Document Properties

You can get and set SOLIDWORKS system options and document properties (also called user preferences) using SOLIDWORKS API enumerators and methods.

To determine which enumerator corresponds with which system option or document property, you can:

  • change a system or document setting in the user interface while recording a macro. Then edit the macro to identify the name and value of the enumerator that corresponds to the setting you just changed and to also identify the name of the method used to change (i.e., set) it. See the System Options and Document Properties Get/Set Methods table in this topic for a list of methods that get and set system-option and document-property enumerators.

    - or -

  • locate the system option or document property in the SOLIDWORKS user interface and click the link that corresponds to it in the Settings and Enumerators table in this topic. Each link opens a topic that contains a:

    • screen shot of the user-interface dialog or menu corresponding to that system option or document property.

    • table containing all of the settings for that system option or document property and the enumerator and methods that get or set it.

Remember to reset any option or property back to its original state after the operation completes. System-option settings persist across SOLIDWORKS sessions.

Settings and Enumerators

NOTE: Unlinked text indicates that an enumerator does not exist for that system option, document property, manager pane option, or menu item. Unlinked text is shown to help you more easily map the text in the table with the text shown on the specified tabs, manager panes, toolbars, and menus in the user interface.
 

Tools > Options > System Options tab

Tools > Options > Document Properties tab

File menu

View menu

 

Insert menu

 

Tools menu

 

Window menu

Toolbars

Appears on tab:

General

Drawings

 - Display Style

 - Area Hatch/Fill

 - Performance

Colors

Sketch

 - Relations/Snaps

Display

Selection

Performance

Assemblies                                                       

External References

Default Templates

File Locations

FeatureManager

Spin Box Increments

View

Backup/Recover

Touch

Hole Wizard/Toolbox

File Explorer

Search

Collaboration

Messages/Errors/Warnings

Import

Export

 

Does not appear on tab:

Miscellaneous

Appears on tab:

Drafting Standard

Annotations

  - Balloons

  - Datums

  - Geometric

     Tolerances

  - Location Label
    (drawings only)

  - Notes

  - Revision Clouds

  - Surface

     Finishes

  - Weld Symbols

Borders (drawings only)

Dimensions

  - Angle

  - Angular Running

  - Arc Length

  - Chamfer

  - Diameter

  - Hole Callout

  - Linear

  - Ordinate

  - Radius

Virtual Sharps (parts and drawings only)

Centerlines/Center Marks (drawings only)

DimXpert (drawings only)

Tables

 - Bend (drawings only)

 - Bill of Materials

 - General

 - Hole (drawings only)

 - Punch (drawings only)

 - Revision (drawings only)

 - Title Block Table (parts and assemblies only)

 - Weld (drawings only)

DimXpert (parts only)

 - Size Dimension

 - Location Dimension

 - Chain Dimension

 - Geometric Tolerance

 - Chamfer Controls

 - Display Options

Views (drawings only)

 - Auxiliary

 - Detail

 - Section

 - Orthographic

 - Other

Detailing

Drawing Sheets (drawings only)

Grid/Snap

Units

Line Font (drawings only)

Line Style (drawings only)

Line Thickness (drawings only)

Model Display (parts and assemblies only)

Material Properties (parts only)

Image Quality

Sheet Metal

Weldments

Plane Display (parts and assemblies only)

Configurations (parts and assemblies only)

      Mates (assemblies
      only)

Does not appear on tab:

- Miscellaneous

> Open

   > Files of type

      > Mesh Files

         > Options

            > System Options

                > Import

                    > STL/OBJ/OFF/PLY/PLY2

      > VRML

         > Options

             > System Options

                > Import

                    > VRML

      > 3MF

         > Options

             > System Options

                > Import

                    > 3D Manufacturing Format

 

      > IDF

         > Options

             > System Options

                > Import

                    > IDF

 

      > Inventor/Catia V5/Creo/NX/Solid Edge

         > Options

             > System Options

                 > Import

                     > Inventor/Catia V5/Creo/NX/Solid Edge

     

       > STEP/IGES/ACIS

          > Options

             > System Options

                 > Import

                     > STEP/IGES/ACIS

 

      > other type of file

         > Options

             > System Options

                 > Import

                     > General

> Save As

     > Save as type

        > Parasolid or Parasolid Binary

           > Options

               > System Options

                   > Export

                       > Parasolid

           > Save

               > Export (sheet

                  metal parts only)

        > IGES

           > Options

               > System Options

                   > Export

                       > IGES 5.3

        > STEP (AP203 or AP214)

           > Options

               > System Options

                   > Export

                       > STEP

        > IFC 2x3 or IFC 4

           > Options

               > System Options

                   > Export

                       > IFC

        > ACIS

           > Options

               > System Options

                   > Export

                       > ACIS

        > VRML

           > Options

               > System Options

                   > Export

                       > VRML

        > STL

           > Options

               > System Options

                   > Export

                       > STL

        > 3D Manufacturing Format (*.3mf)

           > Options

               > System Options

                   > Export

                       > 3MF

        > Additive Manufacturing File (*.amf)

           > Options

               > System Options

                   > Export

                       > AMF

        > eDrawings

            > Options

                > System Options

                    > Export

                        > EDRW/EPRT/EASM

        > Adobe Portable Document Format

            > Save as 3D PDF

                > Options

                    > System Options

                         > Export

                             > 3DPDF

            > Options

                > System Options

                    > Export

                        > PDF

        > Adobe Photoshop Files, Portable Network Graphics, JPEG, or Tif

           > Options

               > System Options

                   > Export

                        > TIF/PSD/JPG/PNG

        > Dwg or Dxf

           (drawings only)

           > Options

               > System Options

                   > Export

                       > DXF/DWG

> Page Setup         

> Print

    > Margins 

    > Line Thickness

> Print3D

> Publish to eDrawings

 

> Display

> Modify

   > Filter Modified Components (only for assemblies opened in Large Design Review mode with one or more modified components)

> Hide / Show

> User Interface

> Mate (assemblies only)

 

> Component Selection (assemblies only)

   > Select Identical Components

> Sketch Entities

   > Corner Rectangle or Center Rectangle or 3 Point Corner Rectangle or 3 Point Center Rectangle or Parallelogram

> Customize

   > Toolbars

   > Mouse Gestures

 

> Viewport

Sketch Ink

Back to top

System Options and Document Properties Get/Set Methods

System Options

Document Properties

 

Back to top



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   System Options and Document Properties
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: API Help (English only) 2018 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.