Hide Table of Contents

System Options > Import > 3MF

To display the dialog:

Select Tools > Options > System Options > Import > File Format > 3MF.

- or -

  1. Select File > Open.
  2. In Files of type, select 3D Manufacturing Format.
  3. Click Options.

 

Setting

Get/Set Methods

Return Value
or
<Value>
or
<OnFlag>

Comment

Import as - Graphics body

ISldWorks::GetUserPreferenceIntegerValue(swUserPerferenceIntegerValue_e.swImportStlVrmlModelType) ISldWorks::SetUserPreferenceIntegerValue(swUserPerferenceIntegerValue_e.swImportStlVrmlModelType, swImportStlVrmlModelType_e.swImportStlVrmlModelType_Graphics)

swImportStlVrmlModelType_e.swImportStlVrmlModelType_Graphics

 

Import as - Solid body

ISldWorks::GetUserPreferenceIntegerValue(swUserPerferenceIntegerValue_e.swImportStlVrmlModelType) ISldWorks::SetUserPreferenceIntegerValue(swUserPerferenceIntegerValue_e.swImportStlVrmlModelType, swImportStlVrmlModelType_e.swImportStlVrmlModelType_Solid)

swImportStlVrmlModelType_e.swImportStlVrmlModelType_Solid

 

Import as - Surface body

ISldWorks::GetUserPreferenceIntegerValue(swUserPerferenceIntegerValue_e.swImportStlVrmlModelType) ISldWorks::SetUserPreferenceIntegerValue(swUserPerferenceIntegerValue_e.swImportStlVrmlModelType, swImportStlVrmlModelType_e.swImportStlVrmlModelType_Surface)

swImportStlVrmlModelType_e.swImportStlVrmlModelType_Surface

 

Mesh body options - Create mesh bodies bounded by single faces

ISldWorks::GetUserPreferenceToggle(swUserPreferenceToggle_e.swVrmlStlImportAsPSMesh)

ISldWorks::SetUserPreferenceToggle(swUserPreferenceToggle_e.swVrmlStlImportAsPSMesh, <OnFlag>)

Boolean value

Valid only when importing as Solid  body or Surface body, specifies whether to create mesh bodies bounded by single faces

Mesh body options - Group facets into faces

ISldWorks::GetUserPreferenceToggle(swUserPreferenceToggle_e.swIVrmlStlImportSegmented)

ISldWorks::SetUserPreferenceToggle(swUserPreferenceToggle_e.swIVrmlStlImportSegmented, <OnFlag>)

Boolean value

Valid only if Create mesh bodies bounded by single faces is selected, specified whether to group facets into faces

Unit

ISldWorks::GetUserPreferenceIntegerValue(swUserPerferenceIntegerValue_e.swImportStlVrmlUnits) ISldWorks::SetUserPreferenceIntegerValue(swUserPerferenceIntegerValue_e.swImportStlVrmlUnits, swLengthUnit_e.<Value>)

Valid options from swLengthUnit_e:

  • 0 = swMM (millimeters)   

  • 1 = swCM (centimeters)  

  • 2 = swMETER

  • 3 = swINCHES

  • 4 = swFEET

 

 



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   System Options > Import > 3MF
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: API Help (English only) 2018 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.