Hide Table of Contents

Viewing and Modifying Solid Properties

Use the Properties palette to view and modify solid properties.

To view and modify properties using the Properties palette:

  1. Click Modify > Properties (or type Properties).
  2. In the graphics area, select one or more solids.

    The Properties palette displays the solid properties including the data that define the geometry.

    • If you selected no solid or other entity, the palette displays only general solid properties (Layer, LineColor, LineScale, LineStyle, LineWeight, Transparency, and Hyperlink).
    • If you selected only one solid, you can modify any property of the solid.
    • If you selected more than one solid, the palette displays those properties common to all selected solids, such as Layer, LineColor, LineScale, LineStyle, LineWeight, Transparency, and Hyperlink. If the common properties are not identical in all of the selected entities, the corresponding drop-down list or field in the palette displays <<Varies>>.
  3. Update the properties of the selected entities by clicking the drop-down lists or entering new values.

  Note: You can drag the Properties palette to create a separate window or anchor it to the left or right of the graphics area. Also, you can use other Properties palette display options to increase the graphics area.

Solid Properties

The Properties palette groups the parameters in the following categories:

General

Groups the general solid properties (Layer, LineColor, LineScale, LineStyle, LineWeight, Transparency, and Hyperlink).

Solid History

Controls the display of solids that form the composite solid or the components that have been removed.

For a composite solid, you can choose to record the sub components that have been removed from the solid.

Geometry

Displays the data defining the solid geometry. The set of parameters varies according to the solid type.

Use the parameters to modify the dimensions and modify the shape of primitive solids.

Examples:

  • To change a cone to a frustum, set the Top radius property.
  • To change the number of sides of a pyramid, set the Sides property.

Access

Command: Properties

Menu: Modify > Properties



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Viewing and Modifying Solid Properties
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2019 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.