Hide Table of Contents

Discarding Duplicate Entities

Use the DiscardDuplicates command to remove duplicate entities or overlapping segments of entities from the drawing. The command creates single entities from adjacent or partially overlapping entities.

You can set specific options to examine and process Lines, Arcs, and PolyLines.

For example, the command resolves geometry redundancies:

  • Discarding duplicate copies of entities.
  • Combining partially overlapping Lines drawn at the same angle into a single Line.
  • Removing Arcs that overlap portions of Circles.
  • Removing duplicate Line or Arc segments that overlap PolyLines.

To discard duplicate entities:

  1. Click Modify > Discard Duplicates (or type DiscardDuplicates).
  2. In thre graphics area, select the entities to examine.
  3. Press Enter.
  4. In the dialog box, under Ignore entity properties, select or clear properties to ignore during comparison (Layer, LineColor, LineStyle, LineScale, LineWeight, PrintStyle, Thickness, or Transparency).
  5. In the dialog box, under Options, set options regarding Lines, Arcs, and PolyLines:
    • Remove polyline duplicate vertices and segments. Examines each vertex and each linear and curved segment of selected PolyLines and removes duplicate vertices and segments. Also, if a PolyLine segment duplicates a Line or Arc, one of the entities is deleted.

      If you select this option, specify additional options:

      • Ignore polyline segments width. Ignores the segment widths of PolyLines.
      • Do not split polyline. PolyLines are not split.
    • Combine overlapping entities into a single one. Creates a single entity from entities that partially overlap.
    • Combine collinear entities aligned end to end. Creates a single entity from entities that have common endpoints.
    • Do not modify associative entities. Leaves associative entities unchanged (such as the boundary entities of Hatches or the defining entities of Dimensions).
  6. Click OK.

    A message reports the number of entities that were removed or combined.

  Note: The software saves these settings.

Access

Command: DiscardDuplicates

Menu: Modify > Discard Duplicates



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Discarding Duplicate Entities
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2019 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.