Hide Table of Contents

Browsing Recent Documents

You can browse recent documents and open them from the Recent Documents preview list.

In the Recent Documents browser, you can pin oftenly used files to create a set of favorite drawings.

To open a file from the Recent Documents browser:

  1. Click File > Preview Recent Documents (or type Recent).

    A preview list of the most recently opened drawings appears.

  2. Use the arrow keys or press Tab to select a document, or hover over a tile to select it.

    The preview highlights in the browser, and the file path for the document appears at the top of the browser.

  3. Press Enter or double-click to open the document.

    The selected drawing opens.

To pin or unpin a drawing on the Recent Documents browser:

  • Click Pin this document to the Recent Documents list  to keep a drawing permanently on the list.
  • Click Unpin this document from the Recent Documents list  to remove a pinned drawing from the list when you no longer need quick access to it.

To open the location of a drawing file from the Recent Documents browser:

  • Click Show in Folder  above a drawing preview to open the location of the drawing.

    The selected file is highlighted.

To close the Recent Documents browser:

  • Click outside the browser or press Esc.

  Note: To browse open drawings, press Ctrl+Tab repeatedly.

Access

Command: Recent

Menu: File > Preview Recent Documents

Keyboard Shortcut: F4

Keyboard Shortcut: F4



Provide feedback on this topic

SOLIDWORKS welcomes your feedback concerning the presentation, accuracy, and thoroughness of the documentation. Use the form below to send your comments and suggestions about this topic directly to our documentation team. The documentation team cannot answer technical support questions. Click here for information about technical support.

* Required

 
*Email:  
Subject:   Feedback on Help Topics
Page:   Browsing Recent Documents
*Comment:  
*   I acknowledge I have read and I hereby accept the privacy policy under which my Personal Data will be used by Dassault Systèmes

Print Topic

Select the scope of content to print:



x

We have detected you are using a browser version older than Internet Explorer 7. For optimized display, we suggest upgrading your browser to Internet Explorer 7 or newer.

 Never show this message again
x

Web Help Content Version: 2019 SP05

To disable Web help from within SOLIDWORKS and use local help instead, click Help > Use SOLIDWORKS Web Help.

To report problems encountered with the Web help interface and search, contact your local support representative. To provide feedback on individual help topics, use the “Feedback on this topic” link on the individual topic page.